aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2023-01-14 18:31:49 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2023-01-14 18:38:23 +0000
commitf9ff6b1f784d8ee02c33343303fde91073e008ed (patch)
tree551bc9acff058cd2369a7d41ba1165d433304124
parentdde3b2b456c3a4bdd217d0bf3684231cc3724a0a (diff)
downloadports-f9ff6b1f784d8ee02c33343303fde91073e008ed.tar.gz
ports-f9ff6b1f784d8ee02c33343303fde91073e008ed.zip
dns/libpsl: Update to 0.21.2 and switch to Meson
* Switch to Meson (simplifies patching and is faster) * Drop IDN option, only allow IDNA2008 compatible libraries * Switch default library to (lib)ICU as its a more common dependency * Enable "make test" * Install psl-make-dafsa binary not just manpage * Modernize Makefile to follow Porters Handbook more closely Changelog: https://github.com/rockdaboot/libpsl/releases/tag/0.21.2 PR: 268544 Approved by: portmgr (maintainer timeout, 2+ weeks)
-rw-r--r--dns/libpsl/Makefile43
-rw-r--r--dns/libpsl/distinfo6
-rw-r--r--dns/libpsl/files/patch-Makefile.in20
-rw-r--r--dns/libpsl/files/patch-configure593
-rw-r--r--dns/libpsl/pkg-plist3
5 files changed, 22 insertions, 643 deletions
diff --git a/dns/libpsl/Makefile b/dns/libpsl/Makefile
index 17eb84dc9c2f..b5a00b907c8a 100644
--- a/dns/libpsl/Makefile
+++ b/dns/libpsl/Makefile
@@ -1,8 +1,7 @@
PORTNAME= libpsl
-PORTVERSION= 0.21.1
-PORTREVISION= 6
+DISTVERSION= 0.21.2
CATEGORIES= dns
-MASTER_SITES= https://github.com/rockdaboot/libpsl/releases/download/${PORTVERSION}/
+MASTER_SITES= https://github.com/rockdaboot/${PORTNAME}/releases/download/${DISTVERSION}/
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= C library to handle the Public Suffix List
@@ -13,38 +12,30 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= public_suffix_list>=0:dns/public_suffix_list
-USES= libtool localbase:ldflags pathfix pkgconfig python:build shebangfix tar:lz
+USES= localbase:ldflags meson pkgconfig python:build shebangfix tar:lz
-CONFIGURE_ARGS= --disable-man \
- --with-psl-file=${LOCALBASE}/share/public_suffix_list/public_suffix_list.dat \
- --with-psl-testfile=${LOCALBASE}/share/public_suffix_list/test_psl.txt
-GNU_CONFIGURE= yes
-INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
USE_LOCALE= en_US.UTF-8
SHEBANG_FILES= src/psl-make-dafsa
+TEST_TARGET= test
-OPTIONS_DEFINE= NLS
-OPTIONS_SINGLE= IDNA
-OPTIONS_SINGLE_IDNA= ICU IDN IDN2
-OPTIONS_DEFAULT=IDN2
-ICU_DESC= Use devel/icu (IDNA2008 UTS\#46 library)
-IDN_DESC= Use dns/libidn (IDNA2003 library)
-IDN2_DESC= Use dns/libidn2 (IDNA2008 library)
+MESON_ARGS= -Ddefault_library=both \
+ -Dpsl_file=${LOCALBASE}/share/public_suffix_list/public_suffix_list.dat \
+ -Dpsl_testfile=${LOCALBASE}/share/public_suffix_list/test_psl.txt
+
+OPTIONS_SINGLE= IDNA
+OPTIONS_SINGLE_IDNA= ICU IDN2
+OPTIONS_DEFAULT= ICU
+
+ICU_DESC= Use devel/icu (IDNA2008 UTS\#46 library)
+IDN2_DESC= Use dns/libidn2 (IDNA2008 library)
-ICU_CONFIGURE_ON= --enable-builtin=libicu --enable-runtime=libicu
ICU_LIB_DEPENDS= libicuuc.so:devel/icu
-IDN_CONFIGURE_ON= --enable-builtin=libidn --enable-runtime=libidn
-IDN_LIB_DEPENDS= libidn.so:dns/libidn \
- libunistring.so:devel/libunistring
-IDN_USES= iconv
-IDN2_CONFIGURE_ON= --enable-builtin=libidn2 --enable-runtime=libidn2
+ICU_MESON_ON= -Druntime=libicu
+IDN2_USES= iconv
IDN2_LIB_DEPENDS= libidn2.so:dns/libidn2 \
libunistring.so:devel/libunistring
-IDN2_USES= iconv
-NLS_CONFIGURE_ENABLE= nls
-NLS_USES= gettext
-NLS_USES_OFF= gettext-tools
+IDN2_MESON_ON= -Druntime=libidn2
.include <bsd.port.mk>
diff --git a/dns/libpsl/distinfo b/dns/libpsl/distinfo
index a3c665328c72..04b41c69ec42 100644
--- a/dns/libpsl/distinfo
+++ b/dns/libpsl/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1598622955
-SHA256 (libpsl-0.21.1.tar.lz) = 644375d557bb3b84c485df2dae98ee388fe1e11fb75230004e4b8623b3b833a9
-SIZE (libpsl-0.21.1.tar.lz) = 2003340
+TIMESTAMP = 1672063633
+SHA256 (libpsl-0.21.2.tar.lz) = aa3d706c452786d1345e094dae201cd36d81f03cf81d636d5cfc10d365907f17
+SIZE (libpsl-0.21.2.tar.lz) = 2039147
diff --git a/dns/libpsl/files/patch-Makefile.in b/dns/libpsl/files/patch-Makefile.in
deleted file mode 100644
index b4c1ee861c07..000000000000
--- a/dns/libpsl/files/patch-Makefile.in
+++ /dev/null
@@ -1,20 +0,0 @@
---- Makefile.in.orig 2020-07-18 11:10:31 UTC
-+++ Makefile.in
-@@ -90,8 +90,6 @@ PRE_UNINSTALL = :
- POST_UNINSTALL = :
- build_triplet = @build@
- host_triplet = @host@
--@ENABLE_GTK_DOC_TRUE@am__append_1 = docs/libpsl
--@ENABLE_GTK_DOC_FALSE@@ENABLE_MAN_TRUE@am__append_2 = docs/libpsl
- subdir = .
- ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
- am__aclocal_m4_deps = $(top_srcdir)/m4/ax_check_compile_flag.m4 \
-@@ -199,7 +197,7 @@ am__define_uniq_tagged_files = \
- ETAGS = etags
- CTAGS = ctags
- CSCOPE = cscope
--DIST_SUBDIRS = po include src tools docs/libpsl fuzz tests msvc
-+DIST_SUBDIRS = po include src tools fuzz tests msvc
- am__DIST_COMMON = $(srcdir)/Makefile.in $(srcdir)/config.h.in \
- $(srcdir)/libpsl.pc.in $(srcdir)/meson.build.in \
- $(top_srcdir)/build-aux/ar-lib $(top_srcdir)/build-aux/compile \
diff --git a/dns/libpsl/files/patch-configure b/dns/libpsl/files/patch-configure
deleted file mode 100644
index 1e37f14c049c..000000000000
--- a/dns/libpsl/files/patch-configure
+++ /dev/null
@@ -1,593 +0,0 @@
---- configure.orig 2020-07-18 11:10:31 UTC
-+++ configure
-@@ -677,18 +677,6 @@ ENABLE_MAN_FALSE
- ENABLE_MAN_TRUE
- XSLTPROC
- LIBPSL_DOCS
--GTK_DOC_USE_REBASE_FALSE
--GTK_DOC_USE_REBASE_TRUE
--GTK_DOC_USE_LIBTOOL_FALSE
--GTK_DOC_USE_LIBTOOL_TRUE
--GTK_DOC_BUILD_PDF_FALSE
--GTK_DOC_BUILD_PDF_TRUE
--GTK_DOC_BUILD_HTML_FALSE
--GTK_DOC_BUILD_HTML_TRUE
--ENABLE_GTK_DOC_FALSE
--ENABLE_GTK_DOC_TRUE
--HAVE_GTK_DOC_FALSE
--HAVE_GTK_DOC_TRUE
- GTKDOC_DEPS_LIBS
- GTKDOC_DEPS_CFLAGS
- HTML_DIR
-@@ -14865,518 +14853,6 @@ $as_echo "#define HAVE_DCGETTEXT 1" >>confdefs.h
-
-
- #
--# check for gtk-doc
--#
--
--
--
--
--
--
--
--
--if test "x$ac_cv_env_PKG_CONFIG_set" != "xset"; then
-- if test -n "$ac_tool_prefix"; then
-- # Extract the first word of "${ac_tool_prefix}pkg-config", so it can be a program name with args.
--set dummy ${ac_tool_prefix}pkg-config; ac_word=$2
--{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
--$as_echo_n "checking for $ac_word... " >&6; }
--if ${ac_cv_path_PKG_CONFIG+:} false; then :
-- $as_echo_n "(cached) " >&6
--else
-- case $PKG_CONFIG in
-- [\\/]* | ?:[\\/]*)
-- ac_cv_path_PKG_CONFIG="$PKG_CONFIG" # Let the user override the test with a path.
-- ;;
-- *)
-- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
--for as_dir in $PATH
--do
-- IFS=$as_save_IFS
-- test -z "$as_dir" && as_dir=.
-- for ac_exec_ext in '' $ac_executable_extensions; do
-- if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
-- ac_cv_path_PKG_CONFIG="$as_dir/$ac_word$ac_exec_ext"
-- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
-- break 2
-- fi
--done
-- done
--IFS=$as_save_IFS
--
-- ;;
--esac
--fi
--PKG_CONFIG=$ac_cv_path_PKG_CONFIG
--if test -n "$PKG_CONFIG"; then
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $PKG_CONFIG" >&5
--$as_echo "$PKG_CONFIG" >&6; }
--else
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
--$as_echo "no" >&6; }
--fi
--
--
--fi
--if test -z "$ac_cv_path_PKG_CONFIG"; then
-- ac_pt_PKG_CONFIG=$PKG_CONFIG
-- # Extract the first word of "pkg-config", so it can be a program name with args.
--set dummy pkg-config; ac_word=$2
--{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
--$as_echo_n "checking for $ac_word... " >&6; }
--if ${ac_cv_path_ac_pt_PKG_CONFIG+:} false; then :
-- $as_echo_n "(cached) " >&6
--else
-- case $ac_pt_PKG_CONFIG in
-- [\\/]* | ?:[\\/]*)
-- ac_cv_path_ac_pt_PKG_CONFIG="$ac_pt_PKG_CONFIG" # Let the user override the test with a path.
-- ;;
-- *)
-- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
--for as_dir in $PATH
--do
-- IFS=$as_save_IFS
-- test -z "$as_dir" && as_dir=.
-- for ac_exec_ext in '' $ac_executable_extensions; do
-- if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
-- ac_cv_path_ac_pt_PKG_CONFIG="$as_dir/$ac_word$ac_exec_ext"
-- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
-- break 2
-- fi
--done
-- done
--IFS=$as_save_IFS
--
-- ;;
--esac
--fi
--ac_pt_PKG_CONFIG=$ac_cv_path_ac_pt_PKG_CONFIG
--if test -n "$ac_pt_PKG_CONFIG"; then
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_pt_PKG_CONFIG" >&5
--$as_echo "$ac_pt_PKG_CONFIG" >&6; }
--else
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
--$as_echo "no" >&6; }
--fi
--
-- if test "x$ac_pt_PKG_CONFIG" = x; then
-- PKG_CONFIG=""
-- else
-- case $cross_compiling:$ac_tool_warned in
--yes:)
--{ $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: using cross tools not prefixed with host triplet" >&5
--$as_echo "$as_me: WARNING: using cross tools not prefixed with host triplet" >&2;}
--ac_tool_warned=yes ;;
--esac
-- PKG_CONFIG=$ac_pt_PKG_CONFIG
-- fi
--else
-- PKG_CONFIG="$ac_cv_path_PKG_CONFIG"
--fi
--
--fi
--if test -n "$PKG_CONFIG"; then
-- _pkg_min_version=0.9.0
-- { $as_echo "$as_me:${as_lineno-$LINENO}: checking pkg-config is at least version $_pkg_min_version" >&5
--$as_echo_n "checking pkg-config is at least version $_pkg_min_version... " >&6; }
-- if $PKG_CONFIG --atleast-pkgconfig-version $_pkg_min_version; then
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
--$as_echo "yes" >&6; }
-- else
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
--$as_echo "no" >&6; }
-- PKG_CONFIG=""
-- fi
--fi
--
--
--
-- gtk_doc_requires="gtk-doc >= 1.15"
-- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for gtk-doc" >&5
--$as_echo_n "checking for gtk-doc... " >&6; }
-- if test -n "$PKG_CONFIG" && \
-- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"\$gtk_doc_requires\""; } >&5
-- ($PKG_CONFIG --exists --print-errors "$gtk_doc_requires") 2>&5
-- ac_status=$?
-- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
-- test $ac_status = 0; }; then
-- have_gtk_doc=yes
--else
-- have_gtk_doc=no
--fi
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $have_gtk_doc" >&5
--$as_echo "$have_gtk_doc" >&6; }
--
-- if test "$have_gtk_doc" = "no"; then
-- { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING:
-- You will not be able to create source packages with 'make dist'
-- because $gtk_doc_requires is not found." >&5
--$as_echo "$as_me: WARNING:
-- You will not be able to create source packages with 'make dist'
-- because $gtk_doc_requires is not found." >&2;}
-- fi
--
-- # Extract the first word of "gtkdoc-check", so it can be a program name with args.
--set dummy gtkdoc-check; ac_word=$2
--{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
--$as_echo_n "checking for $ac_word... " >&6; }
--if ${ac_cv_prog_GTKDOC_CHECK+:} false; then :
-- $as_echo_n "(cached) " >&6
--else
-- if test -n "$GTKDOC_CHECK"; then
-- ac_cv_prog_GTKDOC_CHECK="$GTKDOC_CHECK" # Let the user override the test.
--else
--as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
--for as_dir in $PATH
--do
-- IFS=$as_save_IFS
-- test -z "$as_dir" && as_dir=.
-- for ac_exec_ext in '' $ac_executable_extensions; do
-- if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
-- ac_cv_prog_GTKDOC_CHECK="gtkdoc-check.test"
-- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
-- break 2
-- fi
--done
-- done
--IFS=$as_save_IFS
--
--fi
--fi
--GTKDOC_CHECK=$ac_cv_prog_GTKDOC_CHECK
--if test -n "$GTKDOC_CHECK"; then
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $GTKDOC_CHECK" >&5
--$as_echo "$GTKDOC_CHECK" >&6; }
--else
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
--$as_echo "no" >&6; }
--fi
--
--
-- # Extract the first word of "gtkdoc-check", so it can be a program name with args.
--set dummy gtkdoc-check; ac_word=$2
--{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
--$as_echo_n "checking for $ac_word... " >&6; }
--if ${ac_cv_path_GTKDOC_CHECK_PATH+:} false; then :
-- $as_echo_n "(cached) " >&6
--else
-- case $GTKDOC_CHECK_PATH in
-- [\\/]* | ?:[\\/]*)
-- ac_cv_path_GTKDOC_CHECK_PATH="$GTKDOC_CHECK_PATH" # Let the user override the test with a path.
-- ;;
-- *)
-- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
--for as_dir in $PATH
--do
-- IFS=$as_save_IFS
-- test -z "$as_dir" && as_dir=.
-- for ac_exec_ext in '' $ac_executable_extensions; do
-- if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
-- ac_cv_path_GTKDOC_CHECK_PATH="$as_dir/$ac_word$ac_exec_ext"
-- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
-- break 2
-- fi
--done
-- done
--IFS=$as_save_IFS
--
-- ;;
--esac
--fi
--GTKDOC_CHECK_PATH=$ac_cv_path_GTKDOC_CHECK_PATH
--if test -n "$GTKDOC_CHECK_PATH"; then
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $GTKDOC_CHECK_PATH" >&5
--$as_echo "$GTKDOC_CHECK_PATH" >&6; }
--else
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
--$as_echo "no" >&6; }
--fi
--
--
-- for ac_prog in gtkdoc-rebase
--do
-- # Extract the first word of "$ac_prog", so it can be a program name with args.
--set dummy $ac_prog; ac_word=$2
--{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
--$as_echo_n "checking for $ac_word... " >&6; }
--if ${ac_cv_path_GTKDOC_REBASE+:} false; then :
-- $as_echo_n "(cached) " >&6
--else
-- case $GTKDOC_REBASE in
-- [\\/]* | ?:[\\/]*)
-- ac_cv_path_GTKDOC_REBASE="$GTKDOC_REBASE" # Let the user override the test with a path.
-- ;;
-- *)
-- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
--for as_dir in $PATH
--do
-- IFS=$as_save_IFS
-- test -z "$as_dir" && as_dir=.
-- for ac_exec_ext in '' $ac_executable_extensions; do
-- if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
-- ac_cv_path_GTKDOC_REBASE="$as_dir/$ac_word$ac_exec_ext"
-- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
-- break 2
-- fi
--done
-- done
--IFS=$as_save_IFS
--
-- ;;
--esac
--fi
--GTKDOC_REBASE=$ac_cv_path_GTKDOC_REBASE
--if test -n "$GTKDOC_REBASE"; then
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $GTKDOC_REBASE" >&5
--$as_echo "$GTKDOC_REBASE" >&6; }
--else
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
--$as_echo "no" >&6; }
--fi
--
--
-- test -n "$GTKDOC_REBASE" && break
--done
--test -n "$GTKDOC_REBASE" || GTKDOC_REBASE="true"
--
-- # Extract the first word of "gtkdoc-mkpdf", so it can be a program name with args.
--set dummy gtkdoc-mkpdf; ac_word=$2
--{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
--$as_echo_n "checking for $ac_word... " >&6; }
--if ${ac_cv_path_GTKDOC_MKPDF+:} false; then :
-- $as_echo_n "(cached) " >&6
--else
-- case $GTKDOC_MKPDF in
-- [\\/]* | ?:[\\/]*)
-- ac_cv_path_GTKDOC_MKPDF="$GTKDOC_MKPDF" # Let the user override the test with a path.
-- ;;
-- *)
-- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
--for as_dir in $PATH
--do
-- IFS=$as_save_IFS
-- test -z "$as_dir" && as_dir=.
-- for ac_exec_ext in '' $ac_executable_extensions; do
-- if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
-- ac_cv_path_GTKDOC_MKPDF="$as_dir/$ac_word$ac_exec_ext"
-- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
-- break 2
-- fi
--done
-- done
--IFS=$as_save_IFS
--
-- ;;
--esac
--fi
--GTKDOC_MKPDF=$ac_cv_path_GTKDOC_MKPDF
--if test -n "$GTKDOC_MKPDF"; then
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $GTKDOC_MKPDF" >&5
--$as_echo "$GTKDOC_MKPDF" >&6; }
--else
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
--$as_echo "no" >&6; }
--fi
--
--
--
--
--# Check whether --with-html-dir was given.
--if test "${with_html_dir+set}" = set; then :
-- withval=$with_html_dir;
--else
-- with_html_dir='${datadir}/gtk-doc/html'
--fi
--
-- HTML_DIR="$with_html_dir"
--
--
-- # Check whether --enable-gtk-doc was given.
--if test "${enable_gtk_doc+set}" = set; then :
-- enableval=$enable_gtk_doc;
--else
-- enable_gtk_doc=no
--fi
--
--
-- { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether to build gtk-doc documentation" >&5
--$as_echo_n "checking whether to build gtk-doc documentation... " >&6; }
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $enable_gtk_doc" >&5
--$as_echo "$enable_gtk_doc" >&6; }
--
-- if test "x$enable_gtk_doc" = "xyes" && test "$have_gtk_doc" = "no"; then
-- as_fn_error $? "
-- You must have $gtk_doc_requires installed to build documentation for
-- $PACKAGE_NAME. Please install gtk-doc or disable building the
-- documentation by adding '--disable-gtk-doc' to '$0'." "$LINENO" 5
-- fi
--
-- if test "x$PACKAGE_NAME" != "xglib"; then
--
--pkg_failed=no
--{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for glib-2.0 >= 2.10.0 gobject-2.0 >= 2.10.0" >&5
--$as_echo_n "checking for glib-2.0 >= 2.10.0 gobject-2.0 >= 2.10.0... " >&6; }
--
--if test -n "$GTKDOC_DEPS_CFLAGS"; then
-- pkg_cv_GTKDOC_DEPS_CFLAGS="$GTKDOC_DEPS_CFLAGS"
-- elif test -n "$PKG_CONFIG"; then
-- if test -n "$PKG_CONFIG" && \
-- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"glib-2.0 >= 2.10.0 gobject-2.0 >= 2.10.0\""; } >&5
-- ($PKG_CONFIG --exists --print-errors "glib-2.0 >= 2.10.0 gobject-2.0 >= 2.10.0") 2>&5
-- ac_status=$?
-- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
-- test $ac_status = 0; }; then
-- pkg_cv_GTKDOC_DEPS_CFLAGS=`$PKG_CONFIG --cflags "glib-2.0 >= 2.10.0 gobject-2.0 >= 2.10.0" 2>/dev/null`
-- test "x$?" != "x0" && pkg_failed=yes
--else
-- pkg_failed=yes
--fi
-- else
-- pkg_failed=untried
--fi
--if test -n "$GTKDOC_DEPS_LIBS"; then
-- pkg_cv_GTKDOC_DEPS_LIBS="$GTKDOC_DEPS_LIBS"
-- elif test -n "$PKG_CONFIG"; then
-- if test -n "$PKG_CONFIG" && \
-- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"glib-2.0 >= 2.10.0 gobject-2.0 >= 2.10.0\""; } >&5
-- ($PKG_CONFIG --exists --print-errors "glib-2.0 >= 2.10.0 gobject-2.0 >= 2.10.0") 2>&5
-- ac_status=$?
-- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
-- test $ac_status = 0; }; then
-- pkg_cv_GTKDOC_DEPS_LIBS=`$PKG_CONFIG --libs "glib-2.0 >= 2.10.0 gobject-2.0 >= 2.10.0" 2>/dev/null`
-- test "x$?" != "x0" && pkg_failed=yes
--else
-- pkg_failed=yes
--fi
-- else
-- pkg_failed=untried
--fi
--
--
--
--if test $pkg_failed = yes; then
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
--$as_echo "no" >&6; }
--
--if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
-- _pkg_short_errors_supported=yes
--else
-- _pkg_short_errors_supported=no
--fi
-- if test $_pkg_short_errors_supported = yes; then
-- GTKDOC_DEPS_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "glib-2.0 >= 2.10.0 gobject-2.0 >= 2.10.0" 2>&1`
-- else
-- GTKDOC_DEPS_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "glib-2.0 >= 2.10.0 gobject-2.0 >= 2.10.0" 2>&1`
-- fi
-- # Put the nasty error message in config.log where it belongs
-- echo "$GTKDOC_DEPS_PKG_ERRORS" >&5
--
-- :
--elif test $pkg_failed = untried; then
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
--$as_echo "no" >&6; }
-- :
--else
-- GTKDOC_DEPS_CFLAGS=$pkg_cv_GTKDOC_DEPS_CFLAGS
-- GTKDOC_DEPS_LIBS=$pkg_cv_GTKDOC_DEPS_LIBS
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
--$as_echo "yes" >&6; }
--
--fi
-- fi
--
-- # Check whether --enable-gtk-doc-html was given.
--if test "${enable_gtk_doc_html+set}" = set; then :
-- enableval=$enable_gtk_doc_html;
--else
-- enable_gtk_doc_html=yes
--fi
--
-- # Check whether --enable-gtk-doc-pdf was given.
--if test "${enable_gtk_doc_pdf+set}" = set; then :
-- enableval=$enable_gtk_doc_pdf;
--else
-- enable_gtk_doc_pdf=no
--fi
--
--
-- if test -z "$GTKDOC_MKPDF"; then
-- enable_gtk_doc_pdf=no
-- fi
--
-- if test -z "$AM_DEFAULT_VERBOSITY"; then
-- AM_DEFAULT_VERBOSITY=1
-- fi
--
--
-- if test x$have_gtk_doc = xyes; then
-- HAVE_GTK_DOC_TRUE=
-- HAVE_GTK_DOC_FALSE='#'
--else
-- HAVE_GTK_DOC_TRUE='#'
-- HAVE_GTK_DOC_FALSE=
--fi
--
-- if test x$enable_gtk_doc = xyes; then
-- ENABLE_GTK_DOC_TRUE=
-- ENABLE_GTK_DOC_FALSE='#'
--else
-- ENABLE_GTK_DOC_TRUE='#'
-- ENABLE_GTK_DOC_FALSE=
--fi
--
-- if test x$enable_gtk_doc_html = xyes; then
-- GTK_DOC_BUILD_HTML_TRUE=
-- GTK_DOC_BUILD_HTML_FALSE='#'
--else
-- GTK_DOC_BUILD_HTML_TRUE='#'
-- GTK_DOC_BUILD_HTML_FALSE=
--fi
--
-- if test x$enable_gtk_doc_pdf = xyes; then
-- GTK_DOC_BUILD_PDF_TRUE=
-- GTK_DOC_BUILD_PDF_FALSE='#'
--else
-- GTK_DOC_BUILD_PDF_TRUE='#'
-- GTK_DOC_BUILD_PDF_FALSE=
--fi
--
-- if test -n "$LIBTOOL"; then
-- GTK_DOC_USE_LIBTOOL_TRUE=
-- GTK_DOC_USE_LIBTOOL_FALSE='#'
--else
-- GTK_DOC_USE_LIBTOOL_TRUE='#'
-- GTK_DOC_USE_LIBTOOL_FALSE=
--fi
--
-- if test -n "$GTKDOC_REBASE"; then
-- GTK_DOC_USE_REBASE_TRUE=
-- GTK_DOC_USE_REBASE_FALSE='#'
--else
-- GTK_DOC_USE_REBASE_TRUE='#'
-- GTK_DOC_USE_REBASE_FALSE=
--fi
--
--
--
--# needed for some older versions of gtk-doc
--
-- if false; then
-- GTK_DOC_USE_LIBTOOL_TRUE=
-- GTK_DOC_USE_LIBTOOL_FALSE='#'
--else
-- GTK_DOC_USE_LIBTOOL_TRUE='#'
-- GTK_DOC_USE_LIBTOOL_FALSE=
--fi
--
--
--
--if test x"$have_gtk_doc" = xyes -a x"$enable_gtk_doc" = xyes; then
-- LIBPSL_DOCS=docs/libpsl
--
--fi
--
--#
- # enable creation of man pages
- #
- # Check whether --enable-man was given.
-@@ -17646,7 +17122,7 @@ done
-
- # Override the template file name of the generated .pc file, so that there
- # is no need to rename the template file when the API version changes.
--ac_config_files="$ac_config_files Makefile include/Makefile src/Makefile tools/Makefile po/Makefile.in fuzz/Makefile tests/Makefile docs/libpsl/Makefile docs/libpsl/version.xml libpsl.pc:libpsl.pc.in meson.build msvc/Makefile msvc/config.h.win32 msvc/config-msvc.mak"
-+ac_config_files="$ac_config_files Makefile include/Makefile src/Makefile tools/Makefile po/Makefile.in fuzz/Makefile tests/Makefile libpsl.pc:libpsl.pc.in meson.build msvc/Makefile msvc/config.h.win32 msvc/config-msvc.mak"
-
- cat >confcache <<\_ACEOF
- # This file is a shell script that caches the results of configure
-@@ -17781,34 +17257,6 @@ if test -z "${am__fastdepCC_TRUE}" && test -z "${am__f
- as_fn_error $? "conditional \"am__fastdepCC\" was never defined.
- Usually this means the macro was only invoked conditionally." "$LINENO" 5
- fi
--if test -z "${HAVE_GTK_DOC_TRUE}" && test -z "${HAVE_GTK_DOC_FALSE}"; then
-- as_fn_error $? "conditional \"HAVE_GTK_DOC\" was never defined.
--Usually this means the macro was only invoked conditionally." "$LINENO" 5
--fi
--if test -z "${ENABLE_GTK_DOC_TRUE}" && test -z "${ENABLE_GTK_DOC_FALSE}"; then
-- as_fn_error $? "conditional \"ENABLE_GTK_DOC\" was never defined.
--Usually this means the macro was only invoked conditionally." "$LINENO" 5
--fi
--if test -z "${GTK_DOC_BUILD_HTML_TRUE}" && test -z "${GTK_DOC_BUILD_HTML_FALSE}"; then
-- as_fn_error $? "conditional \"GTK_DOC_BUILD_HTML\" was never defined.
--Usually this means the macro was only invoked conditionally." "$LINENO" 5
--fi
--if test -z "${GTK_DOC_BUILD_PDF_TRUE}" && test -z "${GTK_DOC_BUILD_PDF_FALSE}"; then
-- as_fn_error $? "conditional \"GTK_DOC_BUILD_PDF\" was never defined.
--Usually this means the macro was only invoked conditionally." "$LINENO" 5
--fi
--if test -z "${GTK_DOC_USE_LIBTOOL_TRUE}" && test -z "${GTK_DOC_USE_LIBTOOL_FALSE}"; then
-- as_fn_error $? "conditional \"GTK_DOC_USE_LIBTOOL\" was never defined.
--Usually this means the macro was only invoked conditionally." "$LINENO" 5
--fi
--if test -z "${GTK_DOC_USE_REBASE_TRUE}" && test -z "${GTK_DOC_USE_REBASE_FALSE}"; then
-- as_fn_error $? "conditional \"GTK_DOC_USE_REBASE\" was never defined.
--Usually this means the macro was only invoked conditionally." "$LINENO" 5
--fi
--if test -z "${GTK_DOC_USE_LIBTOOL_TRUE}" && test -z "${GTK_DOC_USE_LIBTOOL_FALSE}"; then
-- as_fn_error $? "conditional \"GTK_DOC_USE_LIBTOOL\" was never defined.
--Usually this means the macro was only invoked conditionally." "$LINENO" 5
--fi
- if test -z "${ENABLE_MAN_TRUE}" && test -z "${ENABLE_MAN_FALSE}"; then
- as_fn_error $? "conditional \"ENABLE_MAN\" was never defined.
- Usually this means the macro was only invoked conditionally." "$LINENO" 5
-@@ -18738,8 +18186,6 @@ do
- "po/Makefile.in") CONFIG_FILES="$CONFIG_FILES po/Makefile.in" ;;
- "fuzz/Makefile") CONFIG_FILES="$CONFIG_FILES fuzz/Makefile" ;;
- "tests/Makefile") CONFIG_FILES="$CONFIG_FILES tests/Makefile" ;;
-- "docs/libpsl/Makefile") CONFIG_FILES="$CONFIG_FILES docs/libpsl/Makefile" ;;
-- "docs/libpsl/version.xml") CONFIG_FILES="$CONFIG_FILES docs/libpsl/version.xml" ;;
- "libpsl.pc") CONFIG_FILES="$CONFIG_FILES libpsl.pc:libpsl.pc.in" ;;
- "meson.build") CONFIG_FILES="$CONFIG_FILES meson.build" ;;
- "msvc/Makefile") CONFIG_FILES="$CONFIG_FILES msvc/Makefile" ;;
diff --git a/dns/libpsl/pkg-plist b/dns/libpsl/pkg-plist
index b4d02ef5f041..c60f11d531df 100644
--- a/dns/libpsl/pkg-plist
+++ b/dns/libpsl/pkg-plist
@@ -1,9 +1,10 @@
+bin/psl-make-dafsa
bin/psl
include/libpsl.h
lib/libpsl.a
lib/libpsl.so
lib/libpsl.so.5
-lib/libpsl.so.5.3.3
+lib/libpsl.so.5.3.4
libdata/pkgconfig/libpsl.pc
man/man1/psl-make-dafsa.1.gz
man/man1/psl.1.gz