aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-02 16:21:58 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-02 16:22:20 +0000
commitfaae7b2bfefde7220d86633aec6042c22a82a20e (patch)
treeb34f587a8bf5cfba60f4ba9a902a12739d3eab16
parent048fdd0a612e36a9a816931af55603a6c6ee5ff2 (diff)
downloadports-faae7b2bfefde7220d86633aec6042c22a82a20e.tar.gz
ports-faae7b2bfefde7220d86633aec6042c22a82a20e.zip
irc/ninja: Fix build with llvm16
Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--irc/ninja/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/irc/ninja/Makefile b/irc/ninja/Makefile
index a135e5505484..f6f1e7c3e511 100644
--- a/irc/ninja/Makefile
+++ b/irc/ninja/Makefile
@@ -13,6 +13,12 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= IRCLIB="${DATADIR}"
MAKE_JOBS_UNSAFE= yes
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
+CFLAGS+= -Wno-error=incompatible-function-pointer-types
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ninja ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/ninjawserv ${STAGEDIR}${PREFIX}/bin