aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2018-03-13 20:09:21 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2018-03-13 20:09:21 +0000
commitfae54c4cb187ff7d9ae82bb0dd260583e32a4987 (patch)
treee851351ec7ce67e3db4b2631c3fc96c7d79d1a89
parentcb7f7cada988f8298303639693c5e0518dcac32e (diff)
downloadports-fae54c4cb187ff7d9ae82bb0dd260583e32a4987.tar.gz
ports-fae54c4cb187ff7d9ae82bb0dd260583e32a4987.zip
- Update to 3.4.1
Notes
Notes: svn path=/head/; revision=464404
-rw-r--r--graphics/osg/Makefile15
-rw-r--r--graphics/osg/distinfo5
-rw-r--r--graphics/osg/files/patch-ffmpeg3157
-rw-r--r--graphics/osg/pkg-plist7
4 files changed, 18 insertions, 166 deletions
diff --git a/graphics/osg/Makefile b/graphics/osg/Makefile
index c931026339ed..bfa77c2772a2 100644
--- a/graphics/osg/Makefile
+++ b/graphics/osg/Makefile
@@ -2,12 +2,9 @@
# $FreeBSD$
PORTNAME= osg
-PORTVERSION= 3.4.0
-PORTREVISION= 4
+PORTVERSION= 3.4.1
+DISTVERSIONPREFIX= OpenSceneGraph-
CATEGORIES= graphics
-MASTER_SITES= http://trac.openscenegraph.org/downloads/developer_releases/ \
- http://mirror.amdmi3.ru/distfiles/
-DISTNAME= OpenSceneGraph-${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= C++ OpenGL scene graph library for real-time rendering
@@ -20,15 +17,19 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LIB_DEPENDS= libpng.so:graphics/png \
libtiff.so:graphics/tiff
+USE_GITHUB= yes
+GH_ACCOUNT= openscenegraph
+GH_PROJECT= OpenSceneGraph
+
CONFLICTS= osg-devel-[0-9]*
-USES= alias cmake:outsource jpeg pkgconfig zip
+USES= alias cmake:outsource jpeg pkgconfig
USE_GL= gl glu
USE_XORG= x11
USE_LDCONFIG= yes
PLIST_SUB= OSG_VERSION=${PORTVERSION} \
- OSG_SHLIBVER=130 \
+ OSG_SHLIBVER=131 \
OPENTHREADS_VERSION=3.3.0 \
OPENTHREADS_SHLIBVER=20
diff --git a/graphics/osg/distinfo b/graphics/osg/distinfo
index db02775862e2..7b8e38def234 100644
--- a/graphics/osg/distinfo
+++ b/graphics/osg/distinfo
@@ -1,2 +1,3 @@
-SHA256 (OpenSceneGraph-3.4.0.zip) = 5c727d84755da276adf8c4a4a3a8ba9c9570fc4b4969f06f1d2e9f89b1e3040e
-SIZE (OpenSceneGraph-3.4.0.zip) = 7975023
+TIMESTAMP = 1506357973
+SHA256 (openscenegraph-OpenSceneGraph-OpenSceneGraph-3.4.1_GH0.tar.gz) = 930eb46f05781a76883ec16c5f49cfb29a059421db131005d75bec4d78401fd5
+SIZE (openscenegraph-OpenSceneGraph-OpenSceneGraph-3.4.1_GH0.tar.gz) = 5686385
diff --git a/graphics/osg/files/patch-ffmpeg3 b/graphics/osg/files/patch-ffmpeg3
deleted file mode 100644
index f3f1a2c73de3..000000000000
--- a/graphics/osg/files/patch-ffmpeg3
+++ /dev/null
@@ -1,157 +0,0 @@
-Description: Replace deprecated FFmpeg API
-Author: Andreas Cadhalpun <Andreas.Cadhalpun@googlemail.com>
-Last-Update: <2015-11-02>
-
---- src/osgPlugins/ffmpeg/FFmpegDecoderVideo.cpp.orig
-+++ src/osgPlugins/ffmpeg/FFmpegDecoderVideo.cpp
-@@ -71,7 +71,7 @@ void FFmpegDecoderVideo::open(AVStream *
- findAspectRatio();
-
- // Find out whether we support Alpha channel
-- m_alpha_channel = (m_context->pix_fmt == PIX_FMT_YUVA420P);
-+ m_alpha_channel = (m_context->pix_fmt == AV_PIX_FMT_YUVA420P);
-
- // Find out the framerate
- m_frame_rate = av_q2d(stream->avg_frame_rate);
-@@ -91,20 +91,19 @@ void FFmpegDecoderVideo::open(AVStream *
- throw std::runtime_error("avcodec_open() failed");
-
- // Allocate video frame
-- m_frame.reset(avcodec_alloc_frame());
-+ m_frame.reset(av_frame_alloc());
-
- // Allocate converted RGB frame
-- m_frame_rgba.reset(avcodec_alloc_frame());
-- m_buffer_rgba[0].resize(avpicture_get_size(PIX_FMT_RGB24, width(), height()));
-+ m_frame_rgba.reset(av_frame_alloc());
-+ m_buffer_rgba[0].resize(avpicture_get_size(AV_PIX_FMT_RGB24, width(), height()));
- m_buffer_rgba[1].resize(m_buffer_rgba[0].size());
-
- // Assign appropriate parts of the buffer to image planes in m_frame_rgba
-- avpicture_fill((AVPicture *) (m_frame_rgba).get(), &(m_buffer_rgba[0])[0], PIX_FMT_RGB24, width(), height());
-+ avpicture_fill((AVPicture *) (m_frame_rgba).get(), &(m_buffer_rgba[0])[0], AV_PIX_FMT_RGB24, width(), height());
-
- // Override get_buffer()/release_buffer() from codec context in order to retrieve the PTS of each frame.
- m_context->opaque = this;
-- m_context->get_buffer = getBuffer;
-- m_context->release_buffer = releaseBuffer;
-+ m_context->get_buffer2 = getBuffer;
- }
-
-
-@@ -263,8 +262,8 @@ int FFmpegDecoderVideo::convert(AVPictur
- #ifdef USE_SWSCALE
- if (m_swscale_ctx==0)
- {
-- m_swscale_ctx = sws_getContext(src_width, src_height, (PixelFormat) src_pix_fmt,
-- src_width, src_height, (PixelFormat) dst_pix_fmt,
-+ m_swscale_ctx = sws_getContext(src_width, src_height, (AVPixelFormat) src_pix_fmt,
-+ src_width, src_height, (AVPixelFormat) dst_pix_fmt,
- /*SWS_BILINEAR*/ SWS_BICUBIC, NULL, NULL, NULL);
- }
-
-@@ -311,14 +310,14 @@ void FFmpegDecoderVideo::publishFrame(co
- AVPicture * const dst = (AVPicture *) m_frame_rgba.get();
-
- // Assign appropriate parts of the buffer to image planes in m_frame_rgba
-- avpicture_fill((AVPicture *) (m_frame_rgba).get(), &(m_buffer_rgba[m_writeBuffer])[0], PIX_FMT_RGB24, width(), height());
-+ avpicture_fill((AVPicture *) (m_frame_rgba).get(), &(m_buffer_rgba[m_writeBuffer])[0], AV_PIX_FMT_RGB24, width(), height());
-
- // Convert YUVA420p (i.e. YUV420p plus alpha channel) using our own routine
-
-- if (m_context->pix_fmt == PIX_FMT_YUVA420P)
-+ if (m_context->pix_fmt == AV_PIX_FMT_YUVA420P)
- yuva420pToRgba(dst, src, width(), height());
- else
-- convert(dst, PIX_FMT_RGB24, src, m_context->pix_fmt, width(), height());
-+ convert(dst, AV_PIX_FMT_RGB24, src, m_context->pix_fmt, width(), height());
-
- // Wait 'delay' seconds before publishing the picture.
- int i_delay = static_cast<int>(delay * 1000000 + 0.5);
-@@ -345,7 +344,7 @@ void FFmpegDecoderVideo::publishFrame(co
-
- void FFmpegDecoderVideo::yuva420pToRgba(AVPicture * const dst, AVPicture * const src, int width, int height)
- {
-- convert(dst, PIX_FMT_RGB24, src, m_context->pix_fmt, width, height);
-+ convert(dst, AV_PIX_FMT_RGB24, src, m_context->pix_fmt, width, height);
-
- const size_t bpp = 4;
-
-@@ -363,31 +362,28 @@ void FFmpegDecoderVideo::yuva420pToRgba(
- }
- }
-
--
--
--int FFmpegDecoderVideo::getBuffer(AVCodecContext * const context, AVFrame * const picture)
-+int FFmpegDecoderVideo::getBuffer(AVCodecContext * const context, AVFrame * const picture, int flags)
- {
-+ AVBufferRef *ref;
- const FFmpegDecoderVideo * const this_ = reinterpret_cast<const FFmpegDecoderVideo*>(context->opaque);
-
-- const int result = avcodec_default_get_buffer(context, picture);
-+ const int result = avcodec_default_get_buffer2(context, picture, flags);
- int64_t * p_pts = reinterpret_cast<int64_t*>( av_malloc(sizeof(int64_t)) );
-
- *p_pts = this_->m_packet_pts;
- picture->opaque = p_pts;
-
-+ ref = av_buffer_create((uint8_t *)picture->opaque, sizeof(int64_t), FFmpegDecoderVideo::freeBuffer, picture->buf[0], flags);
-+ picture->buf[0] = ref;
-+
- return result;
- }
-
--
--
--void FFmpegDecoderVideo::releaseBuffer(AVCodecContext * const context, AVFrame * const picture)
-+void FFmpegDecoderVideo::freeBuffer(void *opaque, uint8_t *data)
- {
-- if (picture != 0)
-- av_freep(&picture->opaque);
--
-- avcodec_default_release_buffer(context, picture);
-+ AVBufferRef *ref = (AVBufferRef *)opaque;
-+ av_buffer_unref(&ref);
-+ av_free(data);
- }
-
--
--
- } // namespace osgFFmpeg
---- src/osgPlugins/ffmpeg/FFmpegDecoderVideo.hpp.orig
-+++ src/osgPlugins/ffmpeg/FFmpegDecoderVideo.hpp
-@@ -94,8 +94,8 @@ private:
- int src_pix_fmt, int src_width, int src_height);
-
-
-- static int getBuffer(AVCodecContext * context, AVFrame * picture);
-- static void releaseBuffer(AVCodecContext * context, AVFrame * picture);
-+ static int getBuffer(AVCodecContext * context, AVFrame * picture, int flags);
-+ static void freeBuffer(void * opaque, uint8_t *data);
-
- PacketQueue & m_packets;
- FFmpegClocks & m_clocks;
---- src/osgPlugins/ffmpeg/FFmpegParameters.cpp.orig
-+++ src/osgPlugins/ffmpeg/FFmpegParameters.cpp
-@@ -19,7 +19,7 @@ extern "C"
- #include <libavutil/pixdesc.h>
- }
-
--inline PixelFormat osg_av_get_pix_fmt(const char *name) { return av_get_pix_fmt(name); }
-+inline AVPixelFormat osg_av_get_pix_fmt(const char *name) { return av_get_pix_fmt(name); }
-
-
- namespace osgFFmpeg {
---- src/osgPlugins/ffmpeg/FFmpegDecoderAudio.cpp.orig 2016-02-18 21:25:39.627923629 +0000
-+++ src/osgPlugins/ffmpeg/FFmpegDecoderAudio.cpp 2016-02-18 21:26:17.071140100 +0000
-@@ -227,8 +227,7 @@
- if (avcodec_open2(m_context, p_codec, NULL) < 0)
- throw std::runtime_error("avcodec_open() failed");
-
-- m_context->get_buffer = avcodec_default_get_buffer;
-- m_context->release_buffer = avcodec_default_release_buffer;
-+ m_context->get_buffer2 = avcodec_default_get_buffer2;
-
- }
-
diff --git a/graphics/osg/pkg-plist b/graphics/osg/pkg-plist
index 8b8ac9563fbc..affadfdc7cd0 100644
--- a/graphics/osg/pkg-plist
+++ b/graphics/osg/pkg-plist
@@ -176,6 +176,7 @@ include/osg/TransferFunction
include/osg/Transform
include/osg/TriangleFunctor
include/osg/TriangleIndexFunctor
+include/osg/TriangleLinePointIndexFunctor
include/osg/Types
include/osg/Uniform
include/osg/UserDataContainer
@@ -570,6 +571,12 @@ include/osgViewer/ViewerEventHandlers
include/osgViewer/api/X11/GraphicsHandleX11
include/osgViewer/api/X11/GraphicsWindowX11
include/osgViewer/api/X11/PixelBufferX11
+include/osgViewer/config/AcrossAllScreens
+include/osgViewer/config/PanoramicSphericalDisplay
+include/osgViewer/config/SingleScreen
+include/osgViewer/config/SingleWindow
+include/osgViewer/config/SphericalDisplay
+include/osgViewer/config/WoWVxDisplay
include/osgVolume/Export
include/osgVolume/FixedFunctionTechnique
include/osgVolume/Layer