aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2022-04-24 09:59:28 +0000
committerJan Beich <jbeich@FreeBSD.org>2022-04-24 11:12:09 +0000
commitfafe77a7d7039a1096c5aa49fa2d1d2a8863b812 (patch)
tree1a7d6b4d7950970641464165494b843c997f5f5d
parent677d1402ddbf0b21ac5499d837e527dcd2c570ab (diff)
downloadports-fafe77a7d7039a1096c5aa49fa2d1d2a8863b812.tar.gz
ports-fafe77a7d7039a1096c5aa49fa2d1d2a8863b812.zip
emulators/citra: mark BROKEN on aarch64 after 2627d61105ad
externals/cryptopp/cryptopp/crc_simd.cpp:100:13: error: use of undeclared identifier '__crc32w' w = __crc32w(w,x); ^ externals/cryptopp/cryptopp/crc_simd.cpp:101:13: error: use of undeclared identifier '__crc32h' w = __crc32h(w,y); ^ externals/cryptopp/cryptopp/crc_simd.cpp:102:13: error: use of undeclared identifier '__crc32b' w = __crc32b(w,z); ^ externals/cryptopp/cryptopp/crc_simd.cpp:103:13: error: use of undeclared identifier '__crc32cw' w = __crc32cw(w,x); ^ externals/cryptopp/cryptopp/crc_simd.cpp:104:13: error: use of undeclared identifier '__crc32ch' w = __crc32ch(w,y); ^ externals/cryptopp/cryptopp/crc_simd.cpp:105:13: error: use of undeclared identifier '__crc32cb' w = __crc32cb(w,z); ^ externals/cryptopp/cryptopp/crc_simd.cpp:125:13: error: use of undeclared identifier '__crc32b' c = __crc32b(c, *s); ^ externals/cryptopp/cryptopp/crc_simd.cpp:128:13: error: use of undeclared identifier '__crc32w' c = __crc32w(c, *(const word32 *)(void*)s); ^ externals/cryptopp/cryptopp/crc_simd.cpp:131:13: error: use of undeclared identifier '__crc32b' c = __crc32b(c, *s); ^ externals/cryptopp/cryptopp/crc_simd.cpp:137:13: error: use of undeclared identifier '__crc32cb' c = __crc32cb(c, *s); ^ externals/cryptopp/cryptopp/crc_simd.cpp:140:13: error: use of undeclared identifier '__crc32cw' c = __crc32cw(c, *(const word32 *)(void*)s); ^ externals/cryptopp/cryptopp/crc_simd.cpp:143:13: error: use of undeclared identifier '__crc32cb' c = __crc32cb(c, *s); ^ Reported by: pkg-fallout
-rw-r--r--emulators/citra/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/emulators/citra/Makefile b/emulators/citra/Makefile
index 36f626bd6f4f..b6940de1b49f 100644
--- a/emulators/citra/Makefile
+++ b/emulators/citra/Makefile
@@ -24,6 +24,8 @@ LICENSE_FILE_LGPL21+ = ${_LICENSE_STORE}/LGPL21 # soundtouch
LICENSE_FILE_MIT= ${WRKSRC}/externals/enet/LICENSE
LICENSE_FILE_OpenSSL= ${WRKSRC}/externals/libressl/COPYING
+BROKEN_aarch64= https://github.com/citra-emu/citra/issues/5921
+
BUILD_DEPENDS= boost-libs>0:devel/boost-libs
USE_GITHUB= yes