aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2022-07-30 11:02:56 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2022-07-30 11:04:12 +0000
commitfb615b1a565d7cf6f2e4ff9d21c79c38f1ba5c78 (patch)
tree1af94abbe2939c62f58a991c32dd3c8047ef35eb
parent820c62d33ed405f98169307ddb92aa7436585d24 (diff)
downloadports-fb615b1a565d7cf6f2e4ff9d21c79c38f1ba5c78.tar.gz
ports-fb615b1a565d7cf6f2e4ff9d21c79c38f1ba5c78.zip
audio/carla: fix build on powerpc64le
Use the portable eel mode instead of dedicated assembly: gmake[2]: Entering directory '/wrkdirs/usr/ports/audio/carla/work/Carla-2.5.0/source/modules/ysfx' Compiling thirdparty/WDL/source/WDL/eel2/nseel-cfunc.c {standard input}: Assembler messages: {standard input}:1444: Error: syntax error; found `(', expected `,' {standard input}:1444: Error: junk at end of line: `(1048576)' {standard input}:1445: Error: syntax error; found `(', expected `,' {standard input}:1445: Error: junk at end of line: `(1048576)' {standard input}:1490: Error: syntax error; found `(', expected `,' {standard input}:1490: Error: junk at end of line: `(1048576)' {standard input}:1491: Error: syntax error; found `(', expected `,' {standard input}:1491: Error: junk at end of line: `(1048576)' {standard input}:2249: Error: missing operand
-rw-r--r--audio/carla/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/audio/carla/Makefile b/audio/carla/Makefile
index 307b8b5cdc0d..77a68bc66a5c 100644
--- a/audio/carla/Makefile
+++ b/audio/carla/Makefile
@@ -12,8 +12,6 @@ COMMENT= Audio plugin host for Jack and PulseAudio
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/doc/GPL.txt
-BROKEN_powerpc64le= fails to build, see https://github.com/falkTX/Carla/issues/1651
-
LIB_DEPENDS= liblo.so:audio/liblo \
libsndfile.so:audio/libsndfile
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyliblo>0:audio/py-pyliblo@${PY_FLAVOR}
@@ -68,6 +66,8 @@ JACK_MAKE_ARGS_OFF= HAVE_JACK=false
PULSEAUDIO_LIB_DEPENDS= libpulse-simple.so:audio/pulseaudio
PULSEAUDIO_MAKE_ARGS_OFF= HAVE_PULSEAUDIO=false
+CFLAGS_powerpc64le= -DEEL_TARGET_PORTABLE
+
post-install:
@${REINPLACE_CMD} -i '' -e ' \
s|^PYTHON=.*|PYTHON=${PYTHON_CMD}|; \