aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-12-11 15:49:21 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-12-11 15:49:21 +0000
commitfb812d0b2fbb14ec530a547b538211d428d70791 (patch)
tree2c594fb087ef92861b4eb87cbb1052160e4c19d8
parentccf14dbaa52352baf8807ae50b308f560438ed0d (diff)
downloadports-fb812d0b2fbb14ec530a547b538211d428d70791.tar.gz
ports-fb812d0b2fbb14ec530a547b538211d428d70791.zip
www/ilias: Update version 7.16=>8.0b2
- Flavorize the port for different php versions - Remove pecl-pdf dependency as it is no longer marked as dependency in the upstream documentation Although upstream mentioned about releasing version 8 before the expiry of php74 unfortunately the schedule has been delayed and will take place some times next year. So rather the reaping the port I am considering to update to a beta release which supports php 8.0. PR: 261610 Approved by: portmgr (blanket infrastructure) Sponsored by: Bounce Experts
-rw-r--r--MOVED1
-rw-r--r--www/ilias/Makefile39
-rw-r--r--www/ilias/distinfo6
3 files changed, 26 insertions, 20 deletions
diff --git a/MOVED b/MOVED
index 1e14e680c372..1be6f9bffa0d 100644
--- a/MOVED
+++ b/MOVED
@@ -17638,3 +17638,4 @@ ftp/php-fastdfs||2022-12-09|Requires php74 which was EOL on 2022-11-28
multimedia/mlt7-qt5|multimedia/mlt7-qt|2022-12-10|Flavorized for Qt5 and Qt6
sysutils/cfengine317||2022-12-10|Has expired: Expire one year after cfengine 3.19.0 released
sysutils/cfengine-masterfiles317||2022-12-10|Has expired: Expire one year after cfengine-masterfiles 3.19.0 released
+www/ilias|www/ilias|2022-12-11|Flavorized for php
diff --git a/www/ilias/Makefile b/www/ilias/Makefile
index e4271c11b1ac..50108bb4aba6 100644
--- a/www/ilias/Makefile
+++ b/www/ilias/Makefile
@@ -1,7 +1,8 @@
PORTNAME= ilias
-PORTVERSION= 7.16
DISTVERSIONPREFIX= v
+DISTVERSION= 8.0_beta2
CATEGORIES= www education
+PKGNAMEPREFIX= ${PHP_PKGNAMEPREFIX}
MAINTAINER= wen@FreeBSD.org
COMMENT= Powerful, dynamic, PHP and MySQL based e-learning platform
@@ -9,29 +10,31 @@ WWW= https://www.ilias.de
LICENSE= GPLv2
+IGNORE_WITH_PHP= 81 82
+
LIB_DEPENDS= libpng.so:graphics/png
RUN_DEPENDS= ${LOCALBASE}/share/pear/Auth/Auth.php:security/pear-Auth@${PHP_FLAVOR} \
${LOCALBASE}/share/pear/HTML/Template/IT.php:devel/pear-HTML_Template_IT@${PHP_FLAVOR} \
${LOCALBASE}/share/pear/MDB2.php:databases/pear-MDB2@${PHP_FLAVOR} \
${LOCALBASE}/share/pear/PEAR.php:devel/pear@${PHP_FLAVOR} \
${UNZIP_CMD}:archivers/unzip \
- composer:devel/php-composer2 \
+ composer:devel/php-composer2@${PHP_FLAVOR} \
sudo:security/sudo \
zip:archivers/zip
-USES= cpe jpeg magick:6,run php
+USES= cpe jpeg magick:6,run php:flavors
USE_GITHUB= yes
GH_ACCOUNT= ILIAS-eLearning
GH_PROJECT= ILIAS
-USE_PHP= curl dom gd ldap fileinfo pcre pdf \
+USE_PHP= curl dom gd ldap fileinfo pcre \
pdo_mysql session simplexml soap \
tokenizer xmlrpc xmlwriter xsl zlib
-IGNORE_WITH_PHP= 80 81 82
-
CONFLICTS= ilias6
+NO_ARCH= yes
NO_BUILD= yes
+
SUB_FILES= pkg-message
SUB_LIST= ILIASFILESDIR=${ILIASFILESDIR}
@@ -50,39 +53,41 @@ ILIASFILESDIR= www/iliasfiles
EXTRA_FILES= %%WWWDIR%%/Modules/Chatroom/chat/node_modules/.bin/mime \
%%WWWDIR%%/Modules/Chatroom/chat/node_modules/.bin/uuid \
%%WWWDIR%%/node_modules/.bin/_mocha \
+ %%WWWDIR%%/node_modules/.bin/acorn \
%%WWWDIR%%/node_modules/.bin/atob \
%%WWWDIR%%/node_modules/.bin/errno \
+ %%WWWDIR%%/node_modules/.bin/escodegen \
+ %%WWWDIR%%/node_modules/.bin/esgenerate \
+ %%WWWDIR%%/node_modules/.bin/esparse \
+ %%WWWDIR%%/node_modules/.bin/esvalidate \
%%WWWDIR%%/node_modules/.bin/flat \
%%WWWDIR%%/node_modules/.bin/gl-style-composite \
%%WWWDIR%%/node_modules/.bin/gl-style-format \
%%WWWDIR%%/node_modules/.bin/gl-style-migrate \
%%WWWDIR%%/node_modules/.bin/gl-style-validate \
%%WWWDIR%%/node_modules/.bin/he \
- %%WWWDIR%%/node_modules/.bin/is-ci \
- %%WWWDIR%%/node_modules/.bin/is-docker \
%%WWWDIR%%/node_modules/.bin/image-size \
%%WWWDIR%%/node_modules/.bin/js-yaml \
%%WWWDIR%%/node_modules/.bin/lessc \
%%WWWDIR%%/node_modules/.bin/loose-envify \
%%WWWDIR%%/node_modules/.bin/mime \
+ %%WWWDIR%%/node_modules/.bin/mkdirp \
%%WWWDIR%%/node_modules/.bin/mocha \
%%WWWDIR%%/node_modules/.bin/nanoid \
%%WWWDIR%%/node_modules/.bin/needle \
- %%WWWDIR%%/node_modules/.bin/node-gyp-build \
- %%WWWDIR%%/node_modules/.bin/node-gyp-build-optional \
- %%WWWDIR%%/node_modules/.bin/node-gyp-build-test \
+ %%WWWDIR%%/node_modules/.bin/node-gyp \
+ %%WWWDIR%%/node_modules/.bin/node-ninja \
%%WWWDIR%%/node_modules/.bin/node-which \
- %%WWWDIR%%/node_modules/.bin/opencollective-postinstall \
- %%WWWDIR%%/node_modules/.bin/patch-package \
+ %%WWWDIR%%/node_modules/.bin/nopt \
%%WWWDIR%%/node_modules/.bin/pbf \
+ %%WWWDIR%%/node_modules/.bin/prebuild \
%%WWWDIR%%/node_modules/.bin/rimraf \
+ %%WWWDIR%%/node_modules/.bin/rc \
%%WWWDIR%%/node_modules/.bin/rollup \
%%WWWDIR%%/node_modules/.bin/semver \
%%WWWDIR%%/node_modules/.bin/terser \
- %%WWWDIR%%/node_modules/.bin/uuid \
- %%WWWDIR%%/node_modules/cross-spawn/node_modules/.bin/which \
- %%WWWDIR%%/test/filter.test.js \
- %%WWWDIR%%/test/mainbar.test.js
+ %%WWWDIR%%/node_modules/.bin/which \
+ %%WWWDIR%%/node_modules/acorn-globals/node_modules/.bin/acorn \
pre-install:
@${ECHO_CMD} "@owner ${WWWOWN}" >> ${PLIST}
diff --git a/www/ilias/distinfo b/www/ilias/distinfo
index 8bcbc685c6ad..78ee734e6243 100644
--- a/www/ilias/distinfo
+++ b/www/ilias/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1669639229
-SHA256 (ILIAS-eLearning-ILIAS-v7.16_GH0.tar.gz) = bc61e43f6946198d5b265a01f8993f884423e9795fc51f9d5908990a9f901491
-SIZE (ILIAS-eLearning-ILIAS-v7.16_GH0.tar.gz) = 185692081
+TIMESTAMP = 1670682382
+SHA256 (ILIAS-eLearning-ILIAS-v8.0_beta2_GH0.tar.gz) = ebde0f3494ebdd4c04a64a8fde61ce14591fbffb6e2c128a2dbbec0aba424664
+SIZE (ILIAS-eLearning-ILIAS-v8.0_beta2_GH0.tar.gz) = 173898946