aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-05-18 15:30:36 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-05-18 15:30:36 +0000
commitfb8eecf90077bb75867cb3e74710fa4be4a0499b (patch)
tree93a0b1de0a0a39bd4c53a13b1fe0ae362e5f3c75
parent03c2de95ff58c64d4012a9e746772efd13fdecf7 (diff)
downloadports-fb8eecf90077bb75867cb3e74710fa4be4a0499b.tar.gz
ports-fb8eecf90077bb75867cb3e74710fa4be4a0499b.zip
dvtm brings the concept of tiling window management, popularized by X11-window
managers like dwm to the console. As a console window manager it tries to make it easy to work with multiple console based programs like vim, mutt, cmus or irssi. WWW: http://www.brain-dump.org/projects/dvtm/ PR: ports/123786 Submitted by: Beat Gätzi <beat at chruetertee.ch>
Notes
Notes: svn path=/head/; revision=213275
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/dvtm/Makefile29
-rw-r--r--sysutils/dvtm/distinfo3
-rw-r--r--sysutils/dvtm/files/patch-config.mk26
-rw-r--r--sysutils/dvtm/pkg-descr6
5 files changed, 65 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index cbef4a93b7a8..7d76e27b8e19 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -162,6 +162,7 @@
SUBDIR += dvdimagecmp
SUBDIR += dvdisaster
SUBDIR += dvdtape
+ SUBDIR += dvtm
SUBDIR += dwatch
SUBDIR += e2fsprogs
SUBDIR += ecore-config
diff --git a/sysutils/dvtm/Makefile b/sysutils/dvtm/Makefile
new file mode 100644
index 000000000000..4f714df90497
--- /dev/null
+++ b/sysutils/dvtm/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: dvtm
+# Date created: May 18, 2008
+# Whom: Beat Gätzi <beat@chruetertee.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dvtm
+PORTVERSION= 0.4.1
+CATEGORIES= sysutils
+MASTER_SITES= http://www.brain-dump.org/projects/dvtm/
+
+MAINTAINER= beat@chruetertee.ch
+COMMENT= Tiling window management for the console
+
+MAN1= dvtm.1
+PLIST_FILES= bin/dvtm bin/dvtm-status
+
+pre-everything::
+ @${ECHO_MSG} "You can build dvtm with your own config.h using the DVTM_CONF knob:"
+ @${ECHO_MSG} "make DVTM_CONF=/path/to/dvtm/config.h install clean"
+
+post-extract:
+.if defined(DVTM_CONF)
+ @${ECHO_MSG} "creating config.h from ${DVTM_CONF}"
+ @${CP} ${DVTM_CONF} ${WRKSRC}/config.h
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/dvtm/distinfo b/sysutils/dvtm/distinfo
new file mode 100644
index 000000000000..8fa9016de0e6
--- /dev/null
+++ b/sysutils/dvtm/distinfo
@@ -0,0 +1,3 @@
+MD5 (dvtm-0.4.1.tar.gz) = bbbf5bce45dbf36c922672d1aa262adf
+SHA256 (dvtm-0.4.1.tar.gz) = f5dc75a5e94811885590d4167541bd3b7fd23530a576c204b95104514b5c173a
+SIZE (dvtm-0.4.1.tar.gz) = 21729
diff --git a/sysutils/dvtm/files/patch-config.mk b/sysutils/dvtm/files/patch-config.mk
new file mode 100644
index 000000000000..b018f391986f
--- /dev/null
+++ b/sysutils/dvtm/files/patch-config.mk
@@ -0,0 +1,26 @@
+--- config.mk.orig 2008-05-18 12:01:46.000000000 +0200
++++ config.mk 2008-05-18 12:05:01.000000000 +0200
+@@ -3,14 +3,14 @@
+
+ # Customize below to fit your system
+
+-PREFIX = /usr/local
+-MANPREFIX = ${PREFIX}/share/man
++PREFIX ?= /usr/local
++MANPREFIX = ${PREFIX}/man
+
+ INCS = -I. -I/usr/include -I/usr/local/include
+ LIBS = -lc -lutil -lncurses
+ LIBS_UTF8 = -lc -lutil -lncursesw
+
+-CFLAGS += -std=c99 -Os ${INCS} -DVERSION=\"${VERSION}\" -DNDEBUG
++CFLAGS += -std=c99 ${INCS} -DVERSION=\"${VERSION}\" -DNDEBUG
+ LDFLAGS += -L/usr/lib -L/usr/local/lib ${LIBS}
+
+ # Mouse handling
+@@ -18,4 +18,4 @@
+
+ DEBUG_CFLAGS = ${CFLAGS} -UNDEBUG -O0 -g -ggdb -Wall
+
+-CC = cc
++CC ?= cc
diff --git a/sysutils/dvtm/pkg-descr b/sysutils/dvtm/pkg-descr
new file mode 100644
index 000000000000..5d5817db84ef
--- /dev/null
+++ b/sysutils/dvtm/pkg-descr
@@ -0,0 +1,6 @@
+dvtm brings the concept of tiling window management, popularized by X11-window
+managers like dwm to the console. As a console window manager it tries to make
+it easy to work with multiple console based programs like vim, mutt, cmus or
+irssi.
+
+WWW: http://www.brain-dump.org/projects/dvtm/