aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2022-08-09 15:59:40 +0000
committerGleb Popov <arrowd@FreeBSD.org>2022-08-10 16:06:38 +0000
commitfc1eb31d26ee40ebc6ae437a192f072b240be01e (patch)
tree152ac63683ce2b22506ec0d732e5385e5b05349b
parent6abe4c43c998c62cc87dbe5208fe7034d0bb9ed8 (diff)
downloadports-fc1eb31d26ee40ebc6ae437a192f072b240be01e.tar.gz
ports-fc1eb31d26ee40ebc6ae437a192f072b240be01e.zip
textproc/py-dict2xml: Small utility to convert a python dictionary into an XML string
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-dict2xml/Makefile27
-rw-r--r--textproc/py-dict2xml/distinfo3
-rw-r--r--textproc/py-dict2xml/pkg-descr3
4 files changed, 34 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index efe9747ab30a..ddf5e0ab1f5a 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1297,6 +1297,7 @@
SUBDIR += py-csvkit
SUBDIR += py-custom_inherit
SUBDIR += py-dbfread
+ SUBDIR += py-dict2xml
SUBDIR += py-diff-match-patch
SUBDIR += py-docrepr
SUBDIR += py-docstring-parser
diff --git a/textproc/py-dict2xml/Makefile b/textproc/py-dict2xml/Makefile
new file mode 100644
index 000000000000..1e655169facc
--- /dev/null
+++ b/textproc/py-dict2xml/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= dict2xml
+DISTVERSIONPREFIX=release-
+DISTVERSION= 1.7.1
+CATEGORIES= textproc devel python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= arrowd@FreeBSD.org
+COMMENT= Small utility to convert a python dictionary into an XML string
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}noseofyeti>0:devel/py-noseofyeti@${PY_FLAVOR}
+
+USES= python:3.5+
+#doesnt ship tests in sdist
+USE_GITHUB= yes
+USE_PYTHON= autoplist distutils
+
+GH_ACCOUNT= delfick
+GH_PROJECT= python-dict2xml
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -v -rs -o addopts=
+
+.include <bsd.port.mk>
diff --git a/textproc/py-dict2xml/distinfo b/textproc/py-dict2xml/distinfo
new file mode 100644
index 000000000000..d6bd331d3a6d
--- /dev/null
+++ b/textproc/py-dict2xml/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1660008780
+SHA256 (delfick-python-dict2xml-release-1.7.1_GH0.tar.gz) = aded290785a8e19feaeaa93229fbbaa112afa156b020ac2405efcb42def53bcc
+SIZE (delfick-python-dict2xml-release-1.7.1_GH0.tar.gz) = 13092
diff --git a/textproc/py-dict2xml/pkg-descr b/textproc/py-dict2xml/pkg-descr
new file mode 100644
index 000000000000..c9bb98ae7469
--- /dev/null
+++ b/textproc/py-dict2xml/pkg-descr
@@ -0,0 +1,3 @@
+Super Simple utility to convert a python dictionary into an xml string.
+
+WWW: https://github.com/delfick/python-dict2xml