aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-07-05 08:18:50 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-07-06 00:55:40 +0000
commitfc22ccb8146f935eeb6bbc69690a7dd9318e3d83 (patch)
tree722c0da8679db5aadee5c70be50298f2df09f10d
parentfc84bbd28e3e576b9573de6933a92e51e495d9ed (diff)
x11/kitty: drop --ignore-compiler-warnings to apply upstream fix
This reverts commit 4ee5c96d5b5dc6ebcab12f7f2af98915111282b5. (cherry picked from commit daf3e1c51e9826becb370a379e64c85e9f62ca27)
-rw-r--r--x11/kitty/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/x11/kitty/Makefile b/x11/kitty/Makefile
index 9cbf400d6b25..f14183f324ca 100644
--- a/x11/kitty/Makefile
+++ b/x11/kitty/Makefile
@@ -93,10 +93,9 @@ EXTRA_PATCHES= ${PATCHDIR}/extra-patch-kitty_data-types.h
.endif
# For librsync, we need to set header and library path
-# --ignore-compiler-warnings is for https://github.com/kovidgoyal/kitty/issues/6422
do-build:
(cd ${WRKSRC} && \
- ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py linux-package --ignore-compiler-warnings --update-check-interval 0 --extra-include-dirs ${LOCALBASE}/include/ --extra-library-dirs ${LOCALBASE}/lib)
+ ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py linux-package --update-check-interval 0 --extra-include-dirs ${LOCALBASE}/include/ --extra-library-dirs ${LOCALBASE}/lib)
${FIND} ${INSTALL_WRKSRC} -name __pycache__ -type d -exec ${RM} -r -- {} +
do-install: