aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-12-30 17:15:06 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-12-30 17:15:06 +0000
commitfc824512c67150eb3a82b89c67567333edf72cc5 (patch)
treebf29ca76cbe34b0c84a53e2596fa0d1ca56ae7a8
parent16bc7070af770abb33cd0e9c7e64a32f706cc232 (diff)
downloadports-fc824512c67150eb3a82b89c67567333edf72cc5.tar.gz
ports-fc824512c67150eb3a82b89c67567333edf72cc5.zip
More GCC-related fixes in kde@ ports
PR: 234461 Submitted by: Piotr Kubaj <pkubaj@anongoth.pl>
Notes
Notes: svn path=/head/; revision=488723
-rw-r--r--audio/cantata/Makefile2
-rw-r--r--audio/kwave/Makefile2
-rw-r--r--deskutils/kfind/Makefile2
-rw-r--r--devel/dolphin-plugins/Makefile2
-rw-r--r--devel/kdesvn/Makefile2
-rw-r--r--editors/kile/Makefile2
-rw-r--r--games/kgoldrunner/Makefile2
-rw-r--r--games/kreversi/Makefile2
-rw-r--r--games/ksnakeduel/Makefile2
-rw-r--r--games/kspaceduel/Makefile2
-rw-r--r--games/kubrick/Makefile2
-rw-r--r--games/lskat/Makefile2
-rw-r--r--graphics/kgraphviewer/Makefile3
-rw-r--r--graphics/kimagemapeditor/Makefile2
-rw-r--r--graphics/qt5-wayland/Makefile3
-rw-r--r--irc/konversation/Makefile3
-rw-r--r--irc/kvirc/Makefile4
-rw-r--r--lang/kross-interpreters/Makefile2
-rw-r--r--misc/ktouch/Makefile2
-rw-r--r--multimedia/mlt/Makefile3
-rw-r--r--multimedia/phonon-designerplugin/Makefile2
-rw-r--r--multimedia/phonon-vlc/Makefile2
-rw-r--r--net/kget/Makefile2
-rw-r--r--net/zeroconf-ioslave/Makefile2
-rw-r--r--security/kleopatra/Makefile2
-rw-r--r--sysutils/k3b/Makefile4
-rw-r--r--sysutils/kbackup/Makefile2
-rw-r--r--sysutils/sweeper/Makefile2
-rw-r--r--textproc/kdiff3/Makefile2
-rw-r--r--x11/rsibreak/Makefile2
30 files changed, 36 insertions, 32 deletions
diff --git a/audio/cantata/Makefile b/audio/cantata/Makefile
index 12fe1075a81e..5f003a5f6fb8 100644
--- a/audio/cantata/Makefile
+++ b/audio/cantata/Makefile
@@ -11,7 +11,7 @@ COMMENT= Graphical client for MPD using Qt5
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= cmake cpe pkgconfig qt:5 shebangfix
+USES= cmake compiler:c++11-lang cpe pkgconfig qt:5 shebangfix
USE_GITHUB= yes
GH_ACCOUNT= CDrummond
diff --git a/audio/kwave/Makefile b/audio/kwave/Makefile
index 5e74ae3603fe..d1f3650cbad4 100644
--- a/audio/kwave/Makefile
+++ b/audio/kwave/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libaudiofile.so:audio/libaudiofile \
libsamplerate.so:audio/libsamplerate \
libvorbisenc.so:audio/libvorbis
-USES= cmake desktop-file-utils gettext kde:5 \
+USES= cmake compiler:c++11-lang desktop-file-utils gettext kde:5 \
localbase:ldflags pkgconfig qt:5 tar:xz
USE_KDE= archive auth bookmarks codecs completion config configwidgets \
coreaddons crash dbusaddons ecm i18n iconthemes itemviews \
diff --git a/deskutils/kfind/Makefile b/deskutils/kfind/Makefile
index 4741552a5ce8..a0d64d709129 100644
--- a/deskutils/kfind/Makefile
+++ b/deskutils/kfind/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= deskutils kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= Find files and folders
-USES= cmake gettext kde:5 qt:5 tar:xz
+USES= cmake compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= archive auth bookmarks codecs completion config configwidgets \
coreaddons crash ecm filemetadata guiaddons i18n iconthemes itemviews \
jobwidgets kdelibs4support kio notifications parts service \
diff --git a/devel/dolphin-plugins/Makefile b/devel/dolphin-plugins/Makefile
index 063f31524063..32e3fb408188 100644
--- a/devel/dolphin-plugins/Makefile
+++ b/devel/dolphin-plugins/Makefile
@@ -10,7 +10,7 @@ COMMENT= Plugins for Dolphin file manager
BUILD_DEPENDS= dolphin:x11-fm/dolphin
RUN_DEPENDS= dolphin:x11-fm/dolphin
-USES= cmake gettext kde:5 qt:5 tar:xz
+USES= cmake compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth bookmarks codecs completion config configwidgets \
coreaddons crash guiaddons i18n iconthemes itemviews jobwidgets \
kdelibs4support kio notifications parts service solid sonnet \
diff --git a/devel/kdesvn/Makefile b/devel/kdesvn/Makefile
index f857d6778ac9..488be4a6efb2 100644
--- a/devel/kdesvn/Makefile
+++ b/devel/kdesvn/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= libapr-1.so:devel/apr1 \
CONFLICTS_INSTALL= kdesvn-kde4 \
qsvn-[0-9]*
-USES= bdb cmake kde:5 qt:5 tar:xz
+USES= bdb cmake compiler:c++11-lang kde:5 qt:5 tar:xz
USE_KDE= auth bookmarks codecs completion config configwidgets \
coreaddons dbusaddons ecm i18n iconthemes itemviews jobwidgets \
kio notifications parts service sonnet texteditor textwidgets \
diff --git a/editors/kile/Makefile b/editors/kile/Makefile
index f76b1fab37e6..05aab2486825 100644
--- a/editors/kile/Makefile
+++ b/editors/kile/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpoppler.so:graphics/poppler \
libpoppler-qt5.so:graphics/poppler-qt5
-USES= cmake desktop-file-utils kde:5 \
+USES= cmake compiler:c++11-lang desktop-file-utils kde:5 \
qt:5 shared-mime-info shebangfix
USE_KDE= auth bookmarks codecs completion config configwidgets \
coreaddons crash dbusaddons ecm guiaddons i18n iconthemes \
diff --git a/games/kgoldrunner/Makefile b/games/kgoldrunner/Makefile
index 4cb2b429878f..f919ca0c45e3 100644
--- a/games/kgoldrunner/Makefile
+++ b/games/kgoldrunner/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= games kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USES= cmake kde:5 qt:5 tar:xz
+USES= cmake compiler:c++11-lang kde:5 qt:5 tar:xz
USE_KDE= auth codecs completion config configwidgets coreaddons \
crash dbusaddons ecm i18n kio libkdegames service \
widgetsaddons xmlgui
diff --git a/games/kreversi/Makefile b/games/kreversi/Makefile
index c3eac5a85547..d46a9e55c5a5 100644
--- a/games/kreversi/Makefile
+++ b/games/kreversi/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= games kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USES= cmake kde:5 qt:5 tar:xz
+USES= cmake compiler:c++11-lang kde:5 qt:5 tar:xz
USE_KDE= auth bookmarks codecs completion config configwidgets \
coreaddons crash dbusaddons ecm i18n iconthemes itemviews \
jobwidgets kdeclarative kio libkdegames package service \
diff --git a/games/ksnakeduel/Makefile b/games/ksnakeduel/Makefile
index e45dd1a87bd4..6f91c445fb92 100644
--- a/games/ksnakeduel/Makefile
+++ b/games/ksnakeduel/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= games kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USES= cmake kde:5 qt:5 tar:xz
+USES= cmake compiler:c++11-lang kde:5 qt:5 tar:xz
USE_KDE= auth codecs completion config configwidgets coreaddons \
crash dbusaddons ecm guiaddons i18n libkdegames \
widgetsaddons xmlgui
diff --git a/games/kspaceduel/Makefile b/games/kspaceduel/Makefile
index 59a579393fb8..92f44a3d2f89 100644
--- a/games/kspaceduel/Makefile
+++ b/games/kspaceduel/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= games kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USES= cmake kde:5 qt:5 tar:xz
+USES= cmake compiler:c++11-lang kde:5 qt:5 tar:xz
USE_KDE= auth codecs completion config configwidgets coreaddons \
crash dbusaddons ecm i18n libkdegames widgetsaddons xmlgui
USE_QT= core dbus declarative gui network svg widgets xml \
diff --git a/games/kubrick/Makefile b/games/kubrick/Makefile
index 65c85189811f..8605076298e1 100644
--- a/games/kubrick/Makefile
+++ b/games/kubrick/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= games kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USES= cmake kde:5 qt:5 tar:xz
+USES= cmake compiler:c++11-lang kde:5 qt:5 tar:xz
USE_GL= gl glu
USE_KDE= auth codecs config configwidgets coreaddons crash ecm \
i18n kio libkdegames service widgetsaddons xmlgui
diff --git a/games/lskat/Makefile b/games/lskat/Makefile
index 9597a30a7251..52f8dab08d2e 100644
--- a/games/lskat/Makefile
+++ b/games/lskat/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= games kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USES= cmake kde:5 qt:5 tar:xz
+USES= cmake compiler:c++11-lang kde:5 qt:5 tar:xz
USE_KDE= auth codecs config configwidgets coreaddons crash ecm \
guiaddons i18n libkdegames notifyconfig widgetsaddons xmlgui
USE_QT= core dbus declarative gui network svg widgets xml \
diff --git a/graphics/kgraphviewer/Makefile b/graphics/kgraphviewer/Makefile
index 6aee97ed77e9..8ee05a6a0aeb 100644
--- a/graphics/kgraphviewer/Makefile
+++ b/graphics/kgraphviewer/Makefile
@@ -14,7 +14,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libgvc.so:graphics/graphviz
-USES= cmake desktop-file-utils kde:5 qt:5 tar:xz pkgconfig
+USES= cmake compiler:c++11-lang desktop-file-utils kde:5 qt:5 tar:xz \
+ pkgconfig
USE_KDE= auth codecs completion config configwidgets \
coreaddons i18n iconthemes jobwidgets kio parts service \
sonnet textwidgets widgetsaddons xmlgui \
diff --git a/graphics/kimagemapeditor/Makefile b/graphics/kimagemapeditor/Makefile
index 28e265e6e662..ba849668abab 100644
--- a/graphics/kimagemapeditor/Makefile
+++ b/graphics/kimagemapeditor/Makefile
@@ -8,7 +8,7 @@ PKGNAMESUFFIX= # hack: uses kde:4 but we don't want the pkgname suffix
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE generator of HTML image maps
-USES= cmake kde:5 qt:5 tar:xz
+USES= cmake compiler:c++11-lang kde:5 qt:5 tar:xz
USE_KDE= auth bookmarks codecs completion config configwidgets \
coreaddons crash guiaddons i18n iconthemes itemviews \
jobwidgets js kdelibs4support khtml kio notifications \
diff --git a/graphics/qt5-wayland/Makefile b/graphics/qt5-wayland/Makefile
index 6d0f98ca6cbe..bfb8c14b14f3 100644
--- a/graphics/qt5-wayland/Makefile
+++ b/graphics/qt5-wayland/Makefile
@@ -13,7 +13,8 @@ LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libwayland-egl.so:graphics/wayland \
libxkbcommon.so:x11/libxkbcommon
-USES= pkgconfig qmake:norecursive qt-dist:5,wayland
+USES= compiler:c++11-lang gl gnome pkgconfig qmake:norecursive \
+ qt-dist:5,wayland
USE_GL= egl gl
USE_GNOME= glib20
USE_QT= core dbus gui declarative \
diff --git a/irc/konversation/Makefile b/irc/konversation/Makefile
index 06d7d3fcca88..d86bca259bd1 100644
--- a/irc/konversation/Makefile
+++ b/irc/konversation/Makefile
@@ -14,7 +14,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libqca-qt5.so:devel/qca@qt5
-USES= cmake desktop-file-utils gettext kde:5 python:run qt:5 shebangfix tar:xz
+USES= cmake compiler:c++11-lang desktop-file-utils gettext kde:5 \
+ python:run qt:5 shebangfix tar:xz
USE_KDE= archive auth bookmarks codecs completion config \
configwidgets coreaddons crash dbusaddons doctools ecm \
emoticons globalaccel i18n iconthemes idletime itemviews \
diff --git a/irc/kvirc/Makefile b/irc/kvirc/Makefile
index 9a64e07f29eb..c0e7bcdda5ae 100644
--- a/irc/kvirc/Makefile
+++ b/irc/kvirc/Makefile
@@ -11,8 +11,8 @@ COMMENT= IRC client for KDE
LIB_DEPENDS= libaudiofile.so:audio/libaudiofile \
libenchant.so:textproc/enchant
-USES= cmake cpe desktop-file-utils gettext gnome kde:5 perl5 \
- pkgconfig python qt:5 ssl tar:bzip2
+USES= cmake compiler:c++11-lang cpe desktop-file-utils gettext gnome \
+ kde:5 perl5 pkgconfig python qt:5 ssl tar:bzip2
USE_GNOME= glib20
USE_PERL5= build
USE_KDE= auth codecs config configwidgets coreaddons i18n notifications \
diff --git a/lang/kross-interpreters/Makefile b/lang/kross-interpreters/Makefile
index 5a0b51f2d93c..a15dab53a757 100644
--- a/lang/kross-interpreters/Makefile
+++ b/lang/kross-interpreters/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= lang kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= Language interpreters to enable in-process scripting with Kross
-USES= cmake gettext kde:5 python:2.7 qt:5 tar:xz
+USES= cmake compiler:c++11-lang gettext kde:5 python:2.7 qt:5 tar:xz
USE_KDE= ecm kross
USE_QT= core gui script widgets xml \
buildtools_build qmake_build
diff --git a/misc/ktouch/Makefile b/misc/ktouch/Makefile
index 15f0bbb7d311..e8f55a2d27a5 100644
--- a/misc/ktouch/Makefile
+++ b/misc/ktouch/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= misc kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= Touch typing tutor for KDE
-USES= cmake gettext kde:5 qt:5 tar:xz
+USES= cmake compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs completion config configwidgets coreaddons doctools \
ecm i18n itemviews kcmutils kdeclarative kio newstuff package \
parts service sonnet texteditor textwidgets widgetsaddons \
diff --git a/multimedia/mlt/Makefile b/multimedia/mlt/Makefile
index e1b856b26035..b3590a141c44 100644
--- a/multimedia/mlt/Makefile
+++ b/multimedia/mlt/Makefile
@@ -12,7 +12,8 @@ COMMENT?= Multimedia framework for TV broadcasting
LICENSE?= GPLv2 GPLv3 LGPL21
LICENSE_COMB?= multi
-USES+= alias eigen:3 gmake localbase pkgconfig
+USES+= alias compiler:c++11-lang eigen:3 gl gmake gnome localbase \
+ pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--enable-gpl --enable-gpl3 --target-os=FreeBSD
USE_GITHUB= yes
diff --git a/multimedia/phonon-designerplugin/Makefile b/multimedia/phonon-designerplugin/Makefile
index 4117f428a059..eb9c90df0625 100644
--- a/multimedia/phonon-designerplugin/Makefile
+++ b/multimedia/phonon-designerplugin/Makefile
@@ -28,7 +28,7 @@ USE_QT= corelib designer gui phonon \
qmake_build moc_build rcc_build uic_build
PLIST_FILES= ${QT_PLUGINDIR_REL}/designer/libphononwidgets.so
. else
-USES+= kde:5 qt:5
+USES+= compiler:c++11-lang kde:5 qt:5
USE_KDE= ecm
USE_QT= core designer gui phonon4 widgets xml \
buildtools_build qmake_build
diff --git a/multimedia/phonon-vlc/Makefile b/multimedia/phonon-vlc/Makefile
index aaea70f4bd64..0cfa5fadf955 100644
--- a/multimedia/phonon-vlc/Makefile
+++ b/multimedia/phonon-vlc/Makefile
@@ -34,7 +34,7 @@ PLIST_FILES= lib/kde4/plugins/phonon_backend/phonon_vlc.so \
share/kde4/services/phononbackends/vlc.desktop \
${QT_PLUGINDIR}/phonon_backend/libphonon_vlc.so
. else
-USES+= kde:5 qt:5
+USES+= compiler:c++11-lang kde:5 qt:5
USE_KDE= ecm
USE_QT= core gui widgets phonon4 \
buildtools_build qmake_build
diff --git a/net/kget/Makefile b/net/kget/Makefile
index fb818aaf9fe0..08cd735005ab 100644
--- a/net/kget/Makefile
+++ b/net/kget/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libKF5Torrent.so:net-p2p/libktorrent \
libqca-qt5.so:devel/qca@qt5 \
libqgpgme.so:security/gpgme-qt5
-USES= cmake kde:5 qt:5 shebangfix sqlite tar:xz
+USES= cmake compiler:c++11-lang kde:5 qt:5 shebangfix sqlite tar:xz
USE_KDE= archive auth bookmarks codecs completion config configwidgets \
coreaddons crash dbusaddons emoticons guiaddons i18n \
diff --git a/net/zeroconf-ioslave/Makefile b/net/zeroconf-ioslave/Makefile
index 15f0f18045ce..1423c97cbac5 100644
--- a/net/zeroconf-ioslave/Makefile
+++ b/net/zeroconf-ioslave/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= net kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE Network monitor for DNS-SD services (Zeroconf)
-USES= cmake kde:5 qt:5 tar:xz
+USES= cmake compiler:c++11-lang kde:5 qt:5 tar:xz
USE_KDE= config coreaddons dbusaddons dnssd i18n kio service
USE_QT= core dbus network \
buildtools_build qmake_build
diff --git a/security/kleopatra/Makefile b/security/kleopatra/Makefile
index 1852eb861a02..633f8253222f 100644
--- a/security/kleopatra/Makefile
+++ b/security/kleopatra/Makefile
@@ -14,7 +14,7 @@ LIB_DEPENDS= libassuan.so:security/libassuan \
libgpgmepp.so:security/gpgme-cpp \
libqgpgme.so:security/gpgme-qt5
-USES= cmake gettext kde:5 qt:5 tar:xz
+USES= cmake compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs config configwidgets coreaddons dbusaddons \
doctools ecm i18n iconthemes itemmodels kcmutils notifications \
service sonnet textwidgets widgetsaddons windowsystem xmlgui \
diff --git a/sysutils/k3b/Makefile b/sysutils/k3b/Makefile
index 70640582d16b..c8c33859bf84 100644
--- a/sysutils/k3b/Makefile
+++ b/sysutils/k3b/Makefile
@@ -21,8 +21,8 @@ LIB_DEPENDS= libFLAC.so:audio/flac \
RUN_DEPENDS= cdrecord:sysutils/cdrtools
BUILD_DEPENDS= cdrecord:sysutils/cdrtools
-USES= cmake desktop-file-utils gettext iconv kde:5 pkgconfig \
- qt:5 shared-mime-info tar:xz
+USES= cmake compiler:c++11-lang desktop-file-utils gettext iconv \
+ kde:5 pkgconfig qt:5 shared-mime-info tar:xz
USE_KDE= archive attica auth bookmarks codecs completion config \
configwidgets coreaddons ecm filemetadata i18n iconthemes \
diff --git a/sysutils/kbackup/Makefile b/sysutils/kbackup/Makefile
index 3d244bb4b75e..f97c9b515c74 100644
--- a/sysutils/kbackup/Makefile
+++ b/sysutils/kbackup/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= sysutils kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= Backup program with an easy to use user interface
-USES= cmake gettext kde:5 qt:5 tar:xz
+USES= cmake compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= archive auth bookmarks codecs completion config configwidgets \
coreaddons ecm i18n iconthemes itemviews jobwidgets kio \
notifications service solid widgetsaddons xmlgui
diff --git a/sysutils/sweeper/Makefile b/sysutils/sweeper/Makefile
index 7e995b070028..01e2daca19c3 100644
--- a/sysutils/sweeper/Makefile
+++ b/sysutils/sweeper/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= sysutils kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= Cleans temporal files for KDE
-USES= cmake kde:5 qt:5 tar:xz
+USES= cmake compiler:c++11-lang kde:5 qt:5 tar:xz
USE_KDE= activities-stats auth bookmarks codecs config configwidgets \
coreaddons crash i18n kio service sonnet textwidgets \
widgetsaddons xmlgui
diff --git a/textproc/kdiff3/Makefile b/textproc/kdiff3/Makefile
index 30ab9bc57594..567c594712fa 100644
--- a/textproc/kdiff3/Makefile
+++ b/textproc/kdiff3/Makefile
@@ -10,7 +10,7 @@ COMMENT= KDE graphical frontend for diff
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= cmake kde:5 qt:5
+USES= cmake compiler:c++11-lang kde:5 qt:5
USE_GITHUB= yes
GH_ACCOUNT= KDE
GH_TAGNAME= 42403aa
diff --git a/x11/rsibreak/Makefile b/x11/rsibreak/Makefile
index 5e3f1ccc216a..a0fc6de9e842 100644
--- a/x11/rsibreak/Makefile
+++ b/x11/rsibreak/Makefile
@@ -12,7 +12,7 @@ COMMENT= KDE RSI prevention tool
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= cmake gettext kde:5 qt:5 tar:xz
+USES= cmake compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs config configwidgets coreaddons crash dbusaddons doctools ecm \
iconthemes i18n idletime notifications notifyconfig \
sonnet textwidgets xmlgui widgetsaddons windowsystem