aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2004-03-15 21:29:05 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2004-03-15 21:29:05 +0000
commitfcbe6b8ed08502685675ceb6154a5e38e768f3ce (patch)
treefc47a89213dd42fb7c888739ce46c9ad0eade5b3
parent42a2f9713e73da80a77791437de942e4cfe1b81e (diff)
downloadports-fcbe6b8ed08502685675ceb6154a5e38e768f3ce.tar.gz
ports-fcbe6b8ed08502685675ceb6154a5e38e768f3ce.zip
Update to 1.6.8 (under new maintenance). Change location of Perl
executable, to work properly on -STABLE. PR: 57726 Submitted by: ijliao
Notes
Notes: svn path=/head/; revision=104112
-rw-r--r--devel/cvslines/Makefile10
-rw-r--r--devel/cvslines/distinfo4
-rw-r--r--devel/cvslines/files/patch-aa20
-rw-r--r--devel/cvslines/files/patch-ab31
-rw-r--r--devel/cvslines/pkg-descr2
5 files changed, 36 insertions, 31 deletions
diff --git a/devel/cvslines/Makefile b/devel/cvslines/Makefile
index 527cb3285099..614821354439 100644
--- a/devel/cvslines/Makefile
+++ b/devel/cvslines/Makefile
@@ -6,15 +6,15 @@
#
PORTNAME= cvslines
-PORTVERSION= 1.6.7
+PORTVERSION= 1.6.8
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_LOCAL} \
- http://www.netsw.org/softeng/versioncontrol/repository/cvs/cvslines/
-MASTER_SITE_SUBDIR= jkoshy
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= trevor@FreeBSD.org
COMMENT= Wrapper to ease merging of changes between CVS branches
+WRKSRC= ${WRKDIR}/${PORTNAME}
PLIST= ${WRKDIR}/pkg-plist
USE_PERL5= yes
NO_BUILD= yes
@@ -22,7 +22,7 @@ NO_BUILD= yes
MAN1= cvslines.1
pre-patch:
- ${PERL} -pi -e "s:usr/local/bin/perl5:${PERL5}:g" ${WRKSRC}/cvslines
+ ${PERL} -pi -e "s:usr/bin/perl5:${PERL5}:g" ${WRKSRC}/cvslines
${PERL} -pi -e "s:the the:the:g" ${WRKSRC}/cvslines.1
pre-install:
diff --git a/devel/cvslines/distinfo b/devel/cvslines/distinfo
index e7c2a8b38eec..330c5b55e203 100644
--- a/devel/cvslines/distinfo
+++ b/devel/cvslines/distinfo
@@ -1,2 +1,2 @@
-MD5 (cvslines-1.6.7.tar.gz) = efca84137a552925f84b0084d833021a
-SIZE (cvslines-1.6.7.tar.gz) = 123518
+MD5 (cvslines-1.6.8.tar.gz) = 593dee98bdfd5a8e238114fa09f5aa13
+SIZE (cvslines-1.6.8.tar.gz) = 141464
diff --git a/devel/cvslines/files/patch-aa b/devel/cvslines/files/patch-aa
index 906c7ad6f8cd..f49c9c2555cb 100644
--- a/devel/cvslines/files/patch-aa
+++ b/devel/cvslines/files/patch-aa
@@ -1,10 +1,10 @@
---- CONFIG.old Wed May 21 11:39:38 1997
-+++ CONFIG Fri Feb 1 04:43:42 2002
+--- CONFIG.orig Wed Oct 8 09:16:47 2003
++++ CONFIG Wed Oct 8 09:18:54 2003
@@ -14,17 +14,17 @@
# The absolute path to the perl interpreter to use.
# INSTALL will substitute this into the #!... line.
#
--if (! defined($PERL5)) { $PERL5 = "/usr/local/bin/perl5"; } # cfg
+-if (! defined($PERL5)) { $PERL5 = "/usr/bin/perl"; } # cfg
+if (! defined($PERL5)) { $PERL5 = "$ENV{'PERL5'}"; } # cfg
# Where to install the cvslines scripts...
@@ -21,12 +21,12 @@
######################################################################
#
-@@ -52,7 +52,7 @@
-
- # Where the RCS to use with cvslines is kept.
+@@ -40,7 +40,7 @@
+ # This is used so that debug versions can know they are and alter
+ # logging behavior, etc.
#
--\$RCSBIN = "$BINDIR"; # cfg
-+\$RCSBIN = "/usr/bin/"; # cfg
-
- 1;
+-\$RELDIR = "$BINDIR"; # cfg
++\$RELDIR = "/usr/bin"; # cfg
+ # Where the cvslines log file is written.
+ #
diff --git a/devel/cvslines/files/patch-ab b/devel/cvslines/files/patch-ab
index 9265dc0bbc4d..df0e8010cc13 100644
--- a/devel/cvslines/files/patch-ab
+++ b/devel/cvslines/files/patch-ab
@@ -1,5 +1,5 @@
---- INSTALL-- Thu May 22 03:36:16 1997
-+++ INSTALL Tue Aug 25 14:26:30 1998
+--- INSTALL.orig Fri Apr 19 21:26:39 2002
++++ INSTALL Wed Oct 8 09:22:22 2003
@@ -73,7 +73,7 @@
}
@@ -9,24 +9,29 @@
($u_os, $u_host, $u_osrel) = split(/\s+/, $uname);
# Try to find things in the usual places, but failing those,
-@@ -121,7 +121,8 @@
- {
+@@ -122,6 +122,7 @@
if ( ! ( ($u_os eq "SunOS" && $u_osrel =~ /^5\./)
|| ($u_os eq "SunOS" && $u_osrel =~ /^4\./)
-- || ($u_os eq "OSF1" && $u_osrel =~ /^V[34]\./)))
-+ || ($u_os eq "OSF1" && $u_osrel =~ /^V[34]\./)
-+ || ($u_os eq "FreeBSD")))
+ || ($u_os eq "OSF1" && $u_osrel =~ /^V[34]\./)
++ || ($u_os eq "FreeBSD")
+ || ($u_os eq "Linux")))
{
print STDERR <<MSG;
- $Myname:
-@@ -148,9 +149,8 @@
- cvslines has been tested with cvs 1.9. The "cvs" command found via
- your \$PATH provided the following version information:
+@@ -134,7 +135,7 @@
+
+ (press Return to continue with the install...)
+ MSG
+- $ans = <STDIN>;
++# $ans = <STDIN>;
+ }
+
+ $cvs_versmsg = `cvs -v`;
+@@ -151,7 +152,7 @@
$cvs_versmsg
-- (press Return to continue with the install...)
+ (press Return to continue with the install...)
MSG
- $ans = <STDIN>;
-+ # $ans = <STDIN>;
++# $ans = <STDIN>;
}
}
diff --git a/devel/cvslines/pkg-descr b/devel/cvslines/pkg-descr
index 6717801378d8..320a27a1a24e 100644
--- a/devel/cvslines/pkg-descr
+++ b/devel/cvslines/pkg-descr
@@ -5,4 +5,4 @@ cvslines is a "wrapper" facility that helps out with merging changes
between various cvs branches, where the branches represent different
lines of development.
-WWW: http://www.floating.co.uk/netapp/technology/freeware/cvslines/
+WWW: http://cvslines.sf.net/menu.html