aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleksii Samorukov <samm@FreeBSD.org>2023-06-06 04:56:40 +0000
committerOleksii Samorukov <samm@FreeBSD.org>2023-06-06 04:58:47 +0000
commitfcc69d210225054e6cc9ea207caab294ce18fe8e (patch)
treec9317e85d75a81a52d5f302f199d4e9a0978ba33
parentd9c7bd925458d6d51ddbdafe03cf1e5a1a422c16 (diff)
downloadports-fcc69d210225054e6cc9ea207caab294ce18fe8e.tar.gz
ports-fcc69d210225054e6cc9ea207caab294ce18fe8e.zip
databases/xtrabackup: fix build on the i386 platform
- Copy fix from the databases/mysql57-server to fix boost compliation - Remove all clang workaround as not needed anymore
-rw-r--r--databases/xtrabackup/Makefile15
1 files changed, 4 insertions, 11 deletions
diff --git a/databases/xtrabackup/Makefile b/databases/xtrabackup/Makefile
index c759124e9a52..d5a5f4c0e81f 100644
--- a/databases/xtrabackup/Makefile
+++ b/databases/xtrabackup/Makefile
@@ -42,20 +42,13 @@ PLIST_FILES= bin/xtrabackup bin/xbstream bin/innobackupex bin/xbcrypt \
bin/xbcloud bin/xbcloud_osenv
.include <bsd.port.pre.mk>
-# xtrabackup/mysql57 fails to compile with llvm11, which was imported to current in r364284
-# without a version increase (1300109 = r364274).
-# Until a proper fix is provided, simply use llvm from ports, which probably could be
-# a backport of amongst other tings:
-# https://github.com/mysql/mysql-server/commit/08f46b3c00ee70e7ed7825daeb91df2289f80f50
-.if ${CHOSEN_COMPILER_TYPE} == clang && ${OPSYS} == FreeBSD && ${OSVERSION} >= 1300109
-_LLVM_VERSION= 10
-BUILD_DEPENDS+= clang${_LLVM_VERSION}:devel/llvm${_LLVM_VERSION}
-CC= ${LOCALBASE}/bin/clang${_LLVM_VERSION}
-CXX= ${LOCALBASE}/bin/clang++${_LLVM_VERSION}
-.endif
# Not sure why it's trying to install mysql client libraries now
post-install:
${RM} -rf ${STAGEDIR}${LOCALBASE}/lib
+post-patch:
+ @${REINPLACE_CMD} -e 's|__clang__|__undefined__|g' \
+ ${WRKDIR}/boost_1_59_0/boost/atomic/detail/ops_gcc_x86_dcas.hpp
+
.include <bsd.port.post.mk>