aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2022-07-11 06:49:37 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2022-07-11 06:52:46 +0000
commitfcc8d20575d2389e3df411c7c4b05a2439b12987 (patch)
tree395c53f6db5d7a37d7fd8cb52c67e7aaae867009
parentcfa6fa4ee7ff30866ded959d06e9c45e5770d6e2 (diff)
downloadports-fcc8d20575d2389e3df411c7c4b05a2439b12987.tar.gz
ports-fcc8d20575d2389e3df411c7c4b05a2439b12987.zip
graphics/py-projpicker: New port: Pick CRS (projection) from coordinates
ProjPicker (projection picker) is a Python module that allows the user to select all coordinate reference systems (CRSs) whose extent completely contains given points, polylines, polygons, and bounding boxes using set-theoretic logical operators in a postfix notation. The goal is to make it easy and visual to select a desired projection by location.
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-projpicker/Makefile18
-rw-r--r--graphics/py-projpicker/distinfo3
-rw-r--r--graphics/py-projpicker/pkg-descr7
4 files changed, 29 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index b73569570c04..eb70a6022298 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -883,6 +883,7 @@
SUBDIR += py-plotly
SUBDIR += py-png
SUBDIR += py-pointpats
+ SUBDIR += py-projpicker
SUBDIR += py-pycha
SUBDIR += py-pycollada
SUBDIR += py-pydot
diff --git a/graphics/py-projpicker/Makefile b/graphics/py-projpicker/Makefile
new file mode 100644
index 000000000000..c65be91c2f09
--- /dev/null
+++ b/graphics/py-projpicker/Makefile
@@ -0,0 +1,18 @@
+PORTNAME= projpicker
+DISTVERSION= 0.3.2
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= lbartoletti@FreeBSD.org
+COMMENT= Select projections whose extent completely contains given coordinates
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/graphics/py-projpicker/distinfo b/graphics/py-projpicker/distinfo
new file mode 100644
index 000000000000..b23b15af3a13
--- /dev/null
+++ b/graphics/py-projpicker/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1657270384
+SHA256 (projpicker-0.3.2.tar.gz) = 88bf4408700d631e2617944dc2c20c42dbe78801ed99d1a26501d7a500654899
+SIZE (projpicker-0.3.2.tar.gz) = 778323
diff --git a/graphics/py-projpicker/pkg-descr b/graphics/py-projpicker/pkg-descr
new file mode 100644
index 000000000000..0b1d6f39a529
--- /dev/null
+++ b/graphics/py-projpicker/pkg-descr
@@ -0,0 +1,7 @@
+ProjPicker (projection picker) is a Python module that allows the user to
+select all coordinate reference systems (CRSs) whose extent completely contains
+given points, polylines, polygons, and bounding boxes using set-theoretic
+logical operators in a postfix notation. The goal is to make it easy and visual
+to select a desired projection by location.
+
+WWW: https://pypi.python.org/pypi/projpicker