aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2024-07-16 10:23:28 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2024-07-16 10:26:26 +0000
commitfcde585fc4ada619f5428867d042c577a53a1fa3 (patch)
treee5bb63ec67aa9e6a31161b5cfebe4b73883391ab
parent10a97a7b95918ba9f2f657c42125e054733178d7 (diff)
lang/chicken: update to 5.4.0
-rw-r--r--lang/chicken/Makefile7
-rw-r--r--lang/chicken/distinfo6
-rw-r--r--lang/chicken/files/patch-egg-compile.scm26
3 files changed, 5 insertions, 34 deletions
diff --git a/lang/chicken/Makefile b/lang/chicken/Makefile
index d9e9dcd9bb3f..7cd788dc2b92 100644
--- a/lang/chicken/Makefile
+++ b/lang/chicken/Makefile
@@ -1,6 +1,5 @@
PORTNAME= chicken
-DISTVERSION= 5.3.0
-PORTREVISION= 4
+DISTVERSION= 5.4.0
PORTEPOCH= 1
CATEGORIES= lang scheme
MASTER_SITES= https://code.call-cc.org/releases/${DISTVERSION}/
@@ -28,10 +27,8 @@ MAKE_ARGS= C_COMPILER="${CC}" \
LIBRARIAN="${AR}" \
LINKER_OPTIONS="${LDFLAGS}" \
MANDIR=${PREFIX}/share/man \
- PREFIX=${PREFIX} \
- CHICKEN=./chicken
+ PREFIX=${PREFIX}
-MAKE_JOBS_UNSAFE= yes
TEST_TARGET= check
TEST_ARGS= ${MAKE_ARGS} PROGRAM_PREFIX=chicken-
diff --git a/lang/chicken/distinfo b/lang/chicken/distinfo
index fff5f495bc54..2ee2f2fc18cc 100644
--- a/lang/chicken/distinfo
+++ b/lang/chicken/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1637825548
-SHA256 (chicken-5.3.0.tar.gz) = c3ad99d8f9e17ed810912ef981ac3b0c2e2f46fb0ecc033b5c3b6dca1bdb0d76
-SIZE (chicken-5.3.0.tar.gz) = 4069549
+TIMESTAMP = 1721112689
+SHA256 (chicken-5.4.0.tar.gz) = 3c5d4aa61c1167bf6d9bf9eaf891da7630ba9f5f3c15bf09515a7039bfcdec5f
+SIZE (chicken-5.4.0.tar.gz) = 4109135
diff --git a/lang/chicken/files/patch-egg-compile.scm b/lang/chicken/files/patch-egg-compile.scm
deleted file mode 100644
index d17adafbc42e..000000000000
--- a/lang/chicken/files/patch-egg-compile.scm
+++ /dev/null
@@ -1,26 +0,0 @@
-From 360e1c423b5475fa2c1caba1f19d652538a8f322 Mon Sep 17 00:00:00 2001
-From: Peter Bex <peter@more-magic.net>
-Date: Mon, 31 Oct 2022 13:06:26 +0100
-Subject: [PATCH 1/1] Do not double call normalize-destination on share dir
-
-In install-random-files, don't call normalize-destination on the
-destination directory - this is already done in compile-egg-info
-
-Before, we'd see things like in the install script like:
- mkdir -p /path/to/chicken/path/to/chicken/share
-With this patch, it becomes:
- mkdir -p /path/to/chicken/share
-which is as it should be.
-
-Signed-off-by: felix <felix@call-with-current-continuation.org>
---- egg-compile.scm.orig 2021-11-18 06:32:06 UTC
-+++ egg-compile.scm
-@@ -1051,7 +1051,7 @@
- (root (string-append srcdir "/"))
- (mkdir (mkdir-command platform))
- (sfiles (map (cut prefix srcdir <>) files))
-- (dfile (qs* (normalize-destination dest mode) platform #t))
-+ (dfile (qs* dest platform #t))
- (ddir (shell-variable "DESTDIR" platform)))
- (print "\n" mkdir " " ddir dfile)
- (let-values (((ds fs) (partition directory? sfiles)))