aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-04 12:43:16 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-04 13:23:26 +0000
commitfce113a37e9ec484648b947cd90f098687bdf96e (patch)
treeb22fc242b2aea5e7f498ecece58942b5d7811f2d
parent6320c4cdd10feafdb8e0dc447c133e11552b1cbe (diff)
downloadports-fce113a37e9ec484648b947cd90f098687bdf96e.tar.gz
ports-fce113a37e9ec484648b947cd90f098687bdf96e.zip
graphics/quat-gui: Fix build with llvm15
- Pet portclippy - Adopt port
-rw-r--r--graphics/quat-gui/Makefile27
1 files changed, 15 insertions, 12 deletions
diff --git a/graphics/quat-gui/Makefile b/graphics/quat-gui/Makefile
index 4734649b2276..cca3f6276159 100644
--- a/graphics/quat-gui/Makefile
+++ b/graphics/quat-gui/Makefile
@@ -5,7 +5,7 @@ CATEGORIES= graphics
MASTER_SITES= https://www.physcip.uni-stuttgart.de/pages/~phy11733/download/
PKGNAMESUFFIX= -gui
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= bofh@FreeBSD.org
COMMENT= Three-dimensional fractal creator (X11 GUI)
WWW= https://www.physcip.uni-stuttgart.de/pages/~phy11733/index_e.html
@@ -13,27 +13,30 @@ LICENSE= GPLv2+
LIB_DEPENDS= libfltk.so:x11-toolkits/fltk
-OPTIONS_DEFINE= OPTIMIZED_CFLAGS DOCS
-
-USES= gl xorg
-USE_XORG= xext
+USES= gl localbase:ldflags xorg
USE_GL= gl glut
+USE_XORG= xext
+
GNU_CONFIGURE= yes
-CONFIGURE_ENV= FLUID="${LOCALBASE}/bin/fluid"
CONFIGURE_ARGS= --datadir=${PREFIX}/share/doc
-
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= FLUID="${LOCALBASE}/bin/fluid"
DOCSDIR= ${PREFIX}/share/doc/${PKGBASE}
+DESKTOP_ENTRIES="Quat" "3D Fractal Generator" "" "${PORTNAME}" "" ""
-PORTDOCS= *
PLIST_FILES= bin/quat
+PORTDOCS= *
-DESKTOP_ENTRIES="Quat" "3D Fractal Generator" "" "${PORTNAME}" "" ""
+OPTIONS_DEFINE= OPTIMIZED_CFLAGS DOCS
OPTIMIZED_CFLAGS_CFLAGS= -O3 -ffast-math
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
+CFLAGS+= -Wno-error=int-conversion
+.endif
+
post-patch:
@${REINPLACE_CMD} -E -e \
's,-(march=pentium|O3|ffast-math),,g' \
@@ -60,4 +63,4 @@ post-install-DOCS-on:
@(cd ${WRKSRC}/doc && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} \
${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>