aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2023-05-05 06:31:14 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2023-05-05 06:31:14 +0000
commitfcfb4ecb19567c9dbb5cde5db4070c51cd5d4058 (patch)
treee7f6b54181c3247456abd7100c190c97469148b3
parentcb7dcff5d1dadfcf60c46e8dc332798c05cec023 (diff)
downloadports-fcfb4ecb19567c9dbb5cde5db4070c51cd5d4058.tar.gz
ports-fcfb4ecb19567c9dbb5cde5db4070c51cd5d4058.zip
sysutils/ntfs2btrfs: the port had been updated to version 20230501
- Back out upstream commit b456295 (walk_btree: use concept rather than std::function) to unbreak the build on older FreeBSD versions - Reword port description slightly for better readability and looks Reported by: portscout
-rw-r--r--sysutils/ntfs2btrfs/Makefile4
-rw-r--r--sysutils/ntfs2btrfs/distinfo6
-rw-r--r--sysutils/ntfs2btrfs/files/patch-src_ntfs.cpp11
-rw-r--r--sysutils/ntfs2btrfs/pkg-descr6
4 files changed, 19 insertions, 8 deletions
diff --git a/sysutils/ntfs2btrfs/Makefile b/sysutils/ntfs2btrfs/Makefile
index 358e6dba4554..7d8ea00fc08a 100644
--- a/sysutils/ntfs2btrfs/Makefile
+++ b/sysutils/ntfs2btrfs/Makefile
@@ -1,5 +1,5 @@
PORTNAME= ntfs2btrfs
-PORTVERSION= 20220812
+PORTVERSION= 20230501
CATEGORIES= sysutils
MAINTAINER= danfe@FreeBSD.org
@@ -19,7 +19,7 @@ PLIST_FILES= sbin/${PORTNAME} share/man/man8/${PORTNAME}.8.gz
post-patch:
# One should not try to mmap(2) disk devices on FreeBSD, it won't work
- @${REINPLACE_CMD} -e '3390s,WIN32,_${OPSYS}__,' \
+ @${REINPLACE_CMD} -e '3449s,WIN32,_${OPSYS}__,' \
${WRKSRC}/src/ntfs2btrfs.cpp
.include <bsd.port.mk>
diff --git a/sysutils/ntfs2btrfs/distinfo b/sysutils/ntfs2btrfs/distinfo
index 632de3f2784e..e0ecb1e9b75e 100644
--- a/sysutils/ntfs2btrfs/distinfo
+++ b/sysutils/ntfs2btrfs/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1660262820
-SHA256 (maharmstone-ntfs2btrfs-20220812_GH0.tar.gz) = 9ce07535e6191ab45f204a4dd281be4768d7917df4426ee7c71aa9c308a2fe93
-SIZE (maharmstone-ntfs2btrfs-20220812_GH0.tar.gz) = 98059
+TIMESTAMP = 1682974776
+SHA256 (maharmstone-ntfs2btrfs-20230501_GH0.tar.gz) = 15924a22e9d80e4ca28bf5524708dd8f69d840df1e781a659ce953fee7d90730
+SIZE (maharmstone-ntfs2btrfs-20230501_GH0.tar.gz) = 98816
diff --git a/sysutils/ntfs2btrfs/files/patch-src_ntfs.cpp b/sysutils/ntfs2btrfs/files/patch-src_ntfs.cpp
new file mode 100644
index 000000000000..74817c12412f
--- /dev/null
+++ b/sysutils/ntfs2btrfs/files/patch-src_ntfs.cpp
@@ -0,0 +1,11 @@
+--- src/ntfs.cpp.orig 2023-05-01 20:59:36 UTC
++++ src/ntfs.cpp
+@@ -465,7 +465,7 @@ string_view ntfs::find_sd(uint32_t id, ntfs_file& secu
+ }
+
+ static void walk_btree(const index_root& ir, const list<mapping>& mappings, const index_node_header& inh, ntfs& dev,
+- const invocable<const index_entry&, string_view> auto& func, unsigned int level) {
++ const function<void(const index_entry&, string_view)>& func, unsigned int level) {
+ auto ent = reinterpret_cast<const index_entry*>((uint8_t*)&inh + inh.first_entry);
+
+ do {
diff --git a/sysutils/ntfs2btrfs/pkg-descr b/sysutils/ntfs2btrfs/pkg-descr
index ed0ee1654542..6845f5661a10 100644
--- a/sysutils/ntfs2btrfs/pkg-descr
+++ b/sysutils/ntfs2btrfs/pkg-descr
@@ -1,5 +1,5 @@
Ntfs2btrfs is a tool which does in-place conversion of Microsoft's NTFS
file system to the open-source file system Btrfs, much as btrfs-convert
-does for ext2. The original image is saved as a reflink copy at
-``image/ntfs.img'', and if you want to keep the conversion you can delete
-this to free up space.
+does for ext2. The original file system image is saved as a reflink copy
+at `image/ntfs.img', and can be deleted to free up space if you want to
+keep the conversion.