aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2021-09-27 22:39:15 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2021-09-27 22:42:58 +0000
commitfd74bc8eb2fed86275167e58e9349045c6bbbaa4 (patch)
tree156b8464c719e994d0a34862c91623d55eae7100
parent6911dd4091d50c0ea29a40e2366f38db0f775c37 (diff)
downloadports-fd74bc8eb2fed86275167e58e9349045c6bbbaa4.tar.gz
ports-fd74bc8eb2fed86275167e58e9349045c6bbbaa4.zip
security/openssh-portable: Fix default ssh-askpass path
Reported by: Piotr Smyrak
-rw-r--r--security/openssh-portable/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index 306c7f4d15a4..b7b71af99747 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -2,7 +2,7 @@
PORTNAME= openssh
DISTVERSION= 8.7p1
-PORTREVISION= 0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= security
MASTER_SITES= OPENBSD/OpenSSH/portable
@@ -191,11 +191,16 @@ VERSION_ADDENDUM_DEFAULT?= ${OPSYS}-${PKGNAME}
CFLAGS+= ${CFLAGS_${CHOSEN_COMPILER_TYPE}}
CFLAGS_gcc= -Wno-stringop-truncation -Wno-stringop-overflow
+SSH_ASKPASS_PATH?= ${LOCALBASE}/bin/ssh-askpass
+
post-patch:
@${REINPLACE_CMD} \
-e 's|install: \(.*\) host-key check-config|install: \1|g' \
${WRKSRC}/Makefile.in
@${REINPLACE_CMD} \
+ -e 's|$$[{(]libexecdir[})]/ssh-askpass|${SSH_ASKPASS_PATH}|' \
+ ${WRKSRC}/Makefile.in ${WRKSRC}/configure.ac
+ @${REINPLACE_CMD} \
-e 's|\(VersionAddendum\) none|\1 ${VERSION_ADDENDUM_DEFAULT}|' \
${WRKSRC}/sshd_config
@${REINPLACE_CMD} \