aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2005-01-31 15:09:34 +0000
committerPeter Pentchev <roam@FreeBSD.org>2005-01-31 15:09:34 +0000
commitfd7b7deee1616da4c0cca2b97204bad4d1a0e9dd (patch)
treed6cb09fdb70ad5f0a1639bc0f124a6bc7594dc8a
parent771a9c4a3dc2d500325db3ac93823cc8148239bd (diff)
downloadports-fd7b7deee1616da4c0cca2b97204bad4d1a0e9dd.tar.gz
ports-fd7b7deee1616da4c0cca2b97204bad4d1a0e9dd.zip
Add the demo of Spheres of Chaos 2.06, a space shoot-em-up with unbelievable
graphics and music.
Notes
Notes: svn path=/head/; revision=127782
-rw-r--r--games/Makefile1
-rw-r--r--games/linux-spheresofchaos-demo/Makefile32
-rw-r--r--games/linux-spheresofchaos-demo/distinfo2
-rw-r--r--games/linux-spheresofchaos-demo/pkg-descr11
-rw-r--r--games/linux-spheresofchaos-demo/pkg-plist1
5 files changed, 47 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index dc93e281b26d..e1d8ea9a8962 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -276,6 +276,7 @@
SUBDIR += linux-nwnclient
SUBDIR += linux-nwserver
SUBDIR += linux-q3ademo
+ SUBDIR += linux-spheresofchaos-demo
SUBDIR += linux-steam
SUBDIR += lm-solve
SUBDIR += ltris
diff --git a/games/linux-spheresofchaos-demo/Makefile b/games/linux-spheresofchaos-demo/Makefile
new file mode 100644
index 000000000000..0f65e02407b5
--- /dev/null
+++ b/games/linux-spheresofchaos-demo/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: spheresofchaos-demo
+# Date created: 31 January 2005
+# Whom: Peter Pentchev <roam@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= spheresofchaos
+PORTVERSION= 2.06
+CATEGORIES= games linux
+MASTER_SITES= http://people.FreeBSD.org/~roam/games/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= roam
+PKGNAMEPREFIX= linux-
+PKGNAMESUFFIX= -demo
+DISTNAME= chaosl-${PORTVERSION}
+
+MAINTAINER= roam@FreeBSD.org
+COMMENT= An unusual and spectacular shoot-em-up for the PC
+
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12
+
+USE_LINUX= yes
+USE_ZIP= yes
+
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKDIR}/Chaosl ${PREFIX}/bin
+ ${BRANDELF} -t Linux ${PREFIX}/bin/Chaosl
+
+.include <bsd.port.mk>
diff --git a/games/linux-spheresofchaos-demo/distinfo b/games/linux-spheresofchaos-demo/distinfo
new file mode 100644
index 000000000000..cb801acdc4ca
--- /dev/null
+++ b/games/linux-spheresofchaos-demo/distinfo
@@ -0,0 +1,2 @@
+MD5 (chaosl-2.06.zip) = ec067bc2373c055f42884d35e35d9b40
+SIZE (chaosl-2.06.zip) = 260609
diff --git a/games/linux-spheresofchaos-demo/pkg-descr b/games/linux-spheresofchaos-demo/pkg-descr
new file mode 100644
index 000000000000..f6263b9ffdf6
--- /dev/null
+++ b/games/linux-spheresofchaos-demo/pkg-descr
@@ -0,0 +1,11 @@
+From the readme.txt file:
+
+Spheres of Chaos is a hectic, fast-paced, and rather colourful arcade game in
+the old-school style.
+
+Fly a ship around, dodging amongst hordes of assorted strange objects that
+subdivide when you shoot them. Earn bonus ships for score, Collect tokens for
+extra-powers. Battle the big aliens and other wierd things that occasionally
+appear. Survive as the game gets ever faster and more manic.
+
+WWW: http://www.spheresofchaos.com/
diff --git a/games/linux-spheresofchaos-demo/pkg-plist b/games/linux-spheresofchaos-demo/pkg-plist
new file mode 100644
index 000000000000..748f5d61515a
--- /dev/null
+++ b/games/linux-spheresofchaos-demo/pkg-plist
@@ -0,0 +1 @@
+bin/Chaosl