aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-11-01 18:16:08 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-11-01 18:17:59 +0000
commitfe98a130284f2ae19105a383aa2aeb0c95c9eb7f (patch)
tree3c2eb6860732772e99d601a939fa4084b1a7223b
parent7eb737fd2e001c2bbc08ee3ddd40fc7f7e80280e (diff)
downloadports-fe98a130284f2ae19105a383aa2aeb0c95c9eb7f.tar.gz
ports-fe98a130284f2ae19105a383aa2aeb0c95c9eb7f.zip
misc/veles: Disable Boost in msgpack
Follow devel/msgpack-cxx port disabling Boost.
-rw-r--r--misc/veles/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/misc/veles/Makefile b/misc/veles/Makefile
index f71b6b1bb505..2e9f28d1e389 100644
--- a/misc/veles/Makefile
+++ b/misc/veles/Makefile
@@ -24,7 +24,7 @@ BUILD_DEPENDS= msgpack-c>0:devel/msgpack-c \
${PY_DEPENDS}
RUN_DEPENDS= ${PY_DEPENDS}
-USES= cmake compiler localbase python:3.6+ qt:5 shebangfix # localbase is for boost headers included from the headers installed by msgpack-cxx
+USES= cmake compiler python:3.6+ qt:5 shebangfix
SHEBANG_GLOB= *.py
SHEBANG_FILES= python/plugin python/proxy resources/install/postinst python/test_dis
USE_GITHUB= yes
@@ -36,6 +36,8 @@ CMAKE_ARGS= -DFREEBSD_PYTHON_CMD:STRING=${PYTHON_CMD} \
-DFREEBSD_LLVM_VERSION:STDING=${LLVM_DEFAULT} \
-DFREEBSD_PYTHON_SITELIBDIR:STRING=${PYTHON_SITELIBDIR} \
-DMSGPACK_INCLUDE_PATH:STRING=${LOCALBASE}/include/mgpack
+CMAKE_OFF= MSGPACK_USE_BOOST # this should work, but Veles doesn't use cmake scripts for msgpack
+CXXFLAGS+= -DMSGPACK_NO_BOOST # workaround for the above
.include <bsd.port.pre.mk>