aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2017-12-30 15:21:01 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2017-12-30 15:21:01 +0000
commitfeb4467d1fd3d2f1767e830c32184e6935c86f78 (patch)
tree5519e52868cde7b3cb5a481f2106ce2bfc42f23b
parent3c46f45bc7aeafcb5cd2b266ee750f6a2ff07633 (diff)
downloadports-feb4467d1fd3d2f1767e830c32184e6935c86f78.tar.gz
ports-feb4467d1fd3d2f1767e830c32184e6935c86f78.zip
- Patch configure instead of configure.in so we can avoid USES=autoreconf.
An obscure macro is used in configure.in that autoreconf cannot find anywhere (ACX_CHECK_CXX_FLAGS). - Disable a test for libcharset from converters/libiconv, so the code will use nl_langinfo from libc instead. - Remove unneeded CONFIGURE_ENV, CPPFLAGS and LDFLAGS. Reported by: antoine
Notes
Notes: svn path=/head/; revision=457601
-rw-r--r--net-p2p/mldonkey/Makefile25
1 files changed, 8 insertions, 17 deletions
diff --git a/net-p2p/mldonkey/Makefile b/net-p2p/mldonkey/Makefile
index e61f4094f7d2..e0255921d833 100644
--- a/net-p2p/mldonkey/Makefile
+++ b/net-p2p/mldonkey/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mldonkey
PORTVERSION= 3.1.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES+= net-p2p
MASTER_SITES= SF
@@ -13,25 +13,17 @@ COMMENT?= OCAML client for multiple peer-to-peer networks
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/Copying.txt
-BUILD_DEPENDS= ${LOCALBASE}/share/aclocal/ax_pthread.m4:devel/autoconf-archive
-
CONFLICTS= mldonkey{-{core,gui},}-devel-[0-9]*
-USES= autoreconf iconv tar:bzip2 gmake
+USES= gmake iconv tar:bzip2
USE_OCAML= yes
USE_OCAML_CAMLP4=yes
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= ac_cv_lib_charset_locale_charset=no
ALL_TARGET= opt
-AUTORECONF_WRKSRC= ${WRKSRC}/config
MAKE_ENV+= OCAMLRUNPARAM="l=256M"
MAKE_JOBS_UNSAFE= yes
-CONFIGURE_ARGS+=${ICONV_CONFIGURE_ARG}
-CONFIGURE_ENV+= NEWCXX="${CXX}" \
- PTHREAD_LIBS="-lpthread"
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-
SUB_FILES= pkg-message
###
@@ -107,12 +99,11 @@ post-patch:
-e "s|%%SH%%|${SH}|" \
${FILESDIR}/wrapper.sh > \
${WRKDIR}/wrapper.sh
- @${REINPLACE_CMD} -E \
- -e 's@(\+)(lablgtk2)@\1site-lib/\2@' \
- -e 's@(\+)(labl\$$\(GTK\))@\1site-lib/\2@' \
- -e 's@(OCAMLLIB/)(\$$LABLGTK_NAME)@\1site-lib/\2@' \
- -e 's@(AC_DEFINE\([^,]*,[^,]*,)\)@\1 desc)@' \
- ${WRKSRC}/config/configure.in \
+ @${REINPLACE_CMD} \
+ -e 's|$$OCAMLLIB/$$LABLGTK_NAME|$$OCAMLLIB/site-lib/$$LABLGTK_NAME|' \
+ ${WRKSRC}/config/configure
+ @${REINPLACE_CMD} \
+ -e 's|+labl|+site-lib/labl|' \
${WRKSRC}/config/Makefile.in
@${REINPLACE_CMD} -E \
-e 's@(#include <)(lablgtk2/)@\1site-lib/\2@' \