aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-12-03 11:37:01 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2021-12-03 11:39:03 +0000
commitfee3247210edf039b7bd0ec0f73a03417bcbd6eb (patch)
tree22ae132cc5bc2c3368ad31b39b6e861b02b188ab
parent6548f83829a3a8744f109d91d4d20436b3c22311 (diff)
downloadports-fee3247210edf039b7bd0ec0f73a03417bcbd6eb.tar.gz
ports-fee3247210edf039b7bd0ec0f73a03417bcbd6eb.zip
security/botan2: add manpages support
Fix hidden dependency on sphinx and introduce optional manpages support. PR: 259737 Reported by: amdmi3 Submitted by: tremere@cainites.net (maintainer)
-rw-r--r--security/botan2/Makefile8
-rw-r--r--security/botan2/pkg-plist1
2 files changed, 7 insertions, 2 deletions
diff --git a/security/botan2/Makefile b/security/botan2/Makefile
index e3b154f8df3e..c46793c82c0d 100644
--- a/security/botan2/Makefile
+++ b/security/botan2/Makefile
@@ -1,5 +1,6 @@
PORTNAME= botan
DISTVERSION= 2.18.2
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://botan.randombit.net/releases/
PKGNAMESUFFIX= 2
@@ -43,10 +44,13 @@ PLIST_SUB= SHLIBVER=${_SHLIBVER} \
SOABIVER=${_SOABIVER}
PORTDOCS= *
-OPTIONS_DEFINE= DOCS PYTHON SQLITE3 SSL
-OPTIONS_DEFAULT= SSL
+OPTIONS_DEFINE= DOCS MANPAGES PYTHON SQLITE3 SSL
+OPTIONS_DEFAULT= MANPAGES SSL
OPTIONS_SUB= yes
+MANPAGES_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=0:textproc/py-sphinx@${PY_FLAVOR}
+MANPAGES_CONFIGURE_WITH= sphinx
+
PYTHON_USES= python:3.6+
PYTHON_USES_OFF= python:3.6+,build
PYTHON_CONFIGURE_ON= --with-python-versions=${PYTHON_VER}
diff --git a/security/botan2/pkg-plist b/security/botan2/pkg-plist
index 25a2f1da8c0f..641b11c2bf4f 100644
--- a/security/botan2/pkg-plist
+++ b/security/botan2/pkg-plist
@@ -323,3 +323,4 @@ lib/libbotan-2.so.%%SOABIVER%%
lib/libbotan-2.so.%%SOABIVER%%.%%SHLIBVER%%.%%SHLIBVERPATCH%%
%%PYTHON%%%%PYTHON_SITELIBDIR%%/botan2.py
libdata/pkgconfig/botan-2.pc
+%%MANPAGES%%share/man/man1/botan.1.gz