aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2017-03-25 07:50:53 +0000
committerCy Schubert <cy@FreeBSD.org>2017-03-25 07:50:53 +0000
commitff3b7d908435f51ed2d9f88cdac18bd20b1446cb (patch)
tree2c1f95b36fb0a9b76c1b4394c57281db25b514a3
parent58ef73fd8f8aa3c60f3c190d38e079be02cdf287 (diff)
downloadports-ff3b7d908435f51ed2d9f88cdac18bd20b1446cb.tar.gz
ports-ff3b7d908435f51ed2d9f88cdac18bd20b1446cb.zip
r436859 removed a bunch of refclock drivers that were enabled by
default. (New patch from ian@.) While here ian@ and I discussed the www/libwww libmd5 dependency. It turns out that if the sntp configure script finds libmd5, it uses it. This is now an option to include the dependency. While working on the libmd5 dependency it was discovered that the sntp build requires SSL only if it finds libmd5. This is now an IMPLIES. Thanks to ian@ for the additional patch and for discovering the libmd5 check, pointing me in the right direction to solve the without SSL breakage. PR: 218078 Submitted by: ian@ (default driver options) Discussed with: ian@ (libmd5 dependency)
Notes
Notes: svn path=/head/; revision=436887
-rw-r--r--net/ntp/Makefile9
-rw-r--r--net/ntp/Makefile.inc89
2 files changed, 43 insertions, 55 deletions
diff --git a/net/ntp/Makefile b/net/ntp/Makefile
index 2343050e88bd..8dad130e98dd 100644
--- a/net/ntp/Makefile
+++ b/net/ntp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ntp
PORTVERSION= 4.2.8p10
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net ipv6
MASTER_SITES= http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/ \
http://archive.ntp.org/ntp4/ntp-4.2/ \
@@ -13,8 +13,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/P/p/:S/.r/-RC/}
MAINTAINER= cy@FreeBSD.org
COMMENT= The Network Time Protocol Distribution
-LIB_DEPENDS= libevent.so:devel/libevent \
- libmd5.so:www/libwww
+LIB_DEPENDS= libevent.so:devel/libevent
CONFLICTS= ntp-devel-*
@@ -56,13 +55,15 @@ SSL_CONFIGURE_ON= --with-openssl-incdir=${OPENSSLINC} \
--with-openssl-libdir=${OPENSSLLIB}
SSL_CONFIGURE_OFF= --without-crypto
SSL_USES= ssl
-SSL_BROKEN_OFF= Includes OpenSSL when deselected
DEBUG_CONFIGURE_ON= --enable-debug
THREADS_CONFIGURE_ENABLE= thread-support
THREADS_CONFIGURE_WITH= threads
+MD5_LIB_DEPENDS= libmd5.so:www/libwww
+MD5_IMPLIES= SSL
+
.for D in ${NTP_DRIVERS}
${D}_CONFIGURE_ENABLE= ${D}
.endfor
diff --git a/net/ntp/Makefile.inc b/net/ntp/Makefile.inc
index fbc059a2a399..9f35dd65699d 100644
--- a/net/ntp/Makefile.inc
+++ b/net/ntp/Makefile.inc
@@ -5,62 +5,15 @@ OPTIONS_DEFINE= NTPSNMPD \
IPV6 \
DEBUG \
NTP_SIGND \
- BANCOMM \
- GPSVME \
- ACTS \
- ARBITER \
- ARCRON_MSF \
- AS2201 \
- ATOM \
- CHRONOLOG \
- CHU \
- AUDIO_CHU \
- DATUM \
- DUMBCLOCK \
- FG \
- HEATH \
- HOPFSERIAL \
- HOPFPCI \
- HPGPS \
- IRIG \
- JJY \
- JUPITER \
- LEITCH \
- LOCAL_CLOCK \
- MX4200 \
- NEOCLOCK4X \
- NMEA \
- ONCORE \
- PALISADE \
- PCF \
PERL_UTILS \
- PST \
- RIPENCC \
- SHM \
- SPECTRACOM \
- TRUETIME \
- ULINK \
- WWV \
- ZYFER \
- COMPUTIME \
- DCF7000 \
- HOPF6021 \
- MEINBERG \
- RAWDCF \
- RCC8000 \
- SCHMID \
- SEL240X \
- TRIMTAIP \
- TRIMTSIP \
- WHARTON \
- VARITEXT \
DOCS \
- EXAMPLES
+ EXAMPLES \
+ MD5 \
+ ${NTP_DRIVERS}
OPTIONS_DEFAULT= SSL \
- ATOM \
PERL_UTILS \
- NMEA
+ ${NTP_DRIVERS_DEFAULT}
NTPSNMPD_DESC= Build and install ntpsnmpd
NTP_SIGND_DESC= Enable signed NTP
@@ -113,6 +66,7 @@ TRIMTAIP_DESC= Enable Trimble GPS receiver/TAIP protocol
TRIMTSIP_DESC= Enable Trimble GPS receiver/TSIP protocol
WHARTON_DESC= Enable WHARTON 400A Series clock
VARITEXT_DESC= Enable VARITEXT clock
+MD5_DESC= Add libwww md5 dependency for sntp (implies SSL)
# Not supported by FreeBSD: TPRO Enable KSI/Odetics TPRO/S GPS receiver/IRIG
# XXX Broken under FreeBSD: TT560 Enable TrueTime 560 IRIG-B decoder
@@ -166,3 +120,36 @@ NTP_DRIVERS= \
TRIMTSIP \
WHARTON \
VARITEXT
+
+NTP_DRIVERS_DEFAULT= \
+ ACTS \
+ ARBITER \
+ ARCRON_MSF \
+ AS2201 \
+ ATOM \
+ CHRONOLOG \
+ CHU \
+ DATUM \
+ DUMBCLOCK \
+ FG \
+ HEATH \
+ HOPFPCI \
+ HOPFSERIAL \
+ HPGPS \
+ IRIG \
+ JJY \
+ JUPITER \
+ LEITCH \
+ LOCAL_CLOCK \
+ NEOCLOCK4X \
+ NMEA \
+ ONCORE \
+ PALISADE \
+ PCF \
+ PST \
+ SHM \
+ SPECTRACOM \
+ TRUETIME \
+ ULINK \
+ WWV \
+ ZYFER