aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-19 16:32:13 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-19 17:30:38 +0000
commitff42bb605e1c46a95f4a7d91ad1194869be7e5ee (patch)
treecdca4dff5da08170f62309e619bbe3304ceb9142
parent4c92acca54ffd386bff9bd5eec3b111306723a48 (diff)
downloadports-ff42bb605e1c46a95f4a7d91ad1194869be7e5ee.tar.gz
ports-ff42bb605e1c46a95f4a7d91ad1194869be7e5ee.zip
devel/cjose: Fix build with llvm16
- Fix build with OpenSSL 3 and later Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--devel/cjose/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/devel/cjose/Makefile b/devel/cjose/Makefile
index e657681e2eac..c1a52369bcaf 100644
--- a/devel/cjose/Makefile
+++ b/devel/cjose/Makefile
@@ -13,8 +13,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libjansson.so:devel/jansson
USES= compiler:c++11-lang libtool pathfix pkgconfig ssl
-BROKEN_SSL= openssl30 openssl31
-BROKEN_SSL_REASON= Requires OpenSSL 3.0.0 deprecated RSA_ routines
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
@@ -24,10 +22,15 @@ GH_ACCOUNT= cisco
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-jansson=${PREFIX} --with-openssl=${OPENSSLBASE}
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
-.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
+.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 160
CFLAGS+= -Wno-error=strict-prototypes
.endif
-.include <bsd.port.mk>
+.if ( ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400092 && ${SSL_DEFAULT} == base ) || ${SSL_DEFAULT:Mopenssl3*}
+CFLAGS+= -Wno-error=deprecated-declarations
+.endif
+
+
+.include <bsd.port.post.mk>