aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2024-03-01 07:58:07 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2024-03-01 07:58:07 +0000
commitff7cc7c71946fef795832da65686dff06c0f7d47 (patch)
treee39de5cb1ae2e9b4952087f5e92a9f18aadbfebc
parent294a6814f4f5ef5f89ca30e769b2da0b361f2d04 (diff)
downloadports-ff7cc7c71946fef795832da65686dff06c0f7d47.tar.gz
ports-ff7cc7c71946fef795832da65686dff06c0f7d47.zip
www/firefox: fix running on wayland
since the latest version firefox uses a wayland-proxy to deal with disconnections from the compositor, this proxy had portability issue in particular it relies on a non defined behaviour polling a non connected socket, remove the test on the polling to make it run on FreeBSD Note for users running into other issues with wayland-proxy they can for now disable it via: MOZ_DISABLE_WAYLAND_PROXY=1 env var. This has been reported upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=1882972 https://github.com/stransky/wayland-proxy/issues/3 https://github.com/stransky/wayland-proxy/pull/6 Reviewd by: manu Tested by: manu
-rw-r--r--www/firefox/Makefile2
-rw-r--r--www/firefox/files/patch-wayland-proxy15
2 files changed, 16 insertions, 1 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 651c4f8ba9eb..6d64abfa085d 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -1,6 +1,6 @@
PORTNAME= firefox
DISTVERSION= 123.0
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 2
CATEGORIES= www wayland
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}${DISTVERSIONSUFFIX}/source \
diff --git a/www/firefox/files/patch-wayland-proxy b/www/firefox/files/patch-wayland-proxy
new file mode 100644
index 000000000000..d9cb16bd2215
--- /dev/null
+++ b/www/firefox/files/patch-wayland-proxy
@@ -0,0 +1,15 @@
+--- third_party/wayland-proxy/wayland-proxy.cpp.orig 2024-02-29 09:10:59.939556000 +0100
++++ third_party/wayland-proxy/wayland-proxy.cpp 2024-02-29 15:07:13.914375000 +0100
+@@ -318,10 +318,10 @@
+ }
+
+ bool ProxiedConnection::ConnectToCompositor() {
+- if (!(mCompositorFlags & POLLOUT)) {
++ /* if (!(mCompositorFlags & POLLOUT)) {
+ // Try again later
+ return true;
+- }
++ }*/
+
+ struct sockaddr_un addr = {};
+ addr.sun_family = AF_UNIX;