aboutsummaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2016-04-13 02:02:43 +0000
committerSteve Wills <swills@FreeBSD.org>2016-04-13 02:02:43 +0000
commit58fd9078161b3393bfa151a1fcc5e33506d5f575 (patch)
tree61105b4ed0c6543b1063ac2e0c737a9dda14a676 /Makefile
parenta5aebf960ef7ee4f50bb2bb4a2077c2225c90a9b (diff)
downloadports-58fd9078161b3393bfa151a1fcc5e33506d5f575.tar.gz
ports-58fd9078161b3393bfa151a1fcc5e33506d5f575.zip
Try harder to find svn
Don't assume svn is installed, but use it if it's available, falling back to svnlite if not (or using svn from base in the case where WITH_SVN was set in base). This matches the logic in base for finding svn. PR: 207479 Discussed with: gjb Reported by: Torsten Zühlsdorff <ports@toco-domains.de>
Notes
Notes: svn path=/head/; revision=413169
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 5ea40e5cb77f..d89e2daed479 100644
--- a/Makefile
+++ b/Makefile
@@ -164,7 +164,15 @@ print-index: ${INDEXDIR}/${INDEXFILE}
@awk -F\| '{ printf("Port:\t%s\nPath:\t%s\nInfo:\t%s\nMaint:\t%s\nIndex:\t%s\nB-deps:\t%s\nR-deps:\t%s\nE-deps:\t%s\nP-deps:\t%s\nF-deps:\t%s\nWWW:\t%s\n\n", $$1, $$2, $$4, $$6, $$7, $$8, $$9, $$11, $$12, $$13, $$10); }' < ${INDEXDIR}/${INDEXFILE}
GIT?= git
-SVN?= svn
+.if !defined(SVN) || empty(SVN)
+. for _P in /usr/bin /usr/local/bin
+. for _S in svn svnlite
+. if exists(${_P}/${_S})
+SVN= ${_P}/${_S}
+. endif
+. endfor
+. endfor
+.endif
RSYNC?= rsync
PORTSNAP?= portsnap
PORTSNAP_FLAGS?= -p ${.CURDIR}