aboutsummaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorSofian Brabez <sbz@FreeBSD.org>2021-05-25 07:35:30 +0000
committerSofian Brabez <sbz@FreeBSD.org>2021-05-25 16:01:19 +0000
commit5d2188800f7a37ba58adf1fa42cb8ad820067b3f (patch)
tree6b3168d4f2b435740e2b864b7f083a0a5da97a80 /Makefile
parent07d1217a854d49123e013cb0f485de8b6a04f9a6 (diff)
downloadports-5d2188800f7a37ba58adf1fa42cb8ad820067b3f.tar.gz
ports-5d2188800f7a37ba58adf1fa42cb8ad820067b3f.zip
Makefile: Force to rebase when using make update
Approved by: uqs Differential Revision: https://reviews.freebsd.org/D30450
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 3ca0ba4cabd3..ad4b13aec200 100644
--- a/Makefile
+++ b/Makefile
@@ -189,7 +189,7 @@ update:
@echo "--------------------------------------------------------------"
@echo ">>> Updating ${.CURDIR} from git repository"
@echo "--------------------------------------------------------------"
- cd ${.CURDIR}; ${GIT} pull
+ cd ${.CURDIR}; ${GIT} pull --rebase
. endif
.elif defined(RSYNC_UPDATE) && defined(PORTS_RSYNC_SOURCE)
@echo "--------------------------------------------------------------"