aboutsummaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2004-05-25 10:16:16 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2004-05-25 10:16:16 +0000
commit60cbbacd3923d6c7d3ee41128ec094f7f18c656a (patch)
treebc427b51b2fe5202aa1698b9038b3350df7872c0 /Makefile
parent8915cb7e3ad6d3357f971778358efc58cd2c6c11 (diff)
downloadports-60cbbacd3923d6c7d3ee41128ec094f7f18c656a.tar.gz
ports-60cbbacd3923d6c7d3ee41128ec094f7f18c656a.zip
Add "fetchindex" target. It fetches the recent index file (INDEX _or_
INDEX-5). A note about the implementation: I had to add the call to chmod to make the index file readable to everyone. I'm a little bit surprised by this, since my umask is 022. Either fetch(1) doesn't respect the umask or it mirrors the permissions too (I haven't investigated this). Both possibilities aren't documented in the man-page. Approved by: kris (previous version without the chmod)
Notes
Notes: svn path=/head/; revision=109965
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 60d95f817bdb..6dabf0719bfe 100644
--- a/Makefile
+++ b/Makefile
@@ -70,6 +70,9 @@ index:
@rm -f ${.CURDIR}/${INDEXFILE}
@cd ${.CURDIR} && make ${.CURDIR}/${INDEXFILE}
+fetchindex:
+ @cd ${.CURDIR} && fetch -am http://www.FreeBSD.org/ports/${INDEXFILE} && chmod a+r ${INDEXFILE}
+
INDEX_JOBS?= 2
${.CURDIR}/${INDEXFILE}: