aboutsummaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJordan K. Hubbard <jkh@FreeBSD.org>1995-03-21 03:12:17 +0000
committerJordan K. Hubbard <jkh@FreeBSD.org>1995-03-21 03:12:17 +0000
commit73dc85456f3ec144dcbbc00d705dd86d78c74a6d (patch)
tree202dc842f450da86e21db4d21fe327e430d163b3 /Makefile
parent86f8fd330d17d3d68abbeb668f56864e353d038c (diff)
downloadports-73dc85456f3ec144dcbbc00d705dd86d78c74a6d.tar.gz
ports-73dc85456f3ec144dcbbc00d705dd86d78c74a6d.zip
New index file format, plus a simple rule (print-index) for making it
more human-readable. This should probably be a more capable perl script at some point.
Notes
Notes: svn path=/head/; revision=1174
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 7a54508ab94e..94940f4d01cf 100644
--- a/Makefile
+++ b/Makefile
@@ -1,11 +1,16 @@
-# $Id: Makefile,v 1.11 1995/03/16 00:12:23 asami Exp $
+# $Id: Makefile,v 1.12 1995/03/21 01:46:29 jkh Exp $
#
SUBDIR= archivers audio cad comms databases devel editors games graphics \
japanese lang mail math net news print shells utils x11
.include <bsd.port.subdir.mk>
-index:
+index: ${.CURDIR}/INDEX
+
+${.CURDIR}/INDEX:
@echo -n "Generating INDEX - please wait.."
- @make describe > ${.CURDIR}/INDEX
+ @make describe | sed -e '/===/D' > ${.CURDIR}/INDEX
@echo " Done."
+
+print-index: ${.CURDIR}/INDEX
+ awk -F@ '{ printf("Port:\t%s\nPath:\t%s\nInfo:\t%s\n\n", $$1, $$2, $$4); }' < ${.CURDIR}/INDEX