aboutsummaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2014-08-18 04:19:46 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2014-08-18 04:19:46 +0000
commite5451112c0b1e51b3a7b8af7499cfa3ddd43ac88 (patch)
treec4c9a94f8386b7a0cbc9cc086a410eea4dc351e2 /Makefile
parent482fd2f40994712cc41b24f91b306d7e2972b715 (diff)
downloadports-e5451112c0b1e51b3a7b8af7499cfa3ddd43ac88.tar.gz
ports-e5451112c0b1e51b3a7b8af7499cfa3ddd43ac88.zip
Makefile: Default INDEX_JOBS value to kern.smp.cpus
INDEX_JOBS currently defaults to 2 for the make index target. MAKE_JOBS_NUMBER in bsd.port.mk currently uses kern.smp.cpus to select a default. Modify INDEX_JOBS to match. Nominal and repeatable performance improvements of ~20-30% were observed. CR: D381 Reviewed by: swills, bdrewery Approved by: portmgr
Notes
Notes: svn path=/head/; revision=365265
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 8b8f9d6f2395..5ea40e5cb77f 100644
--- a/Makefile
+++ b/Makefile
@@ -82,7 +82,10 @@ ${INDEXDIR}/${INDEXFILE}.bz2: .PHONY
MASTER_SITE_INDEX?= http://www.FreeBSD.org/ports/
SETENV?= /usr/bin/env
FETCHINDEX?= ${SETENV} ${FETCH_ENV} fetch -am -o
-INDEX_JOBS?= 2
+
+.if !defined(INDEX_JOBS)
+INDEX_JOBS!= ${SYSCTL} -n kern.smp.cpus
+.endif
.if !defined(INDEX_VERBOSE)
INDEX_ECHO_MSG= true