aboutsummaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-04-02 07:25:23 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-04-02 07:25:23 +0000
commite74f65891de820071516510bbc68b8e00472a79e (patch)
treeed00e25eb1c26e2b9cbd086dbd60a0592c3da8fa /Makefile
parent783ff30c636b06af3170b25cc26e2edc6b112664 (diff)
downloadports-e74f65891de820071516510bbc68b8e00472a79e.tar.gz
ports-e74f65891de820071516510bbc68b8e00472a79e.zip
- Allow processing of info files in non-standard locations; the
INFO_PATH variable may be used to specify their location. It defaults to 'share/info' for the standard PREFIX, and 'info' when PREFIX == /usr. [1] - Remove the <category>/pkg/COMMENT files in favour of a COMMENT variable in <category>/Makefile [2] - Prevent patch breakage with VERSION_CONTROL=numbered [3] - Fix some instances of incorrect WRKDIRPREFIX handling. [4] - remove useless ${MKDIR} ${WRKSRC} in config target [5] - remove reference to OpenBSD [6] - Exempt devel/p5-Module-Build from the self-dependency in PERL_MODBUILD so that this port may use the option without getting an infinite dependency list [7] - The default PERL_ARCH is currently determined as a function of OSVERSION. It should however be a function of PERL_LEVEL since the correct value depends on what Perl version one has installed (older Perl versions use ${ARCH}-freebsd, newer versions use mach). [8] - Fix PORTDOCS on older (4.7, 5.0) systems [9] - Allow 'make parallel' to generate a working makefile when not all categories are present (this does not mean you'll be able to build all ports, unless you make sure they don't have external dependencies) [10] - Don't report symlinks as world-writable in the security check [11] - Fix a comment that was broken by a mismerged patch [12] - Clarify the meaning of USE_*, WANT_*, WITH_* and WITHOUT_* [13] - Don't set _CHKSUMFILES/_IGNOREFILES if CKSUMFILES/IGNOREFILES is empty and DIST_SUBDIR is set. [14] - Fix comment for DISTDIR [15] - Update the documentation of the USE_GL variable [16] - Check to see if NONEXISTENT exists, and fail with an error if it does [17] - Fix fetching of new distfiles in 'make makesum' when SIZE is set [18] - Consistently set MAKE_ENV when USE_GCC=3.2 or 3.3 are set [19] - Rework INDEX builds: [20] * Fix the bsd.port.subdir.mk code that is supposed to report index breakage (the fallback code wasn't actually being run because make would halt immediately following the error). This should help with INDEX error reports because it will immediately show the cause of failure, so we won't have to pull teeth to extract it from the submitter. * Streamline the 'make describe' code a bit. * Provide some basic instructions to the user when an index build fails, on when and how to report index build failures (turn this off with INDEX_QUIET=1) * Removed INDEX_NOSORT, because I couldn't imagine it to be very useful and it doesn't cost very much anyway. * Don't prevent INDEX builds from seeing the local host environment. Since a lot of users are using 'make index' thesedays they should get an index that reflects their local settings and installed ports. If you want to build a 'default' index that isn't influenced by local settings (e.g. for release builds), set the INDEX_PRISTINE variable. * Allows parallel INDEX builds (using make -j). The most obvious way of doing this doesn't work, because I/O from child makes is broken up into 2k chunks, and output lines from 'make describe' that exceed this length (*cough* GNOME *cough*) will be intertwined with the output of other makes, leading to a corrupted INDEX. The I/O interleaving can be disabled using 'make -P', but this inserts extraneous output of its own, and redirects stderr, making it useless for our purposes. Instead, I collect the output from the child make processes in temporary files and recombine them at the end. * The number of concurrent make processes to spawn can be set using INDEX_JOBS. By default this is set to 2, which seems to be a sweet spot for both single and dual-processor systems. On my tests I do not see any significant performance changes on UP, but on a dual 4.x system the build time drops by 47% (6 minute index builds on one test machine!). Depending on your disk and CPU hardware you might see further gains with INDEX_JOBS=4 or higher, so you might like to experiment to see what works best. On a dual 5.x system the performance gains do not seem to be as great (20-30%), but this is still a significant net win. PR: 55493 [1], 59651 [2], 61552 [3], 62247 [4], 62329 [5], 62337 [6], 62422 [7], 62441 [8], 62627 [9], 62983 [10], 63112 [11], 63297 [12], 63335 [13], 64029 [14], 64069 [15], 64236 [16], 64519 [17], 62958 [18], 64237 [19] Submitted by: lev [1], Matthew Seaman <m.seaman@infracaninophile.co.uk> [2], Joel Ray Holveck <joelh@piquan.org> [3], ade [4], Sergey Matveychuk <sem@ciam.ru> [5], markus [6], mat [7], des [8], eik [9], Dmitry Morozovsky <marck@rinet.ru> [10], Andrew <andrew@ugh.net.au> [11], vs [12], linimon [13], edwin [14][15], gerald [16], marcus[17][18], kris [19][20]
Notes
Notes: svn path=/head/; revision=105947
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile46
1 files changed, 35 insertions, 11 deletions
diff --git a/Makefile b/Makefile
index 58f7c7217a6d..60d95f817bdb 100644
--- a/Makefile
+++ b/Makefile
@@ -70,20 +70,44 @@ index:
@rm -f ${.CURDIR}/${INDEXFILE}
@cd ${.CURDIR} && make ${.CURDIR}/${INDEXFILE}
+INDEX_JOBS?= 2
+
${.CURDIR}/${INDEXFILE}:
@echo -n "Generating ${INDEXFILE} - please wait.."; \
- export LOCALBASE=/nonexistentlocal; \
- export X11BASE=/nonexistentx; \
- cd ${.CURDIR} && make describe ECHO_MSG="echo > /dev/null" | \
- perl ${.CURDIR}/Tools/make_index | \
- sed -e 's/ */ /g' -e 's/| */|/g' -e 's/ *|/|/g' -e "s,$${LOCALBASE},/usr/local," -e "s,$${X11BASE},/usr/X11R6," > ${INDEXFILE}
-.if !defined(INDEX_NOSORT)
- @sed -e 's./..g' ${.CURDIR}/${INDEXFILE} | \
+ if [ "${INDEX_PRISTINE}" != "" ]; then \
+ export LOCALBASE=/nonexistentlocal; \
+ export X11BASE=/nonexistentx; \
+ fi; \
+ tmpdir=`/usr/bin/mktemp -d -t index` || exit 1; \
+ trap "rm -rf $${tmpdir}; exit 1" 1 2 3 5 10 13 15; \
+ ( cd ${.CURDIR} && make -j${INDEX_JOBS} INDEX_TMPDIR=$${tmpdir} BUILDING_INDEX=1 \
+ ECHO_MSG="echo > /dev/null" describe ) || \
+ (rm -rf $${tmpdir} ; \
+ if [ "${INDEX_QUIET}" = "" ]; then \
+ echo; \
+ echo "********************************************************************"; \
+ echo "Before reporting this error, verify that you are running a supported"; \
+ echo "version of FreeBSD (see http://www.FreeBSD.org/ports/) and that you"; \
+ echo "have a complete and up-to-date ports collection. If so, then report"; \
+ echo "the failure to ports@FreeBSD.org together with relevant details of"; \
+ echo "your ports configuration (including FreeBSD version, environment and"; \
+ echo "/etc/make.conf settings)."; \
+ echo "********************************************************************"; \
+ echo; \
+ fi; \
+ exit 1); \
+ cat $${tmpdir}/${INDEXFILE}.desc.* | perl ${.CURDIR}/Tools/make_index | \
+ sed -e 's/ */ /g' -e 's/| */|/g' -e 's/ *|/|/g' -e 's./..g' | \
sort -t '|' +1 -2 | \
sed -e 's../.g' > ${.CURDIR}/${INDEXFILE}.tmp; \
- mv -f ${.CURDIR}/${INDEXFILE}.tmp ${.CURDIR}/${INDEXFILE}
-.endif
- @echo " Done."
+ if [ "${INDEX_PRISTINE}" != "" ]; then \
+ sed -e "s,$${LOCALBASE},/usr/local," -e "s,$${X11BASE},/usr/X11R6," \
+ ${.CURDIR}/${INDEXFILE}.tmp > ${.CURDIR}/${INDEXFILE}; \
+ else \
+ mv ${.CURDIR}/${INDEXFILE}.tmp ${.CURDIR}/${INDEXFILE}; \
+ fi; \
+ rm -rf $${tmpdir}; \
+ echo " Done."
print-index: ${.CURDIR}/${INDEXFILE}
@awk -F\| '{ printf("Port:\t%s\nPath:\t%s\nInfo:\t%s\nMaint:\t%s\nIndex:\t%s\nB-deps:\t%s\nR-deps:\t%s\n\n", $$1, $$2, $$4, $$6, $$7, $$8, $$9); }' < ${.CURDIR}/${INDEXFILE}
@@ -95,7 +119,7 @@ parallel: ${.CURDIR}/${INDEXFILE}
@false
.endif
.for dir in ${SUBDIR}
- @echo "all: ${dir}-all"
+ @[ -r ${dir}/Makefile ] && echo "all: ${dir}-all" || true
.endfor
@awk -F '|' '{me=$$1; here=$$2; bdep=$$8; rdep=$$9; split(here, tmp, "/"); if (bdep != "") { gsub("$$", ".tgz", bdep); gsub(" ", ".tgz ", bdep); } if (rdep != "") { gsub("$$", ".tgz", rdep); gsub(" ", ".tgz ", rdep); } print tmp[4] "-all: " me ".tgz"; print me ": " me ".tgz"; print me ".tgz: " bdep " " rdep; printf("\t@/var/portbuild/scripts/pdispatch ${branch} /var/portbuild/scripts/portbuild %s.tgz %s", me, here); if (bdep != "") printf(" %s", bdep); if (rdep != "") printf(" %s", rdep); printf("\n")}' < ${.CURDIR}/${INDEXFILE}