aboutsummaryrefslogtreecommitdiff
path: root/Mk/Uses
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-02-07 12:27:02 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-02-07 12:27:02 +0000
commitac5a807ae01d2e9334a2d24b4e34c8ef06834b47 (patch)
treef72a575660c6838222bb729eda96d386948cde11 /Mk/Uses
parent25c794224fbdc888e76ff140590ef272da22ee74 (diff)
downloadports-ac5a807ae01d2e9334a2d24b4e34c8ef06834b47.tar.gz
ports-ac5a807ae01d2e9334a2d24b4e34c8ef06834b47.zip
Make USES=php behaves a bit more nicely with PHP 7.0 and 7.1 for ports
where USE_PHP includes modules that are 5.6 only (like mysql). Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=433544
Diffstat (limited to 'Mk/Uses')
-rw-r--r--Mk/Uses/php.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/Mk/Uses/php.mk b/Mk/Uses/php.mk
index a9a734b8e7da..bacef1e61b00 100644
--- a/Mk/Uses/php.mk
+++ b/Mk/Uses/php.mk
@@ -139,6 +139,7 @@ PHP_EXT_INC?= ""
. if defined(IGNORE_WITH_PHP)
. for VER in ${IGNORE_WITH_PHP}
. if ${PHP_VER} == "${VER}"
+_IGNORE_PHP_SET=
IGNORE= cannot be installed: doesn't work with lang/php${PHP_VER} port\
(doesn't support PHP ${IGNORE_WITH_PHP:C/^([57])/\1./})
. endif
@@ -402,7 +403,7 @@ BUILD_DEPENDS+= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/${extension:S/:build//}.so:${$
RUN_DEPENDS+= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/${extension:S/:build//}.so:${${extension:S/:build//}_DEPENDS}
. endif
. else
-. if ${ext:tl} != "yes"
+. if ${ext:tl} != "yes" && !defined(_IGNORE_PHP_SET)
check-makevars::
@${ECHO_CMD} "Unknown extension ${extension:S/:build//} for PHP ${PHP_VER}."
@${FALSE}