aboutsummaryrefslogtreecommitdiff
path: root/Mk/Uses
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2020-05-06 11:53:56 +0000
committerMathieu Arnold <mat@FreeBSD.org>2020-05-06 11:53:56 +0000
commitd9869c8271d88dada996d61c9d3da358f82b0423 (patch)
treee1a947aaf06d60ebeda577dd6b61d66b2b2c95e4 /Mk/Uses
parent40e0315810d534e4dd53246dea2b6232f4434a6c (diff)
downloadports-d9869c8271d88dada996d61c9d3da358f82b0423.tar.gz
ports-d9869c8271d88dada996d61c9d3da358f82b0423.zip
Automatically mark ports as DEPRECATED when they use Python 2.
Reviewed by: antoine Differential Revision: https://reviews.freebsd.org/D24732
Notes
Notes: svn path=/head/; revision=534166
Diffstat (limited to 'Mk/Uses')
-rw-r--r--Mk/Uses/python.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/Mk/Uses/python.mk b/Mk/Uses/python.mk
index 4283231b9593..1da52645a47c 100644
--- a/Mk/Uses/python.mk
+++ b/Mk/Uses/python.mk
@@ -463,6 +463,11 @@ PYTHON_ABIVER= m
.endif
.endif
+.if ${PYTHON_MAJOR_VER} == 2
+DEPRECATED?= Uses Python 2.7 which is EOLed upstream
+EXPIRATION_DATE?= 2020-12-31
+.endif
+
.if !defined(PYTHONBASE)
PYTHONBASE!= (${PYTHON_CMD} -c 'import sys; print(sys.prefix)' \
2> /dev/null || ${ECHO_CMD} ${LOCALBASE}) | ${TAIL} -1