aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.autotools.mk
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2004-08-03 22:36:52 +0000
committerAde Lovett <ade@FreeBSD.org>2004-08-03 22:36:52 +0000
commite32a8245791aab6e734fe5ecda71641e15c94b45 (patch)
tree4daccf3b91f25a920b92ab009f8f336fb635fb30 /Mk/bsd.autotools.mk
parent99fb36c32d824e3fb95f9b66463538631d38cdc8 (diff)
downloadports-e32a8245791aab6e734fe5ecda71641e15c94b45.tar.gz
ports-e32a8245791aab6e734fe5ecda71641e15c94b45.zip
Move devel/autoconf->devel/autoconf253 and devel/automake->devel/automake15
All autotools ports are now truly versioned and do not conflict with each other. This marks the end of "Phase 1" of the autotools updates.
Notes
Notes: svn path=/head/; revision=115365
Diffstat (limited to 'Mk/bsd.autotools.mk')
-rw-r--r--Mk/bsd.autotools.mk25
1 files changed, 0 insertions, 25 deletions
diff --git a/Mk/bsd.autotools.mk b/Mk/bsd.autotools.mk
index 66ea3ca77bb5..1915bc6b07d2 100644
--- a/Mk/bsd.autotools.mk
+++ b/Mk/bsd.autotools.mk
@@ -116,12 +116,6 @@ Autotools_Include_MAINTAINER= ade@FreeBSD.org
# the configuration steps.
#
# Things to do:
-# - Move both autoconf and automake to true versioned ports
-# (devel/autoconf253 and devel/automake14 respectively). This is
-# likely to break a number of ports that make assumptions about
-# "autoconf", "automake", et al. but is required if we are to move
-# to strictly-versioned autotools.
-#
# - Work on killing off as many "old" autotools ports as possible
#
# - Bring back the installation of libtool .la files by default, removing
@@ -153,15 +147,7 @@ GNU_CONFIGURE?= yes
.endif
.if defined(WANT_AUTOMAKE_VER)
-
-# XXX: hackery to handle non-versioned "legacy" ports
-# destined to die
-#
-. if ${WANT_AUTOMAKE_VER} == 15
-AUTOMAKE_SUFFIX= # empty
-. else
AUTOMAKE_SUFFIX= ${WANT_AUTOMAKE_VER}
-. endif
# Make sure we specified a legal version of automake
#
@@ -220,15 +206,7 @@ BROKEN= "Incompatible autoheader ${WANT_AUTOHEADER_VER} and autoconf ${WANT_AUTO
.endif
.if defined(WANT_AUTOCONF_VER)
-
-# XXX: hackery to handle non-versioned "legacy" ports
-# destined to die
-#
-. if ${WANT_AUTOCONF_VER} == 253
-AUTOCONF_SUFFIX= # empty
-. else
AUTOCONF_SUFFIX= ${WANT_AUTOCONF_VER}
-. endif
# Make sure we specified a legal version of autoconf
#
@@ -277,9 +255,6 @@ GNU_CONFIGURE?= yes
WANT_LIBTOOL_VER?= ${USE_INC_LIBTOOL_VER}
.endif
-# Note that there aren't any non-versioned libtools, so we can skip
-# a little bit of cruft that exists in automake/autoconf above
-#
.if defined(WANT_LIBTOOL_VER)
LIBTOOL_SUFFIX= ${WANT_LIBTOOL_VER}