aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.default-versions.mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-09-19 08:16:43 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-09-19 08:16:43 +0000
commit377fc0342d3f2f3229c06321c39421698dfa1947 (patch)
tree05d309c8525dca581e8ee3aab697d460af0220cd /Mk/bsd.default-versions.mk
parentcb471dbbdc733133c89a3e369f4098b378f9a96f (diff)
downloadports-377fc0342d3f2f3229c06321c39421698dfa1947.tar.gz
ports-377fc0342d3f2f3229c06321c39421698dfa1947.zip
Introduce the one-true-way to handle multi version ports
This defines a new macros for end users! DEFAULT_VERSIONS. This macros is used to end-users to define what version they want to be the default version for the whole ports tree (for ports allowing that) Syntax is the following: DEFAULT_VERSIONS= perl5=5.18 ruby=2.0 Swith bsd.ruby.mk to use it[1], switch Uses/perl5.mk to use it[2] If you are maintaining settable multi version port, please change it so it uses DEFAULT_VERSIONS. Reviewed by: ruby (swills) [1], perl (az) [2] Approved by: ruby (swills) [1], perl (az) [2]
Notes
Notes: svn path=/head/; revision=327602
Diffstat (limited to 'Mk/bsd.default-versions.mk')
-rw-r--r--Mk/bsd.default-versions.mk23
1 files changed, 23 insertions, 0 deletions
diff --git a/Mk/bsd.default-versions.mk b/Mk/bsd.default-versions.mk
new file mode 100644
index 000000000000..8233509067df
--- /dev/null
+++ b/Mk/bsd.default-versions.mk
@@ -0,0 +1,23 @@
+# $FreeBSD$
+#
+# MAINTAINER: ports@FreeBSD.org
+#
+# Handle the default versions for users chosable multi versions.
+#
+# It expects users to define DEFAULT_VERSIONS in there make.conf
+# Syntax is the following:
+#
+# DEFAULT_VERSION= perl5=5.18 ruby=2.0
+
+.if !defined(_INCLUDE_BSD_DEFAULT_VERSIONS_MK)
+_INCLUDE_BSD_DEFAULT_VERSIONS_MK= yes
+
+.for lang in ${DEFAULT_VERSIONS}
+_l= ${lang:C/=.*//g}
+${_l:U}_DEFAULT= ${lang:C/.*=//g}
+.endfor
+
+PERL5_DEFAULT?= 5.14
+RUBY_DEFAULT?= 1.9
+
+.endif