aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.gstreamer.mk
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2008-03-24 03:52:36 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2008-03-24 03:52:36 +0000
commit6f32add9a75efb180e462ffbdb0b080bc88088e3 (patch)
tree0fc7af36e22fc0dc7c1dc8aacabf6fe117e881da /Mk/bsd.gstreamer.mk
parentb8d245fedd5842fb6d68d0bdc6539885555a84e3 (diff)
downloadports-6f32add9a75efb180e462ffbdb0b080bc88088e3.tar.gz
ports-6f32add9a75efb180e462ffbdb0b080bc88088e3.zip
The FreeBSD GNOME team is proud to annunce the release of GNOME 2.22.0 for
FreeBSD. The official GNOME 2.22 release notes can be found at http://library.gnome.org/misc/release-notes/2.22/ . On the FreeBSD front, this release features an updated hal port with support for video4linux devices, DRM (Direct Rendering), and better support of removable media. Work is also underway to tie webkit more closely into GNOME. As part of the GNOME 2.22 upgrade, GStreamer received a rather large upgrade as well. Be sure to consult UPDATING on the proper steps to upgrade all of your GNOME ports. This release would not have been possible without the contributions and testing efforts of the following people: Pawel Worach kan edwin Peter Ulrich Kruppa J. W. Ballantine Yasuda Keisuke Andriy Gapon
Notes
Notes: svn path=/head/; revision=209647
Diffstat (limited to 'Mk/bsd.gstreamer.mk')
-rw-r--r--Mk/bsd.gstreamer.mk28
1 files changed, 21 insertions, 7 deletions
diff --git a/Mk/bsd.gstreamer.mk b/Mk/bsd.gstreamer.mk
index 73608afbf2eb..601efe93bcba 100644
--- a/Mk/bsd.gstreamer.mk
+++ b/Mk/bsd.gstreamer.mk
@@ -7,7 +7,7 @@
# Date: 4 Oct 2004
#
# $FreeBSD$
-# $MCom: ports/Mk/bsd.gstreamer.mk,v 1.38 2006/10/10 20:22:01 mezz Exp $
+# $MCom: ports/Mk/bsd.gstreamer.mk,v 1.43 2008/03/21 04:14:18 ahze Exp $
.if !defined(_POSTMKINCLUDED) && !defined(Gstreamer_Pre_Include)
@@ -53,15 +53,16 @@ GST_SHLIB_VERSION= 1
#
# These are the current supported gstreamer-plugins modules
#
-_USE_GSTREAMER10_ALL= a52dec aalib annodex bad bz2 cairo cdaudio cdparanoia dts \
- dv dvd esound faac faad ffmpeg flac gconf gnomevfs \
- gnonlin good gsm hal ivorbis jack jpeg ladspa lame \
- libcaca libmms libpng libvisual mp3 mpeg2enc mpeg2dec \
+_USE_GSTREAMER10_ALL= a52dec aalib annodex bz2 cairo cdaudio cdparanoia dts \
+ dv dvd esound faac faad ffmpeg flac gconf gio gnomevfs \
+ gnonlin gsm hal ivorbis jack jpeg ladspa lame \
+ libcaca libmms libpng libvisual mm mp3 mpeg2enc mpeg2dec \
musepack nas neon ogg pango pulse python sdl shout2 sidplay \
- sndfile spc speex swfdec theora ugly vorbis wavpack x264 xvid
+ sndfile spc soundtouch soup speex swfdec taglib \
+ theora vorbis wavpack x264 xvid
# other plugins
-OTHER_GSTREAMER_PLUGINS+= core yes ${_USE_GSTREAMER10_ALL} fluendo-mp3 mad
+OTHER_GSTREAMER_PLUGINS+=bad good ugly core yes ${_USE_GSTREAMER10_ALL} fluendo-mp3 mad
_USE_GSTREAMER_ALL+= ${OTHER_GSTREAMER_PLUGINS}
@@ -112,6 +113,11 @@ mad_DEPENDS= audio/gstreamer-plugins-mad
mikmod_DEPENDS= audio/gstreamer-plugins-mikmod
+mm_DEPENDS= multimedia/gstreamermm
+mm_GST_PREFIX= gstreamer
+mm_GST_SUFX= # empty
+mm_GST_VERSION= 0.9.4
+
mp3_DEPENDS= audio/gstreamer-plugins-mp3
musepack_DEPENDS= audio/gstreamer-plugins-musepack
@@ -139,19 +145,27 @@ smoothwave_DEPENDS= audio/gstreamer-plugins-smoothwave
sndfile_DEPENDS= audio/gstreamer-plugins-sndfile
+soundtouch_DEPENDS= audio/gstreamer-plugins-soundtouch
+
spc_DEPENDS= audio/gstreamer-plugins-spc
speex_DEPENDS= audio/gstreamer-plugins-speex
+taglib_DEPENDS= audio/gstreamer-plugins-taglib
+
vorbis_DEPENDS= audio/gstreamer-plugins-vorbis
wavpack_DEPENDS= audio/gstreamer-plugins-wavpack
# Devel Plugins Section
+gio_DEPENDS= devel/gstreamer-plugins-gio
+
gnomevfs_DEPENDS= devel/gstreamer-plugins-gnomevfs
sdl_DEPENDS= devel/gstreamer-plugins-sdl
+soup_DEPENDS= devel/gstreamer-plugins-soup
+
# Graphics Plugins Section
aalib_DEPENDS= graphics/gstreamer-plugins-aalib