aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.kde4.mk
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-08-04 21:14:07 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-08-04 21:14:07 +0000
commit84daec6f093d3d7d53a50edf53ce7943b9621bb1 (patch)
tree043b1cfb262179f2ec700f10588786db42f9c61d /Mk/bsd.kde4.mk
parent8faa3d596e83b24604219d48c4c6ddb772530ae7 (diff)
downloadports-84daec6f093d3d7d53a50edf53ce7943b9621bb1.tar.gz
ports-84daec6f093d3d7d53a50edf53ce7943b9621bb1.zip
The KDE FreeBSD team is proud to announce the release of KDE 4.3.0
for FreeBSD. The official KDE 4.3.0 (Codename: "Caizen") release notes can be found at: http://kde.org/announcements/4.3/index.php. We'd like to say thanks to all helpers and submitters. Tested by: pointyhat-exp-run (pav/miwi)
Notes
Notes: svn path=/head/; revision=238903
Diffstat (limited to 'Mk/bsd.kde4.mk')
-rw-r--r--Mk/bsd.kde4.mk13
1 files changed, 11 insertions, 2 deletions
diff --git a/Mk/bsd.kde4.mk b/Mk/bsd.kde4.mk
index bcc4defa084e..d71360a67e03 100644
--- a/Mk/bsd.kde4.mk
+++ b/Mk/bsd.kde4.mk
@@ -34,9 +34,12 @@ Kde_Include_MAINTAINER= kde@FreeBSD.org
# kdelibs - The base set of KDE4 libraries
# kdeprefix - If set, port will be installed into ${KDE4_PREFIX} instead of ${LOCALBASE}
# pimlibs - KDE4 PIM libraries
+# pimruntime - KDE4 PIM runtime services
# runtime - More KDE applications
# sharedmime - share-mime-info wrapper for KDE4 ports
# workspace - More KDE applications (Plasma, kwin, etc.)
+# kdeexp - experimental libraries (with non-stable ABI/API)
+# oxygen - icon themes
#
# These read-only variables can be used in port Makefile:
#
@@ -49,7 +52,7 @@ Kde_Include_MAINTAINER= kde@FreeBSD.org
# but this could be changed in a future.
#
-KDE4_VERSION= 4.2.4
+KDE4_VERSION= 4.3.0
KDE4_BRANCH?= stable
#
@@ -72,7 +75,7 @@ MASTER_SITE_KDE_kde= ${kmaster:S@%SUBDIR%/@${ksub}/@g}
# KDE4 modules
#
_USE_KDE4_ALL= akonadi automoc4 kdebase kdehier kdelibs kdeprefix \
- pimlibs runtime sharedmime workspace
+ pimlibs pimruntime runtime sharedmime workspace kdeexp oxygen
akonadi_LIB_DEPENDS= akonadiprotocolinternals.1:${PORTSDIR}/databases/akonadi
@@ -88,6 +91,8 @@ kdeprefix_PREFIX= ${KDE4_PREFIX}
pimlibs_LIB_DEPENDS= kpimutils.5:${PORTSDIR}/deskutils/kdepimlibs4
+pimruntime_LIB_DEPENDS= kdepim-copy.5:${PORTSDIR}/deskutils/kdepim4-runtime
+
runtime_BUILD_DEPENDS= ${KDE4_PREFIX}/bin/kdebugdialog:${PORTSDIR}/x11/kdebase4-runtime
runtime_RUN_DEPENDS= ${KDE4_PREFIX}/bin/kdebugdialog:${PORTSDIR}/x11/kdebase4-runtime
@@ -96,6 +101,10 @@ sharedmime_RUN_DEPENDS= kde4-shared-mime-info>=1:${PORTSDIR}/misc/kde4-shared-m
workspace_LIB_DEPENDS= kscreensaver.5:${PORTSDIR}/x11/kdebase4-workspace
+kdeexp_LIB_DEPENDS= knotificationitem-1.1:${PORTSDIR}/x11/kdelibs4-experimental
+
+oxygen_RUN_DEPENDS= ${KDE4_PREFIX}/share/icons/oxygen/index.theme:${PORTSDIR}/x11-themes/kde4-icons-oxygen
+
#
# Common build related stuff for kde4 ports. It's not intended for usage
# in KDE4-dependent ports