aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.options.mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-06-07 08:06:17 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-06-07 08:06:17 +0000
commita639e24276e6184dce2469848b11e8269983a622 (patch)
treeb061ecc4d58ddf4303c6b44ce13d75a2f7c01167 /Mk/bsd.options.mk
parent19677862999fb1a007b2cc479aab5843ab72f516 (diff)
downloadports-a639e24276e6184dce2469848b11e8269983a622.tar.gz
ports-a639e24276e6184dce2469848b11e8269983a622.zip
Do not automatically popup dialog in case only options from global options are defined
Requested by: many
Notes
Notes: svn path=/head/; revision=320177
Diffstat (limited to 'Mk/bsd.options.mk')
-rw-r--r--Mk/bsd.options.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index 693c8c7c9e10..dfe42536f913 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -54,6 +54,8 @@ OPTIONSFILE?= ${PORT_DBDIR}/${UNIQUENAME}/options
#ALL_OPTIONS= DOCS \
# NLS
+GLOBAL_OPTIONS= DOCS NLS EXAMPLES IPV6
+
# Set the default values for the global options, as defined by portmgr
.if !defined(NOPORTDOCS)
PORT_OPTIONS+= DOCS
@@ -315,3 +317,8 @@ WITH_${opt}:= true
.endfor
.endif
###
+
+_OPTIONS_WITHOUT_GLOBALS:= ${COMPLETE_OPTIONS_LIST}
+.for opt in ${GLOBAL_OPTIONS}
+_OPTIONS_WITHOUT_GLOBALS:= ${_OPTIONS_WITHOUT_GLOBALS:N${opt}}
+.endfor