aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.options.mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-06-10 08:22:34 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-06-10 08:22:34 +0000
commitdfcbb8d250641f9e3d8ddca9d35115160baba322 (patch)
treecbbf1a3368893469623a3ebc39cfd48e4d718d02 /Mk/bsd.options.mk
parent4f36e076262c3b78587f31e86cc460d2b0640180 (diff)
downloadports-dfcbb8d250641f9e3d8ddca9d35115160baba322.tar.gz
ports-dfcbb8d250641f9e3d8ddca9d35115160baba322.zip
This should not have been in either
Notes
Notes: svn path=/head/; revision=320444
Diffstat (limited to 'Mk/bsd.options.mk')
-rw-r--r--Mk/bsd.options.mk27
1 files changed, 0 insertions, 27 deletions
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index 07871c3697c0..9e2fabad02c4 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -49,9 +49,7 @@
.if !defined(OPTIONSMKINCLUDED)
OPTIONSMKINCLUDED= bsd.options.mk
-OPTIONS_NAME?= ${PKGORIGIN:S/\//_/}
OPTIONSFILE?= ${PORT_DBDIR}/${UNIQUENAME}/options
-OPTIONS_FILE?= ${PORT_DBDIR}/${OPTIONS_NAME}/options
#ALL_OPTIONS= DOCS \
# NLS
@@ -178,7 +176,6 @@ PORT_OPTIONS:= ${PORT_OPTIONS:O:u}
PORT_OPTIONS:= ${PORT_OPTIONS:N${opt}}
. endfor
-# XXX To remove once UNIQUENAME will be removed
## Set the options specified per-port (set by user in make.conf)
. for opt in ${${UNIQUENAME}_SET}
. if !empty(COMPLETE_OPTIONS_LIST:M${opt})
@@ -191,22 +188,7 @@ PORT_OPTIONS:= ${PORT_OPTIONS:O:u}
. for opt in ${${UNIQUENAME}_UNSET}
PORT_OPTIONS:= ${PORT_OPTIONS:N${opt}}
. endfor
-# XXX To remove once UNIQUENAME will be removed
-## Set the options specified per-port (set by user in make.conf)
-. for opt in ${${OPTIONS_NAME}_SET}
-. if !empty(COMPLETE_OPTIONS_LIST:M${opt})
-PORT_OPTIONS+= ${opt}
-. endif
-. endfor
-PORT_OPTIONS:= ${PORT_OPTIONS:O:u}
-
-## Unset the options excluded per-port (set by user in make.conf)
-. for opt in ${${OPTIONS_NAME}_UNSET}
-PORT_OPTIONS:= ${PORT_OPTIONS:N${opt}}
-. endfor
-
-# XXX to remove once UNIQUENAME is removed
## options files (from dialog)
. if exists(${OPTIONSFILE}) && !make(rmconfig)
. include "${OPTIONSFILE}"
@@ -214,15 +196,6 @@ PORT_OPTIONS:= ${PORT_OPTIONS:N${opt}}
. if exists(${OPTIONSFILE}.local)
. include "${OPTIONSFILE}.local"
. endif
-# XXX to remove once UNIQUENAME is removed
-
-## options files (from dialog)
-. if exists(${OPTIONS_FILE}) && !make(rmconfig)
-. include "${OPTIONS_FILE}"
-. endif
-. if exists(${OPTIONS_FILE}.local)
-. include "${OPTIONS_FILE}.local"
-. endif
### convert WITH and WITHOUT found in make.conf or reloaded from old optionsfile
.for opt in ${ALL_OPTIONS}