aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2018-01-04 19:18:48 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2018-01-04 19:18:48 +0000
commit0f12fc7d3275696bf8e6d28bfc1384770f213a49 (patch)
tree6070a9cc8abbecc79fac0f8f3a2868b0765def4e /Mk/bsd.port.mk
parentc622191024acfa9cd925423c4f9183a00d58e489 (diff)
downloadports-0f12fc7d3275696bf8e6d28bfc1384770f213a49.tar.gz
ports-0f12fc7d3275696bf8e6d28bfc1384770f213a49.zip
Stop truncating .MAKEOVERRIDES after the FLAVORS work.
There is no such variable as ${MAKEOVERRIDES}, only ${.MAKEOVERRIDES}, so this code was simply truncating .MAKEOVERRIDES entirely which could cause performance and other odd issues with OSREL and make recursion. We don't want to leak FLAVOR to child sub-makes but that can be fixed later; this code was not doing what it intended. Approved by: portmgr (implicit) MFH: 2018Q1
Notes
Notes: svn path=/head/; revision=458048
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk3
1 files changed, 0 insertions, 3 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 6ad80888a9da..f9070030e8d3 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1081,9 +1081,6 @@ _PORTS_DIRECTORIES+= ${PKG_DBDIR} ${PREFIX} ${WRKDIR} ${EXTRACT_WRKDIR} \
.include "${PORTSDIR}/Mk/bsd.commands.mk"
-# Do not leak flavors to childs make
-.MAKEOVERRIDES:= ${MAKEOVERRIDES:NFLAVOR=*}
-
.if !empty(FLAVOR) && !defined(_DID_FLAVORS_HELPERS)
_DID_FLAVORS_HELPERS= yes
_FLAVOR_HELPERS_OVERRIDE= DESCR PLIST PKGNAMEPREFIX PKGNAMESUFFIX