aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2007-09-13 22:10:33 +0000
committerMark Linimon <linimon@FreeBSD.org>2007-09-13 22:10:33 +0000
commit43b5db1e289fc66c750c7bde928537e273ca7eb1 (patch)
tree49a869eedb5259ea3c23d9cfd0c9ecb71f94c031 /Mk/bsd.port.mk
parent58b87661cde113f8460233f17eacbbeff95262c7 (diff)
downloadports-43b5db1e289fc66c750c7bde928537e273ca7eb1.tar.gz
ports-43b5db1e289fc66c750c7bde928537e273ca7eb1.zip
Restore the semantics of USE_PERL and friends by moving them back to
the 'post' block from which they originally came. This should fix the remaining few package build errors because of conditional perl inclusion. Pointy hat: linimon
Notes
Notes: svn path=/head/; revision=199447
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk12
1 files changed, 7 insertions, 5 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index ab08c18fe18b..5d0020c1a2b8 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1422,11 +1422,6 @@ SITE_PERL?= ${LOCALBASE}/${SITE_PERL_REL}
PERL5= ${LOCALBASE}/bin/perl${PERL_VERSION}
PERL= ${LOCALBASE}/bin/perl
-PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
- PERL_VER=${PERL_VER} \
- PERL_ARCH=${PERL_ARCH} \
- SITE_PERL=${SITE_PERL_REL}
-
.endif # !defined(_PERL_REFACTORING_COMPLETE)
.if defined(USE_LOCAL_MK)
@@ -1936,6 +1931,13 @@ RUN_DEPENDS+= ${_GL_${_component}_RUN_DEPENDS}
BUILD_DEPENDS+= bison:${PORTSDIR}/devel/bison
.endif
+.if !defined(_PERL_REFACTORING_COMPLETE)
+PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
+ PERL_VER=${PERL_VER} \
+ PERL_ARCH=${PERL_ARCH} \
+ SITE_PERL=${SITE_PERL_REL}
+.endif # !defined(_PERL_REFACTORING_COMPLETE)
+
.if defined(USE_LOCAL_MK)
.include "${PORTSDIR}/Mk/bsd.local.mk"
.endif