aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1997-01-12 12:37:48 +0000
committerSatoshi Asami <asami@FreeBSD.org>1997-01-12 12:37:48 +0000
commit8078abcbdf7608f7f3334d7485279410b26cb7d4 (patch)
treef4ab5c15d4166071b23c5789dc76ccdda1756322 /Mk/bsd.port.mk
parent74945d467bfa4d14d98e5864e1164583683015ab (diff)
downloadports-8078abcbdf7608f7f3334d7485279410b26cb7d4.tar.gz
ports-8078abcbdf7608f7f3334d7485279410b26cb7d4.zip
Add OpenBSD support. Change some comments to reflect the fact. Also:
(1) Change commented out MAINTAINER to FreeBSD_MAINTAINER and OpenBSD_MAINTAINER. These are not comments anymore, so we may even use it in the future. (2) Instead of the ".if ${OPSYS} = "NetBSD" hack, use ".if exists()" to find the location of md5 an tar. Play similar trick for fetch (OpenBSD uses /usr/bin/ftp which groks http: addresses). This commit includes most of the changes made in 1.242 (although many of them are done differently after more discussion). One thing that is conspicuously missing is NOMANCOMPRESS, which has been postponed until Warner figures out what exactly the situation is on the OpenBSD ports paradigm. (In a nutshell, we can't just define NOMANCOMPRESS in this file even if uncompressed manpages is the default for OpenBSD, because that will take away the ability of individual users to select manpage compression.) Reviewed by: imp@openbsd.org
Notes
Notes: svn path=/head/; revision=5321
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk31
1 files changed, 22 insertions, 9 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index e39ab518cac6..9f2af612692b 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -6,19 +6,20 @@
# bsd.port.mk - 940820 Jordan K. Hubbard.
# This file is in the public domain.
#
-# $Id: bsd.port.mk,v 1.244 1997/01/10 21:02:27 wosch Exp $
+# $Id: bsd.port.mk,v 1.245 1997/01/12 11:48:26 asami Exp $
#
# Please view me with 4 column tabs!
# This is for this file, not for the ports that includes it, so it's
-# commented out -- the person to contact if you have questions/
+# not called MAINTAINER -- the person to contact if you have questions/
# suggestions about bsd.port.mk.
#
# If you are not him, you are not allowed to commit to this file without
# his permission. :)
#
-# MAINTAINER= asami@FreeBSD.ORG
-#
+
+FreeBSD_MAINTAINER= asami@FreeBSD.ORG
+OpenBSD_MAINTAINER= imp@OpenBSD.ORG
# Supported Variables and their behaviors:
#
@@ -26,10 +27,10 @@
#
# OPSYS - Portability clause. This is the operating system the
# makefile is being used on. Automatically set to
-# "FreeBSD" or "NetBSD" as appropriate.
+# "FreeBSD," "NetBSD," or "OpenBSD" as appropriate.
# PORTSDIR - The root of the ports tree. Defaults:
-# FreeBSD: /usr/ports
-# NetBSD: /usr/opt
+# FreeBSD/OpenBSD: /usr/ports
+# NetBSD: /usr/opt
# DISTDIR - Where to get gzip'd, tarballed copies of original sources
# (default: ${PORTSDIR}/distfiles).
# PREFIX - Where to install things in general (default: /usr/local).
@@ -323,10 +324,14 @@ DO_NADA?= /usr/bin/true
# Miscellaneous overridable commands:
GMAKE?= gmake
XMKMF?= xmkmf -a
-.if (${OPSYS} == "NetBSD")
+.if exists(/sbin/md5)
+MD5?= /sbin/md5
+.elif exists(/bin/md5)
+MD5?= /bin/md5
+.elif exists(/usr/bin/md5)
MD5?= /usr/bin/md5
.else
-MD5?= /sbin/md5
+MD5?= md5
.endif
MD5_FILE?= ${FILESDIR}/md5
@@ -334,7 +339,11 @@ MAKE_FLAGS?= -f
MAKEFILE?= Makefile
MAKE_ENV+= PREFIX=${PREFIX} LOCALBASE=${LOCALBASE} X11BASE=${X11BASE} MOTIFLIB="${MOTIFLIB}" CFLAGS="${CFLAGS}"
+.if exists(/usr/bin/fetch)
FETCH_CMD?= /usr/bin/fetch
+.else
+FETCH_CMD?= /usr/bin/ftp
+.endif
TOUCH?= /usr/bin/touch
TOUCH_FLAGS?= -f
@@ -361,7 +370,11 @@ PATCH_ARGS+= -C
PATCH_DIST_ARGS+= -C
.endif
+.if exists(/bin/tar)
+EXTRACT_CMD?= /bin/tar
+.else
EXTRACT_CMD?= /usr/bin/tar
+.endif
EXTRACT_SUFX?= .tar.gz
# Backwards compatability.
.if defined(EXTRACT_ARGS)