aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-06-28 11:51:05 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-06-28 11:51:05 +0000
commit932db7c46c9a269808dfa67ea02746b350c194d8 (patch)
tree5182ef394eeef9bff78abf27f4a3a05f7fb8ff43 /Mk/bsd.port.mk
parentb9b5e71f19dfde1a969d42e0660cc786432b3500 (diff)
downloadports-932db7c46c9a269808dfa67ea02746b350c194d8.tar.gz
ports-932db7c46c9a269808dfa67ea02746b350c194d8.zip
New USES imake to handle the dependency on imake.
This uses accept 'env' as an argument for ports that do use their own or a different do-configure target. Modify xmkmf so it accept IMAKECPPFLAGS as default flags for imake and pass it to the called imake. Modify xorg-cf-files (the FreeBSD.cf configuration file) to allow CppCmd to be overwritten. Pass CppCmd CcCmd and CplusplusCmd via command line to each call of imake via IMAKECPPFLAGS Pass IMAKE_DEFINE with the above arguments to MAKE_ARGS so that imake spawned from Makefile generated by a previous imake also inherit the defined CppCmd CcCmd and CplusplusCmd. Make imake use devel/tradcpp all the time, so that when buidling with clang we do not depend on gcc's cpp. Make imake respect CC and CXX Make imake respect USE_GCC (if set imake will use gcc's cpp). While here: - Remove a couple of indefinite articles from comments - Trim headers - Fix a couple of ports to build with clang or use: USE_GCC=any - Fix a now useless redefinition of the extraction chain - Fix a typo in japanese/Wnn7-lib bundled imake template definitions - Fix some XMKMF execution with no env specified - Use options helper in x11/xautolock to simplify the port
Notes
Notes: svn path=/head/; revision=321957
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk28
1 files changed, 1 insertions, 27 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 53145e3a7e5b..a4d12245fd28 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1623,11 +1623,7 @@ check-makevars::
.endif
.endif
-.if defined(USE_IMAKE) && !defined(NO_INSTALL_MANPAGES)
-MANCOMPRESSED?= yes
-.else
MANCOMPRESSED?= no
-.endif
.if defined(PATCHFILES)
.if ${PATCHFILES:M*.zip}x != x
@@ -1908,7 +1904,6 @@ LIB_DEPENDS+= Xm.4:${PORTSDIR}/x11-toolkits/open-motif
.endif
.endif
-X_IMAKE_PORT= ${PORTSDIR}/devel/imake
X_FONTSERVER_PORT= ${PORTSDIR}/x11-fonts/xfs
X_VFBSERVER_PORT= ${PORTSDIR}/x11-servers/xorg-vfbserver
X_FONTS_ENCODINGS_PORT= ${PORTSDIR}/x11-fonts/encodings
@@ -1920,19 +1915,6 @@ X_FONTS_TTF_PORT= ${PORTSDIR}/x11-fonts/xorg-fonts-truetype
X_FONTS_TYPE1_PORT= ${PORTSDIR}/x11-fonts/xorg-fonts-type1
X_FONTS_ALIAS_PORT= ${PORTSDIR}/x11-fonts/font-alias
-.if defined(USE_IMAKE)
-.if (${OSVERSION} >= 900506 && ${OSVERSION} < 1000000) || \
- ${OSVERSION} >= 1000010
-CONFIGURE_ENV+= IMAKECPP="gcpp"
-MAKE_ENV+= IMAKECPP="gcpp"
-.else
-CONFIGURE_ENV+= IMAKECPP="${CPP}"
-MAKE_ENV+= IMAKECPP="${CPP}"
-.endif
-MAKE_FLAGS?= CC="${CC}" CXX="${CXX}"
-BUILD_DEPENDS+= imake:${X_IMAKE_PORT}
-.endif
-
.if defined(USE_DISPLAY) && !defined(DISPLAY)
BUILD_DEPENDS+= Xvfb:${X_VFBSERVER_PORT} \
${LOCALBASE}/lib/X11/fonts/misc/8x13O.pcf.gz:${X_FONTS_MISC_PORT} \
@@ -2423,6 +2405,7 @@ MOTIFLIB?= -L${LOCALBASE}/lib -lXm -lXp
ALL_TARGET?= all
INSTALL_TARGET?= install
+INSTALL_TARGET+= ${LATE_INSTALL_ARGS}
# Integrate with the license auditing framework
.if !defined (DISABLE_LICENSES)
@@ -3716,9 +3699,6 @@ do-configure:
${FALSE}; \
fi)
.endif
-.if defined(USE_IMAKE)
- @(cd ${CONFIGURE_WRKSRC}; ${SETENV} ${MAKE_ENV} ${XMKMF})
-.endif
.endif
# Build
@@ -3864,14 +3844,8 @@ check-install-conflicts:
do-install:
.if defined(USE_GMAKE)
@(cd ${INSTALL_WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
-.if defined(USE_IMAKE) && !defined(NO_INSTALL_MANPAGES)
- @(cd ${INSTALL_WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} install.man)
-.endif
.else # !defined(USE_GMAKE)
@(cd ${INSTALL_WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
-.if defined(USE_IMAKE) && !defined(NO_INSTALL_MANPAGES)
- @(cd ${INSTALL_WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} install.man)
-.endif
.endif
.endif