aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.subdir.mk
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1998-10-30 08:28:02 +0000
committerSatoshi Asami <asami@FreeBSD.org>1998-10-30 08:28:02 +0000
commit584030d6044c02f451cb2ff96e3428e39c7d2c53 (patch)
treebde9a51a97aaafa7e72357dc7a8cac531bacf58d /Mk/bsd.port.subdir.mk
parentafbc2ba0b430b20365147c38909ab4c05894dcab (diff)
downloadports-584030d6044c02f451cb2ff96e3428e39c7d2c53.tar.gz
ports-584030d6044c02f451cb2ff96e3428e39c7d2c53.zip
(1) Add new variables LOOP_VAR and LOOP_OPTIONS to implement building several
packages from a single port. LOOP_VAR is the name of the variable and LOOP_OPTIONS is a space-separated list of values it should take. When these are set, the target "package-loop" will go through a clean and package loop for all the options. The "package-loop" target is defined as "package" when LOOP_VAR is not defined, so if you are in the business for building packages, you should use "package-loop" all the time. (This target is added to bsd.port.subdir.mk too.) Also, the "describe" target prints out multiple lines so that all options will go into the INDEX. (In other words, if you define these variables, INDEX is going to look real silly if you don't put ${${LOOP_VAR}} in PKGNAME.) Seconded by: obrien ("ANYTHING") (2) Turn off regexp support for LIB_DEPENDS. It is a fixed string of the form <NAME>.<VER> now. Tested by: several rounds of complete package builds (3) Check checksum even if NO_EXTRACT is defined. (4) Cosmetic fix for message in MANUAL_PACKAGE_BUILD case.
Notes
Notes: svn path=/head/; revision=14257
Diffstat (limited to 'Mk/bsd.port.subdir.mk')
-rw-r--r--Mk/bsd.port.subdir.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/Mk/bsd.port.subdir.mk b/Mk/bsd.port.subdir.mk
index 72a97b2df306..ba16c9e642a9 100644
--- a/Mk/bsd.port.subdir.mk
+++ b/Mk/bsd.port.subdir.mk
@@ -1,5 +1,5 @@
# from: @(#)bsd.subdir.mk 5.9 (Berkeley) 2/1/91
-# $Id: bsd.port.subdir.mk,v 1.23 1997/11/20 05:31:44 asami Exp $
+# $Id: bsd.port.subdir.mk,v 1.24 1998/08/26 23:46:13 asami Exp $
#
# The include file <bsd.port.subdir.mk> contains the default targets
# for building ports subdirectories.
@@ -29,7 +29,7 @@
#
# afterinstall, all, beforeinstall, build, checksum, clean,
# configure, deinstall, depend, describe, extract, fetch, fetch-list,
-# install, package, readmes, realinstall, reinstall, tags
+# install, package, package-loop, readmes, realinstall, reinstall, tags
#
@@ -78,7 +78,7 @@ ${SUBDIR}::
fi; \
${MAKE} all
-.for __target in all fetch fetch-list package extract configure \
+.for __target in all fetch fetch-list package package-loop extract configure \
build clean deinstall depend describe distclean \
reinstall tags checksum
.if !target(${__target})