aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.qt.mk
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-12-05 21:39:13 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-12-05 21:39:13 +0000
commitc502e77d8f318117c0982f8999f2e243e8ef511c (patch)
tree1cdac219e0557792052352f043f3a1fff1d5a55c /Mk/bsd.qt.mk
parent96cfbc524a71a80449456330c5b025805563eaa5 (diff)
downloadports-c502e77d8f318117c0982f8999f2e243e8ef511c.tar.gz
ports-c502e77d8f318117c0982f8999f2e243e8ef511c.zip
bsd.qt.mk: Move QT_NONSTANDARD check to the _POSTMKINCLUDED section.
Do it so that files in Mk/Uses can set it too. It is required by the upcoming Uses/pyqt.mk that we will land soon to support PyQt5. PR: 204975
Notes
Notes: svn path=/head/; revision=403081
Diffstat (limited to 'Mk/bsd.qt.mk')
-rw-r--r--Mk/bsd.qt.mk20
1 files changed, 10 insertions, 10 deletions
diff --git a/Mk/bsd.qt.mk b/Mk/bsd.qt.mk
index 8771b659623e..5f1fb4968955 100644
--- a/Mk/bsd.qt.mk
+++ b/Mk/bsd.qt.mk
@@ -208,16 +208,6 @@ PLIST_SUB+= SHORTVER=${_QT_VERSION:R} \
FULLVER=${_QT_VERSION:C/-.*//}
.endif # defined(QT_DIST)
-.if !defined(QT_NONSTANDARD)
-CONFIGURE_ENV+= QTDIR="${QT_PREFIX}" QMAKE="${QMAKE}" \
- MOC="${MOC}" RCC="${RCC}" UIC="${UIC}" \
- QMAKESPEC="${QMAKESPEC}"
-CONFIGURE_ARGS+=--with-qt-includes=${QT_INCDIR} \
- --with-qt-libraries=${QT_LIBDIR} \
- --with-extra-includes=${LOCALBASE}/include \
- --with-extra-libs=${LOCALBASE}/lib
-.endif # !defined(QT_NONSTANDARD)
-
.if ${_QT_VERSION:M4*}
QT_BINDIR_REL?= bin
QT_LIBDIR_REL?= lib/${_QT_RELNAME}
@@ -287,6 +277,16 @@ PLIST_SUB+= QT_${dir}DIR="${QT_${dir}DIR_REL}"
Qt_Post_Include= bsd.qt.mk
+.if !defined(QT_NONSTANDARD)
+CONFIGURE_ENV+= QTDIR="${QT_PREFIX}" QMAKE="${QMAKE}" \
+ MOC="${MOC}" RCC="${RCC}" UIC="${UIC}" \
+ QMAKESPEC="${QMAKESPEC}"
+CONFIGURE_ARGS+=--with-qt-includes=${QT_INCDIR} \
+ --with-qt-libraries=${QT_LIBDIR} \
+ --with-extra-includes=${LOCALBASE}/include \
+ --with-extra-libs=${LOCALBASE}/lib
+.endif # !defined(QT_NONSTANDARD)
+
_USE_QT_ALL= assistant clucene dbus declarative designer gui help \
imageformats linguist linguisttools multimedia network opengl pixeltool \
qdbusviewer qmake script scripttools sql sql-ibase sql-mysql \