aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.ruby.mk
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-09-16 11:37:37 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-09-16 11:37:37 +0000
commitf6b2a9ebe4803bc953fb473b1c14ec1a4ae8fcb2 (patch)
treecacc150922c364b5c5b7357a6d5f86adc47f2255 /Mk/bsd.ruby.mk
parenteb69c4212649174fc3a0cb22d3b0696ca3f71f6d (diff)
downloadports-f6b2a9ebe4803bc953fb473b1c14ec1a4ae8fcb2.tar.gz
ports-f6b2a9ebe4803bc953fb473b1c14ec1a4ae8fcb2.zip
Add RUBY_NO_BUILD_DEPENDS and RUBY_NO_RUN_DEPENDS knobs.
Prevent this file from being included twice.
Notes
Notes: svn path=/head/; revision=32689
Diffstat (limited to 'Mk/bsd.ruby.mk')
-rw-r--r--Mk/bsd.ruby.mk12
1 files changed, 11 insertions, 1 deletions
diff --git a/Mk/bsd.ruby.mk b/Mk/bsd.ruby.mk
index 7249475ae32c..92e6e791437d 100644
--- a/Mk/bsd.ruby.mk
+++ b/Mk/bsd.ruby.mk
@@ -6,6 +6,8 @@
# $FreeBSD$
#
+.if !defined(Ruby_Include)
+
Ruby_Include= bsd.ruby.mk
Ruby_Include_MAINTAINER= knu@FreeBSD.org
@@ -14,8 +16,10 @@ Ruby_Include_MAINTAINER= knu@FreeBSD.org
#
# RUBY_VER - Set to the alternative short version of ruby (see below for current value).
# USE_RUBY - Says that the port uses ruby for building and running.
+# RUBY_NO_BUILD_DEPENDS - Says that the port should not build-depend on ruby.
+# RUBY_NO_RUN_DEPENDS - Says that the port should not run-depend on ruby.
# USE_LIBRUBY - Says that the port uses libruby.
-# USE_RUBY_EXTCONF - Says that the port uses extconf.rb to configure.
+# USE_RUBY_EXTCONF - Says that the port uses extconf.rb to configure. Implies USE_RUBY.
# RUBY_EXTCONF - Set to the alternative name of extconf.rb (default: extconf.rb).
# RUBY_EXTCONF_SUBDIRS - Set to list of subdirectories, if multiple modules are included.
# USE_RUBY_SETUP - Says that the port uses setup.rb to configure and build. Implies USE_RUBY_AMSTD.
@@ -166,9 +170,13 @@ LIB_DEPENDS+= ${RUBY_LIB_DEPENDS}
.endif
.if defined(USE_RUBY)
+.if !defined(RUBY_NO_BUILD_DEPENDS)
BUILD_DEPENDS+= ${RUBY_DEPENDS}
+.endif
+.if !defined(RUBY_NO_RUN_DEPENDS)
RUN_DEPENDS+= ${RUBY_DEPENDS}
.endif
+.endif
.if defined(USE_RUBY_AMSTD)
BUILD_DEPENDS+= ${RUBY_AMSTD_DEPENDS}
@@ -178,3 +186,5 @@ RUN_DEPENDS+= ${RUBY_AMSTD_DEPENDS}
.if defined(USE_RUBY_RD) && !defined(NOPORTDOCS)
BUILD_DEPENDS+= ${RUBY_RD2_DEPENDS}
.endif
+
+.endif