aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-06-14 14:18:45 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-06-14 14:18:45 +0000
commit0e8027e93f594f3a79b382f66f5b1f6d62b66ed0 (patch)
tree1ef48c0e94d95a7770577426a65cc460480a1e80 /Mk
parentb876916186d4f89b320dee3f2c4397d41b75fe54 (diff)
downloadports-0e8027e93f594f3a79b382f66f5b1f6d62b66ed0.tar.gz
ports-0e8027e93f594f3a79b382f66f5b1f6d62b66ed0.zip
Add a forgotten helper:
${OPT}_CMAKE_ON and ${OPT}_CMAKE_OFF
Notes
Notes: svn path=/head/; revision=320926
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.options.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index 8f6d3666a8d1..562e0fe9392e 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -309,6 +309,9 @@ CONFIGURE_ARGS+= --enable-${${opt}_CONFIGURE_ENABLE}
. if defined(${opt}_CONFIGURE_ON)
CONFIGURE_ARGS+= ${${opt}_CONFIGURE_ON}
. endif
+. if defined(${opt}_CMAKE_ON)
+CMAKE_ARGS+= ${${opt}_CMAKE_ON}
+. endif
. for flags in CFLAGS CXXFLAGS LDFLAGS CONFIGURE_ENV MAKE_ENV USES DISTFILES
. if defined(${opt}_${flags})
${flags}+= ${${opt}_${flags}}
@@ -326,6 +329,9 @@ CONFIGURE_ARGS+= --disable-${${opt}_CONFIGURE_ENABLE}
. if defined(${opt}_CONFIGURE_OFF)
CONFIGURE_ARGS+= ${${opt}_CONFIGURE_OFF}
. endif
+. if defined(${opt}_CMAKE_OFF)
+CMAKE_ARGS+= ${${opt}_CMAKE_OFF}
+. endif
. endif
.endfor