aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2021-05-19 09:16:39 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2021-05-19 09:16:39 +0000
commit0fa7a283402615d5113a6e55328df7497a414139 (patch)
tree84632bf489ec12d29628d4563589520aed9a13e1 /Mk
parentf0c42a14102512e2a8ea60dbbe771e4ce22de011 (diff)
downloadports-0fa7a283402615d5113a6e55328df7497a414139.tar.gz
ports-0fa7a283402615d5113a6e55328df7497a414139.zip
ansible.mk: Fix ANSIBLE_RUN_DEPENDS
sysutils/ansible does not provide the Ansible program directly. It is provided by its dependencies (sysutils/py-ansible-core at the moment). Fix the ANSIBLE_RUN_DEPENDS so that it looks for the ansible package instead of the Ansible binary.
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/ansible.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/Uses/ansible.mk b/Mk/Uses/ansible.mk
index 9547df262540..30db2dc978de 100644
--- a/Mk/Uses/ansible.mk
+++ b/Mk/Uses/ansible.mk
@@ -60,7 +60,7 @@ _USES_POST+= python:env
ANSIBLE_CMD?= ${LOCALBASE}/bin/ansible
ANSIBLE_DOC_CMD?= ${LOCALBASE}/bin/ansible-doc
-ANSIBLE_RUN_DEPENDS?= ${ANSIBLE_CMD}:sysutils/ansible@${PY_FLAVOR}
+ANSIBLE_RUN_DEPENDS?= ${PYTHON_PKGNAMEPREFIX}ansible>0:sysutils/ansible@${PY_FLAVOR}
ANSIBLE_DATADIR?= ${PREFIX}/share/${PYTHON_PKGNAMEPREFIX}ansible
ANSIBLE_ETCDIR?= ${PREFIX}/etc/ansible