aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-10-27 17:35:52 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-10-27 17:35:52 +0000
commit166d24f12c74b34fc896d2b16bb1f35b2d0b3a10 (patch)
tree7d653909bfb3b1f7931645746755bd1841009127 /Mk
parent01c11adf03ff27624c2ac822889ce3185b2d271e (diff)
downloadports-166d24f12c74b34fc896d2b16bb1f35b2d0b3a10.tar.gz
ports-166d24f12c74b34fc896d2b16bb1f35b2d0b3a10.zip
- Use leading "-" to ignore exit status instead of trailing "|| ${TRUE}"
Suggested by: mat
Notes
Notes: svn path=/head/; revision=331787
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/perl5.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/Uses/perl5.mk b/Mk/Uses/perl5.mk
index 4b9da58b06b5..7c5740987d33 100644
--- a/Mk/Uses/perl5.mk
+++ b/Mk/Uses/perl5.mk
@@ -261,6 +261,6 @@ do-install:
post-stage::
# TODO: change to ${_USE_PERL5:Mconfigure} when M::B creates .packlist
.if ${USE_PERL5:Mconfigure} || ${USE_PERL5:Mmodbuildtiny}
- @([ -d ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto ] && ${FIND} ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto -name .packlist -exec ${SED} -i '' 's|^${STAGEDIR}||' '{}' \;) || ${TRUE}
+ -@[ -d ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto ] && ${FIND} ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto -name .packlist -exec ${SED} -i '' 's|^${STAGEDIR}||' '{}' \;
.endif
.endif # defined(_POSTMKINCLUDED)