aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorChristoph Moench-Tegeder <cmt@FreeBSD.org>2022-04-26 21:20:50 +0000
committerChristoph Moench-Tegeder <cmt@FreeBSD.org>2022-04-26 21:20:50 +0000
commit21791843fe99d04a53c4631aa3c917b3ede3a86e (patch)
treedd769be35dd8a2f04b2ee9286a5a0a1852744fc0 /Mk
parentb71a11deeb8bf5dfbdb57da76f2eb7aa4487703c (diff)
downloadports-21791843fe99d04a53c4631aa3c917b3ede3a86e.tar.gz
ports-21791843fe99d04a53c4631aa3c917b3ede3a86e.zip
Mk/bsd.gecko.gk: fix sndio logic
my previous attempt at handling both firefox >= 100 and firefox-esr/ thunderbird at 91.x suffered a thinko.
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.gecko.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index cee597e4e465..af3e496a05c5 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -270,15 +270,18 @@ MOZ_OPTIONS+= --disable-pulseaudio
. if ${PORT_OPTIONS:MSNDIO}
BUILD_DEPENDS+= ${LOCALBASE}/include/sndio.h:audio/sndio
-MOZ_OPTIONS+= --enable-sndio
. if ${MOZILLA_VER:R:R} < 100
post-patch-SNDIO-on:
@${REINPLACE_CMD} -e 's|OpenBSD|${OPSYS}|g' \
-e '/DISABLE_LIBSNDIO_DLOPEN/d' \
${MOZSRC}/media/libcubeb/src/moz.build
+. else
+MOZ_OPTIONS+= --enable-sndio
. endif
. else
+. if ${MOZILLA_VER:R:R} >= 100
MOZ_OPTIONS+= --disable-sndio
+. endif
. endif
. if ${PORT_OPTIONS:MDEBUG}