aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-12-08 20:03:07 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-12-08 20:03:07 +0000
commit47b26d9293f196d71c39ba4d82df23d179884405 (patch)
tree3984ac0366432e29f9e1ac47cbac9b18032f7c04 /Mk
parent96fd51619a1ebc0b215ab75ccc37ce7ab300ed8b (diff)
downloadports-47b26d9293f196d71c39ba4d82df23d179884405.tar.gz
ports-47b26d9293f196d71c39ba4d82df23d179884405.zip
Update Qt/PySide2 to 5.15.2 / PyQt to 5.15.1 / SIP to 5.4.0
This commit combines several updates. - Update Qt to 5.12.2 - Update PyQt to 5.15.1 - Since PySide 5.15.1 is broken with Qt 5.15.2, so PySide and Shiboken are also updated to 5.15.2. - Update sip to 5.4.0 SIP is a collection of tools to create Python bindings for C and C++ libraries and used by PyQt and wxPython. There are some changes with sip5 [1]: - python 3.5+ is required - sip drops support of old deprecated methods as sipdistutils & cie. - this version breaks also PyQt5 extension ABI. SIP files will be installed in ${PYTHON_SITELIBDIR}/PyQt${_PYQT_VERSION}/bindings - some ports will use the new pyqtbuilder package with the pyproject.toml setup. Instead if the project have a setup.py, you should use sip-build to build it. - if a port needs sip, it should also needs pysip. BTW, py-qt5-core requires pysip, so that should be enough for PyQt packages. List of ports impacted by this change. Most of the patches have been integrated or are in the process of being integrated upstream: - devel/libsavitar - graphics/py-python-poppler-qt5 - net-im/scudcloud - net/libarcus - print/py-frescobaldi - science/py-veusz - graphics/qgis and graphics/qgis-ltr - deskutils/calibre A special note regarding calibre. New versions require sip>=5, we update it to the latest version (thanks to madpilot@) science/scidavis will remove the PyQt binding soon and there is no patch planned, so we remove the python option (ok makc@) While here, convert some ports to USE_PYQT (cad/cura, cad/uranium, devel/eric6, ...) Thanks to tcberner and adridg! [1] https://www.riverbankcomputing.com/static/Docs/sip/ PR: 250853 Exp-run by: antoine
Notes
Notes: svn path=/head/; revision=557300
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/pyqt.mk35
-rw-r--r--Mk/Uses/qt.mk2
2 files changed, 20 insertions, 17 deletions
diff --git a/Mk/Uses/pyqt.mk b/Mk/Uses/pyqt.mk
index 3463944c435b..ae6a83c35599 100644
--- a/Mk/Uses/pyqt.mk
+++ b/Mk/Uses/pyqt.mk
@@ -53,28 +53,27 @@ PYQT_MAINTAINER= kde@FreeBSD.org
MASTER_SITE_RIVERBANK= https://www.riverbankcomputing.com/static/Downloads/%SUBDIR%/
-#MASTER_SITES_SIP= https://pypi.python.org/packages/source/s/sip/
-# https://www.riverbankcomputing.com/static/Downloads/sip/4.19.15/sip-4.19.15.tar.gz
-MASTER_SITES_SIP= RIVERBANK/sip/${PORTVERSION} \
- SF/pyqt/sip/sip-${PORTVERSION} \
- GENTOO
+MASTER_SITES_SIP= https://pypi.python.org/packages/source/s/sip/
MASTER_SITES_PYQT5= https://pypi.python.org/packages/source/P/PyQt5/
MASTER_SITES_PYQTSIP= https://pypi.python.org/packages/source/P/PyQt5-sip/
MASTER_SITES_PYQTCHART= https://pypi.python.org/packages/source/P/PyQtChart/
+MASTER_SITES_PYQTBUILDER= https://pypi.io/packages/source/P/PyQt-builder/
#https://www.riverbankcomputing.com/static/Downloads/QScintilla/2.11.4/QScintilla-2.11.4.tar.gz
MASTER_SITES_QSCI2= RIVERBANK/QScintilla/${PORTVERSION} \
SF/pyqt/QScintilla2/QScintilla-${PORTVERSION} \
GENTOO
-SIP_VERSION= 4.19.24
+SIP_VERSION= 5.4.0
QSCI2_VERSION= 2.11.5
-PYQT5_VERSION= 5.15.0
+PYQT5_VERSION= 5.15.1
PYQTSIP_VERSION= 12.8.0
+PYQTBUILDER_VERSION= 1.4.0
SIP_DISTNAME= sip-${SIP_VERSION}
PYQT5_DISTNAME= PyQt5-${PYQT5_VERSION}
PYQTSIP_DISTNAME= PyQt5_sip-${PYQTSIP_VERSION}
PYQTCHART_DISTNAME= PyQtChart-${PYQT_VERSION}
+PYQTBUILDER_DISTNAME= PyQt-builder-${PYQTBUILDER_VERSION}
PYQT5_DISTINFO_FILE= ${.CURDIR:H:H}/devel/${PYQT_RELNAME}/distinfo
QSCI2_DISTNAME= QScintilla-${QSCI2_VERSION}
PYQT5_LICENSE= GPLv3
@@ -109,8 +108,9 @@ _USE_PYQT_ALL= ${_USE_PYQT_COMMS} \
${_USE_PYQT_WWW} \
${_USE_PYQT_X11} \
${_USE_PYQT_X11-TOOLKITS}
-_USE_SIP_ALL= sip # pysip
+_USE_SIP_ALL= sip pysip
_USE_QSCINTILLA= qscintilla2
+_USE_PYQTBUILDER= qtbuilder
# Unversioned variables for the rest of the file
PYQT_VERSION= ${PYQT${_PYQT_VERSION}_VERSION}
@@ -123,8 +123,9 @@ PYQT_LICENSE= ${PYQT${_PYQT_VERSION}_LICENSE}
# PATH
py-sip_PATH= ${PYTHON_PKGNAMEPREFIX}sip>=${SIP_VERSION}
-# py-pysip_PATH= ${PYQT_PY_RELNAME}-sip>=${PYQTSIP_VERSION}
+py-pysip_PATH= ${PYQT_PY_RELNAME}-sip>=${PYQTSIP_VERSION}
py-qscintilla2_PATH= ${PYQT_PY_RELNAME}-qscintilla2>=${QSCI2_VERSION}
+py-qtbuilder_PATH= ${PYTHON_PKGNAMEPREFIX}qtbuilder>=${PYQTBUILDER_VERSION}
. for _component in ${_USE_PYQT_ALL}
py-${_component}_PATH?=${PYQT_PY_RELNAME}-${_component}>=${PYQT_VERSION}
@@ -132,7 +133,8 @@ py-${_component}_PATH?=${PYQT_PY_RELNAME}-${_component}>=${PYQT_VERSION}
# PORT
py-sip_PORT= devel/py-sip
-# py-pysip_PORT= devel/${PYQT_RELNAME}-sip
+py-qtbuilder_PORT= devel/py-qtbuilder
+py-pysip_PORT= devel/${PYQT_RELNAME}-sip
py-qscintilla2_PORT= devel/${PYQT_RELNAME}-qscintilla2
. for _categorie in comms databases devel graphics lang misc multimedia net print textproc www x11 x11-toolkits
@@ -179,29 +181,29 @@ py-xml_DESC= Python bindings for QtXml module
py-xmlpatterns_DESC= Python bindings for QtXmlPatterns module
# The versionned executable of sip
-SIP= ${LOCALBASE}/bin/sip-${PYTHON_VER}
+SIP= ${LOCALBASE}/bin/sip5-${PYTHON_VER}
# Relative directories
_VERSION_SUBDIR_REL= PyQt${_PYQT_VERSION}/${PYTHON_VER}
_APIDIR_REL= share/${_VERSION_SUBDIR_REL}/qsci
_DOCDIR_REL= share/doc/${_VERSION_SUBDIR_REL}
_EXAMPLEDIR_REL= share/examples/${_VERSION_SUBDIR_REL}
-_SIPDIR_REL= share/${_VERSION_SUBDIR_REL}/sip
+_SIPDIR_REL= PyQt${_PYQT_VERSION}/bindings
_DESIGNERDIR_REL= ${QT_PLUGINDIR_REL}/designer/${_VERSION_SUBDIR_REL}
_QMLDIR_REL= ${QT_QMLDIR_REL}/${_VERSION_SUBDIR_REL}
-# Absolute direcotries
+# Absolute directories
PYQT_APIDIR= ${PREFIX}/${_APIDIR_REL}
PYQT_DOCDIR= ${PREFIX}/${_DOCDIR_REL}
PYQT_EXAMPLEDIR= ${PREFIX}/${_EXAMPLEDIR_REL}
-PYQT_SIPDIR?= ${PREFIX}/${_SIPDIR_REL}
+PYQT_SIPDIR?= ${PYTHON_SITELIBDIR}/${_SIPDIR_REL}
PYQT_DESIGNERDIR= ${PREFIX}/${_DESIGNERDIR_REL}
PYQT_QMLDIR= ${PREFIX}/${_QMLDIR_REL}
PLIST_SUB+= PYQT_APIDIR=${_APIDIR_REL} \
PYQT_DOCDIR=${_DOCDIR_REL} \
PYQT_EXAMPLEDIR=${_EXAMPLEDIR_REL} \
- PYQT_SIPDIR=${_SIPDIR_REL} \
+ PYQT_SIPDIR=${PYQT_SIPDIR} \
PYQT_DESIGNERDIR=${_DESIGNERDIR_REL} \
PYQT_QMLDIR=${_QMLDIR_REL} \
PYQT_SIPVERSION=${SIP_VERSION} \
@@ -256,7 +258,8 @@ do-configure:
# Set build, run and test depends -- we need to prefix them internally with "py-"
# else we conflict with the ones defined in bsd.qt.mk with the same name
_USE_PYQT_ALL+= ${_USE_SIP_ALL} \
- ${_USE_QSCINTILLA}
+ ${_USE_QSCINTILLA} \
+ ${_USE_PYQTBUILDER}
. for comp in ${_USE_PYQT_ALL:O:u}
_USE_PYQT_ALL_SUFFIXED+= py-${comp} py-${comp}_build py-${comp}_run py-${comp}_test
py-${comp}_BUILD_DEPENDS?= ${py-${comp}_PATH}:${py-${comp}_PORT}@${PY_FLAVOR}
diff --git a/Mk/Uses/qt.mk b/Mk/Uses/qt.mk
index 1a0ac199df89..ae99c5d28baf 100644
--- a/Mk/Uses/qt.mk
+++ b/Mk/Uses/qt.mk
@@ -24,7 +24,7 @@ _QT_MK_INCLUDED= qt.mk
# Qt versions currently supported by the framework.
_QT_SUPPORTED?= 5
-QT5_VERSION?= 5.15.0
+QT5_VERSION?= 5.15.2
# We accept the Qt version to be passed by either or all of the three mk files.
. if empty(qt_ARGS) && empty(qmake_ARGS) && empty(qt-dist_ARGS)